Subject: Re: [ippm] New Version Notification for draft-brockners-opsawg-ioam-deployment-00.txt

From: Barak Gafni <[email-masked]>
Date: Wed, 6 Nov 2019 22:09:02 +0000

Dear authors,
Thanks for this contribution, it is highly appreciated!

I would like to suggest some further discussion on the below topics:
1. The distinction between "Endpoint active measurement" and "IOAM active measurement using probe packets", as well as the pointer to trace only.
2. IOAM layering - Although there is a good infrastructure laid out, I think that this topic need more details. Mostly, we need to discuss the definition of a layer, and whether an underlay can use a shim layer and consider ownership. For example, which layer an IOAM header belongs to when carried within Geneve, or over GRE in multiple cases.
3. IOAM trace types - I would like to suggest to consider the description of the distinction between hw and sw implementations, including pointing out suggested solutions that support both. 

I would be glad to further collaborate with you to discuss the above

Thanks,
Barak

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Frank Brockners (fbrockne)
Sent: Wednesday, October 30, 2019 9:23 AM
To: [email-masked]; [email-masked]
Subject: [ippm] FW: New Version Notification for draft-brockners-opsawg-ioam-deployment-00.txt

Several of you have indicated multiple times that it would really help, if we had an "IOAM deployment" draft that discusses the various deployment considerations for IOAM all in one place - and serves as a single entry point for IOAM, referencing in the different IOAM related drafts.

We finally arrived at creating an initial revision - and we greatly appreciate your thoughts and comments how to evolve this further.

Thanks much, Frank

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Mittwoch, 30. Oktober 2019 17:17
> To: Daniel Bernier <[email-masked]>; Frank Brockners 
> (fbrockne) <[email-masked]>; [email-masked] 
> <[email-masked]>; Shwetha Bhandari (shwethab) 
> <[email-masked]>
> Subject: New Version Notification for draft-brockners-opsawg-ioam- 
> deployment-00.txt
> 
> 
> A new version of I-D, draft-brockners-opsawg-ioam-deployment-00.txt
> has been successfully submitted by Frank Brockners and posted to the 
> IETF repository.
> 
> Name:		draft-brockners-opsawg-ioam-deployment
> Revision:	00
> Title:		In-situ OAM Deployment
> Document date:	2019-10-30
> Group:		Individual Submission
> Pages:		22
> URL:            https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-brockners-opsawg-ioam-&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=GV1T7klrsHwI%2FOqKoXL2Z9lbxruh2dV8EOzEyzHhydA%3D&amp;reserved=0
> deployment-00.txt
> Status:         https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-brockners-opsawg-ioam-&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=399M95HkEzGgwWJ%2FHAJyA8Q7kTp0rQ%2FOpzOhXHPrP%2FI%3D&amp;reserved=0
> deployment/
> Htmlized:       https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-brockners-opsawg-ioam-&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=re82N92s6JusTvrdRY8ZwlDpzrLD5BgJ9YvsbS0%2FhsY%3D&amp;reserved=0
> deployment-00
> Htmlized:       https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-brockners-opsawg-&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=NEvw5OYddqain1dwWWMYjR3e0T9feR3Sb46Re0UbnkU%3D&amp;reserved=0
> ioam-deployment
> 
> 
> Abstract:
>    In-situ Operations, Administration, and Maintenance (IOAM) records
>    operational and telemetry information in the packet while the packet
>    traverses a path between two points in the network.  This document
>    provides a framework for IOAM deployment and provides best current
>    practices.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=AoMzW1DY7vsIZ3UNpmptgv8cInxb9ucZRZMAjaW55uE%3D&amp;reserved=0

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Sat, 16 Nov 2019 15:32:06 +0000

Hi Barak,

> From: Barak Gafni <[email-masked]>
> Sent: Mittwoch, 6. November 2019 23:09
> To: Frank Brockners (fbrockne) <[email-masked]>; [email-masked];
> [email-masked]
> Subject: RE: New Version Notification for draft-brockners-opsawg-ioam-
> deployment-00.txt
> 
> Dear authors,
> 1. The distinction between "Endpoint active measurement" and "IOAM active
> measurement using probe packets", as well as the pointer to trace only.

...FB: Good topic to expand in the next rev. Interested in scribbling a short paragraph that we could add?

> 2. IOAM layering - Although there is a good infrastructure laid out, I think that
> this topic need more details. Mostly, we need to discuss the definition of a layer,
> and whether an underlay can use a shim layer and consider ownership. For
> example, which layer an IOAM header belongs to when carried within Geneve,
> or over GRE in multiple cases.

...FB: We can of course expand the section on layering as well - and your help would be appreciated. Given that this is a deployment draft, we'd want to focus on the implications/considerations that carrying IOAM in one or another layer would have. 

> 3. IOAM trace types - I would like to suggest to consider the description of the
> distinction between hw and sw implementations, including pointing out
> suggested solutions that support both.

...FB: HW/SW implementation and that fact that both Trace-Option-Types can be present in a packet is already stated in
https://tools.ietf.org/html/draft-brockners-opsawg-ioam-deployment-00#section-7.3
Could you detail what additional explanation would be required?

> I would be glad to further collaborate with you to discuss the above

...FB: That would be greatly appreciated.

Thanks, Frank

> Several of you have indicated multiple times that it would really help, if we had
> an "IOAM deployment" draft that discusses the various deployment
> considerations for IOAM all in one place - and serves as a single entry point for
> IOAM, referencing in the different IOAM related drafts.
> 
> We finally arrived at creating an initial revision - and we greatly appreciate your
> thoughts and comments how to evolve this further.
> 
> Thanks much, Frank
> 
> 
> > URL:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Finternet-drafts%2Fdraft-brockners-opsawg-ioam-
> &amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d9
> 08d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C63708
> 0494185344466&amp;sdata=GV1T7klrsHwI%2FOqKoXL2Z9lbxruh2dV8EOzEyzHh
> ydA%3D&amp;reserved=0
> > deployment-00.txt
> > Status:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrac
> ker.ietf.org%2Fdoc%2Fdraft-brockners-opsawg-ioam-
> &amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d9
> 08d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C63708
> 0494185344466&amp;sdata=399M95HkEzGgwWJ%2FHAJyA8Q7kTp0rQ%2FOpz
> OhXHPrP%2FI%3D&amp;reserved=0
> > deployment/
> > Htmlized:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf
> .org%2Fhtml%2Fdraft-brockners-opsawg-ioam-
> &amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d9
> 08d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C63708
> 0494185344466&amp;sdata=re82N92s6JusTvrdRY8ZwlDpzrLD5BgJ9YvsbS0%2Fh
> sY%3D&amp;reserved=0
> > deployment-00
> > Htmlized:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrac
> ker.ietf.org%2Fdoc%2Fhtml%2Fdraft-brockners-opsawg-
> &amp;data=02%7C01%7Cgbarak%40mellanox.com%7C9c5935d1525d448a68d9
> 08d75d55847b%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C63708
> 0494185344466&amp;sdata=NEvw5OYddqain1dwWWMYjR3e0T9feR3Sb46Re0
> UbnkU%3D&amp;reserved=0
> > ioam-deployment
> >
> >
> > Abstract:
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mella
> nox.com%7C9c5935d1525d448a68d908d75d55847b%7Ca652971c7d2e4d9ba6a
> 4d149256f461b%7C0%7C0%7C637080494185344466&amp;sdata=AoMzW1DY7
> vsIZ3UNpmptgv8cInxb9ucZRZMAjaW55uE%3D&amp;reserved=0