Subject: Re: [ippm] Adoption Call for draft-ioamteam-ippm-ioam-direct-export

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 3 Dec 2019 08:47:55 +0000

Hi,
I support the adoption of this draft.

I have one comment, the IANA section specify a registry for the IOAM DEX Flags. There are no initial values yet the draft mentions in the consideration section the loopback flag so is loopback supported by this draft?
What about the overflow flag?

Roni Even 

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell
> (IETF)
> Sent: Monday, November 18, 2019 5:46 AM
> To: IETF IPPM WG
> Subject: [ippm] Adoption Call for draft-ioamteam-ippm-ioam-direct-export
> 
> Greetings, all,
> 
> The IPPM working group has been asked to adopt draft-ioamteam-ippm-
> ioam-direct-export-00 as as a working group document.
> 
> This message begins an adoption call to end on Monday 9 December 2019.
> Please send a message to [email-masked] indicating:
> 
> - whether you believe the draft is in scope for the WG and mature enough to
> be a WG document, and if not, why not
> - whether you are willing to review the document
> 
> Many thanks, cheers,
> 
> Brian (as co-chair)
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 3 Dec 2019 14:36:07 +0200

Hi Roni,

The loopback flag is not relevant to the direct exporting option type. The
fact that loopback is mentioned in the draft is a copy+paste error, and
will be fixed in the next revision.
The overflow flag is relevant to the increment/preallocated trace options
(draft-ietf-ippm-ioam-data), and is not applicable to direct exporting;
since no data fields are present in the DEX option itself there is no need
for an overflow indication. The exported packet itself (which is not
defined in the DEX draft) will include the IOAM data, and possibly also the
overflow indication.

Thanks for the comments.

Cheers,
Tal.

On Tue, Dec 3, 2019 at 10:48 AM Roni Even (A) <[email-masked]> wrote:

> I have one comment, the IANA section specify a registry for the IOAM DEX
> Flags. There are no initial values yet the draft mentions in the
> consideration section the loopback flag so is loopback supported by this
> draft?

---

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 3 Dec 2019 12:59:09 +0000

Hi Tal,
Got it.

So what happens when the IOAM-Trace-Type in the DEX option is not a subset of the IOAM-Trace-Type in the trace option.

Also reading “IOAM nodes MAY send exported data for  all traversing packets that carry the DEX option, or MAY selectively  export data only for a subset of these packets.” Does it mean that DEX option should be sent with a trace option?

Roni

From: Tal Mizrahi [mailto:[email-masked]]
Sent: Tuesday, December 03, 2019 2:36 PM
To: Roni Even (A)
Cc: Brian Trammell (IETF); IETF IPPM WG
Subject: Re: [ippm] Adoption Call for draft-ioamteam-ippm-ioam-direct-export

Hi Roni,

The loopback flag is not relevant to the direct exporting option type. The fact that loopback is mentioned in the draft is a copy+paste error, and will be fixed in the next revision.
The overflow flag is relevant to the increment/preallocated trace options (draft-ietf-ippm-ioam-data), and is not applicable to direct exporting; since no data fields are present in the DEX option itself there is no need for an overflow indication. The exported packet itself (which is not defined in the DEX draft) will include the IOAM data, and possibly also the overflow indication.

Thanks for the comments.

Cheers,
Tal.

On Tue, Dec 3, 2019 at 10:48 AM Roni Even (A) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
I support the adoption of this draft.

Roni Even

> From: ippm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Trammell
> (IETF)
> Please send a message to [email-masked]<mailto:[email-masked]> indicating:
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm