Subject: [ippm] Éric Vyncke's Discuss on draft-ietf-ippm-initial-registry-14: (with DISCUSS and COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Tue, 03 Dec 2019 05:55:54 -0800

Éric Vyncke has entered the following ballot position for
draft-ietf-ippm-initial-registry-14: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ippm-initial-registry/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for the work put into this document.

I have a couple of easy and trivial to fix DISCUSS. And a couple of COMMENTs,
feel free to ignore the COMMENTs but I would appreciate it if you replied to
them.

Regards,

-éric

== DISCUSS ==

-- Section 4.2.2 --
Easy to fix: there is no 'protocol' field in the IPv6 header but a 'next
header' one that has the same semantic.

-- Section 9.2.2. --
Also easy to fix, 'next header' for ICMPv6 is not 01 but 58 (decimal) and
'ICMPv6 echo request' is 128 (decimal).

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

== COMMENTS ==

-- Section 4.2.2 -- and others

Should some additional parameters be specified for IPv6? Namely flow label and
the absence of extension header.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 3 Dec 2019 16:23:06 +0000

Hi éric,

Please see replies to your DISCUSS and comments below,
and Thanks for your review/catches in a large memo!

Al

> -----Original Message-----
> From: Éric Vyncke via Datatracker [mailto:[email-masked]]
> Sent: Tuesday, December 3, 2019 8:56 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Brian Trammell
> <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
> Subject: Éric Vyncke's Discuss on draft-ietf-ippm-initial-registry-14:
> (with DISCUSS and COMMENT)
> 
> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwIDaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=_F03j_j1jxXV5oiClX3bcmg9H_8AD
> 9ZTvAqE7ZTYyNk&s=6S8oGWjSmZ4OaXe_xcHMugRaNvTb9ttLlB53w0esJdo&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dinitial-
> 2Dregistry_&d=DwIDaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=_F03j_j1jxXV5oiClX3bcmg9H_8AD
> 9ZTvAqE7ZTYyNk&s=8tgnXZ1nYPNouDBlPHKRdkV3GlsjhmSNYUvglIaOLT8&e=
> 
> 
> 
[acm] 
Thanks, fixed in all similar sections.
> 'ICMPv6 echo request' is 128 (decimal).
[acm] 
Also fixed in the working version.
[acm] 
I agree, it's more complete to set nominal vales here.
I added Flow Label: set to zero and Extension Headers: none.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 3 Dec 2019 18:35:29 +0000

This was a fast reply ;-)

I am clearing my DISCUSS as the next revision will have the fixes

-éric

On 03/12/2019, 17:23, "iesg on behalf of MORTON, ALFRED C (AL)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi éric,

    Al
    
    [acm] 
    [acm] 
    [acm]