Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

From: Tommy Pauly <[email-masked]>
Date: Mon, 09 Dec 2019 12:18:07 -0800

Hello IPPM,

Continuing on in our list of Last Calls, we are now beginning the Working Group Last Call for draft-ietf-ippm-multipoint-alt-mark:

https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03

The Last Call will end on Monday, December 23. Please reply to [email-masked] with your reviews, and indicate whether or not you think this document is ready for publication.

Best,
Tommy (as co-chair)

---

From: Giuseppe Fioccola <[email-masked]>
Date: Tue, 10 Dec 2019 08:56:04 +0000

Dear Tommy, All,
I support this draft as an author and I think it is ready for publication.

Best Regards,

Giuseppe

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Monday, December 9, 2019 9:18 PM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

The Last Call will end on Monday, December 23. Please reply to [email-masked]<mailto:[email-masked]> with your reviews, and indicate whether or not you think this document is ready for publication.

Best,
Tommy (as co-chair)

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 10 Dec 2019 09:21:43 +0000

Hi Tommy and WG,

I've read this document and think it's mature and ready to be published.
Support.

Cheers,
Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Tuesday, December 10, 2019 4:18 AM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

Best,
Tommy (as co-chair)

---

From: Cociglio Mauro <[email-masked]>
Date: Tue, 10 Dec 2019 10:20:25 +0000

Hi All.
As co-author I support this draft.
In my opinion it is ready for publication.
Regards.
Mauro
_____________________
Mauro Cociglio
Telecom Italia-TIM
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

Da: ippm <[email-masked]> Per conto di Tommy Pauly
Inviato: lunedì 9 dicembre 2019 21:18
A: IETF IPPM WG <[email-masked]>
Oggetto: [EXT] [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

Best,
Tommy (as co-chair)

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Amedeo Sapio <[email-masked]>
Date: Tue, 10 Dec 2019 12:52:32 -0800

Dear all,
I support this draft as an author and think it is ready for publication.

Cheers,
---
Amedeo

On Tue, Dec 10, 2019 at 12:56 AM Giuseppe Fioccola <
[email-masked]> wrote:

> *From:* ippm [mailto:[email-masked]] *On Behalf Of *Tommy Pauly
> *Sent:* Monday, December 9, 2019 9:18 PM
> *To:* IETF IPPM WG <[email-masked]>
> *Subject:* [ippm] Working Group Last Call:
> draft-fioccola-ippm-multipoint-alt-mark
>
>
>
> Hello IPPM,
>
>
>
> Continuing on in our list of Last Calls, we are now beginning the Working
> Group Last Call for draft-ietf-ippm-multipoint-alt-mark:
>
>
>
> The Last Call will end on *Monday, December 23*. Please reply to
> [email-masked] with your reviews, and indicate whether or not you think
> this document is ready for publication.
>
>
>
> Best,
>
> Tommy (as co-chair)
>

---

From: "Bulgarella Fabio (Guest)" <[email-masked]>
Date: Tue, 10 Dec 2019 22:07:58 +0000

Hello Everybody,
I read this draft and I support its publication.

Best Regards,
Fabio B.

Il giorno 10 dic 2019, alle ore 21:53, Amedeo Sapio <[email-masked]> ha scritto:

Dear all,

Cheers,
---
Amedeo

On Tue, Dec 10, 2019 at 12:56 AM Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>> wrote:
Dear Tommy, All,
I support this draft as an author and I think it is ready for publication.

Best Regards,

Giuseppe

From: ippm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Tommy Pauly
Sent: Monday, December 9, 2019 9:18 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

The Last Call will end on Monday, December 23.. Please reply to [email-masked]<mailto:[email-masked]> with your reviews, and indicate whether or not you think this document is ready for publication.

Best,
Tommy (as co-chair)
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Riccardo Sisto <[email-masked]>
Date: Wed, 11 Dec 2019 10:31:20 +0100

Dear All,
I too support this draft as an author and I think it is ready for publication.
Best regards,

Riccardo

---

From: Tal Mizrahi <[email-masked]>
Date: Wed, 11 Dec 2019 16:28:43 +0200

I believe this draft is ready for publication.

Cheers,
Tal.

---

From: Mach Chen <[email-masked]>
Date: Thu, 12 Dec 2019 03:46:51 +0000

Hi Tommy,

I have the latest version of the document, and think it's ready for publication.

BTW, the email title seems not right :)

Best regards,
Mach

Hello IPPM,

Best,
Tommy (as co-chair)

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 22 Dec 2019 17:40:20 +0000

Hi IPPM,

I have reviewed the latest draft of multipoint-alt-mark,
as well as several earlier versions.

I believe the draft is ready for publication, with a few minor
comments below.

Al

          multipoint-to-point
              +------+
          ---<>  R1  <>
              +------+ \
                        \ +------+
                        <>  R4  <>
                        / +------+ \
              +------+ /            \ +------+
          ---<>  R2  <>              <>  R4  <>---
              +------+              / +------+
                          +------+ /
                         <>  R5  <>
                        / +------+
              +------+ /
          ---<>  R3  <>
              +------+

I'm fairly sure the Router on the far right is R6 (Figure 1).

Also the last sentence of Section 3 reads:
   While ECMP flow is in scope by definition, since it is a point-to-
   multipoint unicast flow.
There is an issue with two phrases beginning "While" and "since", maybe this
was meant, (plus the phrase in italics?):
   An ECMP flow is in scope by definition, since it is a point-to-
   multipoint unicast flow, _or/and a point-to-point multipath flow_?

Section 4.1

[I-D.amf-ippm-route<https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03#ref-I-D.amf-ippm-route>]  Reference out of date, please use WG version.

Section 5

   And in case of no packet loss occurring in the marking period, if all
   the input and output points of the network domain to be monitored are
   measurement points, the sum of the number of packets on all the
   ingress interfaces and on all the egress interfaces is the same.
Suggest
   And in case of no packet loss occurring in the marking period, if all
   the input and output points of the network domain to be monitored are
   measurement points, the sum of the number of packets on all the
   ingress interfaces _equals the number on egress interfaces for the _monitored_flow.
===========
   It is possible to define the Network Packet Loss (for 1 flow, for 1
   period): <<In a packet network, the number of lost packets is the
   number of packets counted by the input nodes minus the number of
   packets counted by the output nodes>>.
Suggest
   It is possible to define the Network Packet Loss (for 1 _monitored_flow, for 1
   period): <<In a packet network, the number of lost packets is the
   number of packets counted by the input nodes minus the number of
   packets counted by the output nodes>>.

Section 13

You can probably just say, "This memo makes no requests of IANA."

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Monday, December 9, 2019 3:18 PM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dmultipoint-2Dalt-2Dmark-2D03&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrcUHiENItugXyVC4F6KnN1f0LEcV3F68vitzlOk-04&s=87YJDmtGd8q5H4GpNd7l5SMz6f5lKU34xddFIRdI7jE&e=>

Best,
Tommy (as co-chair)

---

From: Giuseppe Fioccola <[email-masked]>
Date: Sun, 22 Dec 2019 22:34:18 +0000

Dear Al,
Thank you for the support and for the inputs.
Your suggestions are ok and I will address them in the new revision of the draft.

Regards,

Giuseppe

________________________________

Giuseppe Fioccola
Mobile: +49-15222812418<tel:<a%20href=>">15222812418<tel:15222812418>
Email: [email-masked]<mailto:<a%20href=>">[email-masked]<mailto:[email-masked]>

From: MORTON, ALFRED C (AL)<[email-masked]<mailto:[email-masked]>>
To: Tommy Pauly<tpauly=[email-masked]<mailto:tpauly=[email-masked]>>;IETF IPPM WG<[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark
Time: 2019-12-22 18:41:08

Hi IPPM,

Al

          multipoint-to-point
              +------+
          ---<>  R1  <>
              +------+ \
                        \ +------+
                        <>  R4  <>
                        / +------+ \
              +------+ /            \ +------+
          ---<>  R2  <>              <>  R4  <>---
              +------+              / +------+
                          +------+ /
                         <>  R5  <>
                        / +------+
              +------+ /
          ---<>  R3  <>
              +------+

I’m fairly sure the Router on the far right is R6 (Figure 1).

There is an issue with two phrases beginning “While” and “since”, maybe this

Section 4.1

Section 5

Section 13

You can probably just say, “This memo makes no requests of IANA.”

From: ippm [mailto:ippm-bounces@ietf..org] On Behalf Of Tommy Pauly
Sent: Monday, December 9, 2019 3:18 PM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

Best,
Tommy (as co-chair)

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 23 Dec 2019 11:33:59 -0800

Hello all,

Thanks for your inputs during the last call! We will progress the document to the IESG once we get a Document Shepherd write-up.

Authors, please post an update of the draft to include Al's comments when you can.

We also do need a Document Shepherd to create the write-up for this draft. If anyone in the group who is not an author on this document would like to be the document shepherd, please send an email to the chairs!

Best,
Tommy

> On Dec 22, 2019, at 2:34 PM, Giuseppe Fioccola <[email-masked]> wrote:
> 
> Dear Al,
> Mobile: +49-15222812418 <tel:<a href=>">15222812418 <tel:15222812418>  
> Email: [email-masked] <mailto:<a href=>">[email-masked] <mailto:[email-masked]>
> 
> 
> 
> From: MORTON, ALFRED C (AL)<[email-masked] <mailto:[email-masked]>>
> To: Tommy Pauly<tpauly=[email-masked] <mailto:tpauly=40apple.com@dmarc..ietf.org>>;IETF IPPM WG<[email-masked] <mailto:[email-masked]>>
>   <>
> [I-D.amf-ippm-route <https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03#ref-I-D.amf-ippm-route>]  Reference out of date, please use WG version.
>  
> Section 5
>  
> To: IETF IPPM WG <[email-masked] <mailto:[email-masked]>>
> https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dmultipoint-2Dalt-2Dmark-2D03&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrcUHiENItugXyVC4F6KnN1f0LEcV3F68vitzlOk-04&s=87YJDmtGd8q5H4GpNd7l5SMz6f5lKU34xddFIRdI7jE&e=>
>  
> The Last Call will end on Monday, December 23... Please reply to [email-masked] <mailto:[email-masked]> with your reviews, and indicate whether or not you think this document is ready for publication.
>  
> Best,
> Tommy (as co-chair)
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>