Subject: [ippm] PBT draft

From: Haoyu Song <[email-masked]>
Date: Mon, 16 Dec 2019 19:42:49 +0000

Hi IPPM chairs,

We have requested to present this draft for two times in past meetings but didn't get a chance due to the lack of time in WG sessions.
So I write this email to bring it to your attention.  We also like to raise more discussion in email list.

https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/
The draft is now in version 06.

It describes and compare two basic types of on-path telemetry techniques: postcard and passport.
It describes two subtypes of postcard techniques: instruction-based and marking-based. Both has its applications:

The instruction-based variation has been stripped out from the draft and now evolves to be a new IOAM option mode. The draft has been adopted by IPPM.
https://tools.ietf.org/html/draft-ioamteam-ippm-ioam-direct-export-00

The marking-based variation has inspired an implementation in SRv6 which was presented in 6MAN.
https://tools.ietf.org/html/draft-song-6man-srv6-pbt-01

We also presented in IPPM the work on using postcard or combining passport and postcard to support efficient multicast telemetry.
https://tools.ietf.org/html/draft-song-multicast-telemetry-01

We believe this informational draft introduces an important type of on-path telemetry technique.
The discussion on technique pros and cons can guide the corresponding  technique development, which is evidenced by the above examples.
Therefore, I request the working group to consider adoption of it as WG document.

Please let me know if you have any question about it. Thanks!

Best regards,
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 17 Dec 2019 01:48:41 +0000

I support the adoption of this document.

Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Tuesday, December 17, 2019 3:43 AM
To: IPPM Chairs <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: [ippm] PBT draft

Hi IPPM chairs,

Please let me know if you have any question about it.. Thanks!

Best regards,
Haoyu

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Mon, 23 Dec 2019 17:48:14 +0100

hi Haoyu,

> On 16 Dec 2019, at 20:42, Haoyu Song <[email-masked]> wrote:
> 
> Hi IPPM chairs,
>  
> We have requested to present this draft for two times in past meetings but didn’t get a chance due to the lack of time in WG sessions.

My review of the list discussion to date does not suggest a consensus emerging that a call for adoption should be issued at this time. However, we can place a ten-minute slot on the agenda in Vancouver to discuss this in person.

Cheers,

Brian (as IPPM chair)

---

From: Haoyu Song <[email-masked]>
Date: Mon, 23 Dec 2019 18:52:22 +0000

Hi Brian,

Thank you very much! A meeting discussion will be helpful.
Happy Holidays!

Haoyu  

-----Original Message-----
From: Brian Trammell (IETF) <[email-masked]> 
Sent: Monday, December 23, 2019 8:48 AM
To: Haoyu Song <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: PBT draft

hi Haoyu,

> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Ceffd63354e0249bc15dc08d787c7e9e7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637127165033425418&amp;sdata=CvjbnDxZYK0lEcAsCh7rgBRgQndmWyel8DWLh3yH32g%3D&amp;reserved=0
> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Ceffd63354e0249bc15dc08d787c7e9e7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637127165033425418&amp;sdata=WOrM%2F%2BBuecVkYYMbADYX2qyZ44ETuyF6UnOCOG%2B8%2BHo%3D&amp;reserved=0
>  
> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-6man-srv6-pbt-01&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Ceffd63354e0249bc15dc08d787c7e9e7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637127165033425418&amp;sdata=D0nSg85ZZBZAt3wXryy%2Fh1yyZ1s%2FOjiF4eVLeTiKQC0%3D&amp;reserved=0
>  
> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-multicast-telemetry-01&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Ceffd63354e0249bc15dc08d787c7e9e7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637127165033435413&amp;sdata=2vQY0VVnSOyOr%2FwSGYNJ0HRHuiEy6k%2Fg0iJaaY6qkjc%3D&amp;reserved=0
>  

Cheers,

Brian (as IPPM chair)