Subject: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-00.txt

From: [email-masked]
Date: Wed, 29 Jan 2020 16:49:37 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : Metrics and Methods for IP Capacity
        Authors         : Al Morton
                          Ruediger Geib
                          Len Ciavattone
	Filename        : draft-ietf-ippm-capacity-metric-method-00.txt
	Pages           : 20
	Date            : 2020-01-29

Abstract:
   This memo revisits the problem of Network Capacity metrics first
   examined in RFC 5136.  The memo specifies a more practical Maximum
   IP-layer Capacity metric definition catering for measurement
   purposes, and outlines the corresponding methods of measurement.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-capacity-metric-method/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-capacity-metric-method-00
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-capacity-metric-method-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 30 Jan 2020 15:14:11 +0000

Hi IPPM,

Thanks to everyone who supported adoption of our draft.
This version simply changes the filename.

At the IETF-106 Hackathon, we encountered some new conditions
in our testing with the prototype implementation:
https://github.com/IETF-Hackathon/ietf106-project-presentations/blob/master/106-acm-Hackathon-Measurements.pdf

Load Adjustment: 
Search Algorithm uses Loss and delay variation feedback

Observed:
Random loss throughout some tests, with insignificant delay variation

Possible revisions to Search Algorithm, etc. under these conditions:
	Add a variable Loss threshold for conditions encountered
	Continue "large" rate increases when loss-only is encountered
	May need longer test durations under Loss-only Conditions

We'd like to discuss these findings further with the WG, and run 
some more tests to answer questions and investigate further.

regards,
Al, for the co-authors

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Wednesday, January 29, 2020 7:50 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-00.txt
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-
> 2Dmethod_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=wr9y6v7T2pw1NXocsCDBLyhp1XSfR
> aMle2rSbJ4MYZ8&s=PKuptmwoRT6LU0XzA5aP5ALP1V886WdfH5ZX22BoJ98&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-2Dmethod-
> 2D00&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=wr9y6v7T2pw1NXocsCDBLyhp1XSfR
> aMle2rSbJ4MYZ8&s=raoeB7QOHSj15ytpNw58k9mRSEH4ORlmgztBDL8JH-8&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-
> 2Dmethod-2D00&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=wr9y6v7T2pw1NXocsCDBLyhp1XSfR
> aMle2rSbJ4MYZ8&s=jRWhzLsfl0BvlwGBPXzAFPIDCSlGTqGLu367v1fmXL8&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=wr9y6v7T2pw1NXocsCDBLyhp1XSfR
> aMle2rSbJ4MYZ8&s=lBIhRtdqdEhzyeJ2ZjT-tONnwcxIsLe0VHDtL4k9Rrc&e=
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_ippm&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=wr9y6v7T2pw1NXocsCDBLyhp1XSfR
> aMle2rSbJ4MYZ8&s=Y8MyKFxZhcXaex8xmJn8G3hrATiH7vegAuYDd8ZF_zg&e=