Subject: Re: [ippm] Working Group Last Call: draft-ietf-ippm-multipoint-alt-mark

From: Giuseppe Fioccola <[email-masked]>
Date: Tue, 7 Jan 2020 13:35:51 +0000

Dear Tommy, All,
Thank you!
I have just posted an updated version (-04) of the draft and included Al's comments.
Regarding the Document Shepherd I would like to suggest Al Morton or Tal Mizrahi, since they gave useful inputs and comments during the development of the document.

Regards,

Giuseppe

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, December 23, 2019 8:34 PM
To: Giuseppe Fioccola <[email-masked]>; IETF IPPM WG <[email-masked]>
Cc: MORTON, ALFRED C (AL) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>
Subject: Re: [ippm] Working Group Last Call: draft-ietf-ippm-multipoint-alt-mark

Hello all,

Thanks for your inputs during the last call! We will progress the document to the IESG once we get a Document Shepherd write-up.

Authors, please post an update of the draft to include Al's comments when you can.

We also do need a Document Shepherd to create the write-up for this draft. If anyone in the group who is not an author on this document would like to be the document shepherd, please send an email to the chairs!

Best,
Tommy

On Dec 22, 2019, at 2:34 PM, Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>> wrote:

Dear Al,
Thank you for the support and for the inputs.
Your suggestions are ok and I will address them in the new revision of the draft.

Regards,

Giuseppe

________________________________

Giuseppe Fioccola
Mobile: +49-15222812418<tel:%3ca%20href=>">15222812418<tel:15222812418>
Email: [email-masked]<mailto:%3ca%20href=>">[email-masked]<mailto:[email-masked]>

From: MORTON, ALFRED C (AL)<[email-masked]<mailto:[email-masked]>>
To: Tommy Pauly<tpauly=[email-masked]<mailto:tpauly=40apple.com@dmarc..ietf.org>>;IETF IPPM WG<[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark
Time: 2019-12-22 18:41:08

Hi IPPM,

I have reviewed the latest draft of multipoint-alt-mark,
as well as several earlier versions.

I believe the draft is ready for publication, with a few minor
comments below.

Al

          multipoint-to-point
              +------+
          ---<>  R1  <>
              +------+ \
                        \ +------+
                        <>  R4  <>
                        / +------+ \
              +------+ /            \ +------+
          ---<>  R2  <>              <>  R4  <>---
              +------+              / +------+
                          +------+ /
                         <>  R5  <>
                        / +------+
              +------+ /
          ---<>  R3  <>
              +------+

I’m fairly sure the Router on the far right is R6 (Figure 1).

Also the last sentence of Section 3 reads:
   While ECMP flow is in scope by definition, since it is a point-to-
   multipoint unicast flow.
There is an issue with two phrases beginning “While” and “since”, maybe this
was meant, (plus the phrase in italics?):
   An ECMP flow is in scope by definition, since it is a point-to-
   multipoint unicast flow, _or/and a point-to-point multipath flow_?

Section 4.1

[I-D.amf-ippm-route<https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03#ref-I-D.amf-ippm-route>]  Reference out of date, please use WG version.

Section 5

   And in case of no packet loss occurring in the marking period, if all
   the input and output points of the network domain to be monitored are
   measurement points, the sum of the number of packets on all the
   ingress interfaces and on all the egress interfaces is the same.
Suggest
   And in case of no packet loss occurring in the marking period, if all
   the input and output points of the network domain to be monitored are
   measurement points, the sum of the number of packets on all the
   ingress interfaces _equals the number on egress interfaces for the _monitored_flow.
===========
   It is possible to define the Network Packet Loss (for 1 flow, for 1
   period): <<In a packet network, the number of lost packets is the
   number of packets counted by the input nodes minus the number of
   packets counted by the output nodes>>.
Suggest
   It is possible to define the Network Packet Loss (for 1 _monitored_flow, for 1
   period): <<In a packet network, the number of lost packets is the
   number of packets counted by the input nodes minus the number of
   packets counted by the output nodes>>.

Section 13

You can probably just say, “This memo makes no requests of IANA.”

From: ippm [mailto:ippm-bounces@ietf..org] On Behalf Of Tommy Pauly
Sent: Monday, December 9, 2019 3:18 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Working Group Last Call: draft-fioccola-ippm-multipoint-alt-mark

Hello IPPM,

Continuing on in our list of Last Calls, we are now beginning the Working Group Last Call for draft-ietf-ippm-multipoint-alt-mark:

https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dmultipoint-2Dalt-2Dmark-2D03&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrcUHiENItugXyVC4F6KnN1f0LEcV3F68vitzlOk-04&s=87YJDmtGd8q5H4GpNd7l5SMz6f5lKU34xddFIRdI7jE&e=>

The Last Call will end on Monday, December 23... Please reply to [email-masked]<mailto:[email-masked]> with your reviews, and indicate whether or not you think this document is ready for publication.

Best,
Tommy (as co-chair)
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 08 Jan 2020 09:25:03 -0800

Thanks, Giuseppe!

Tal has agreed to shepherd the document. Thanks very much to Tal!

Best,
Tommy

> On Jan 7, 2020, at 5:35 AM, Giuseppe Fioccola <[email-masked]> wrote:
> 
> Dear Tommy, All,
> Thank you!
>   <>
> On Dec 22, 2019, at 2:34 PM, Giuseppe Fioccola <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear Al,
> Mobile: +49-15222812418 <tel:%3ca%20href=>">15222812418 <tel:15222812418>  
> Email: [email-masked] <mailto:%3ca%20href=>">[email-masked] <mailto:[email-masked]>
> 
>  
> From: MORTON, ALFRED C (AL)<[email-masked] <mailto:[email-masked]>>
> To: Tommy Pauly<tpauly=[email-masked] <mailto:tpauly=40apple.com@dmarc..ietf.org>>;IETF IPPM WG<[email-masked] <mailto:[email-masked]>>
> [I-D.amf-ippm-route <https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03#ref-I-D.amf-ippm-route>]  Reference out of date, please use WG version.
>  
> Section 5
>  
> To: IETF IPPM WG <[email-masked] <mailto:[email-masked]>>
> https://tools.ietf.org/html/draft-ietf-ippm-multipoint-alt-mark-03 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dmultipoint-2Dalt-2Dmark-2D03&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrcUHiENItugXyVC4F6KnN1f0LEcV3F68vitzlOk-04&s=87YJDmtGd8q5H4GpNd7l5SMz6f5lKU34xddFIRdI7jE&e=>
>  
> The Last Call will end on Monday, December 23... Please reply to [email-masked] <mailto:[email-masked]> with your reviews, and indicate whether or not you think this document is ready for publication.
>  
> Best,
> Tommy (as co-chair)
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 9 Jan 2020 11:22:53 +0000

Good news Tommy! Thanks a lot Tal for your help!
Best Regards,

Giuseppe

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 8, 2020 6:25 PM
To: Giuseppe Fioccola <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>; MORTON, ALFRED C (AL) <[email-masked]>; Tal Mizrahi <[email-masked]>
Subject: Re: [ippm] Working Group Last Call: draft-ietf-ippm-multipoint-alt-mark

Thanks, Giuseppe!

Best,
Tommy

On Jan 7, 2020, at 5:35 AM, Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>> wrote:

Dear Tommy, All,
Thank you!

Regards,

Giuseppe

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, December 23, 2019 8:34 PM
To: Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Cc: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Subject: Re: [ippm] Working Group Last Call: draft-ietf-ippm-multipoint-alt-mark

Hello all,

Best,
Tommy

Dear Al,

Regards,

Giuseppe

Giuseppe Fioccola

Hi IPPM,

Al

          multipoint-to-point
              +------+
          ---<>  R1  <>
              +------+ \
                        \ +------+
                        <>  R4  <>
                        / +------+ \
              +------+ /            \ +------+
          ---<>  R2  <>              <>  R4  <>---
              +------+              / +------+
                          +------+ /
                         <>  R5  <>
                        / +------+
              +------+ /
          ---<>  R3  <>
              +------+

Section 4.1

Section 5

Section 13

Hello IPPM,

Best,
Tommy (as co-chair)