Subject: [ippm] Shepherd review of draft-fioccola-ippm-multipoint-alt-mark-04

From: Tal Mizrahi <[email-masked]>
Date: Wed, 29 Jan 2020 15:49:50 +0200

Dear authors,

I believe this document is ready for publication, with a few minor comments.
If the authors can kindly address these comments and post an updated
version, we will proceed with the publication process.

Comments:

Section 5:
"The Monitored Network Packet Loss with n input nodes and m output nodes is
given by"
Please clarify whether the metric PL is measured on a per flow (5-tuple)
basis, as defined in Section 4, or measured globally for all the flows.

Section 5:
"The equation is applied on a per-time-interval basis."
Please note that the term time interval has not been defined before this
point in the document. This would be a good point to add a sentence that
explains that an "interval" is derived from an alternating marking field.

Section 6:
Please clarify whether a cluster is defined on a per-flow basis, or is it
assumed that all flows are monitored at all times.

Section 7:
"In general the measurement interval for describing the results is the
interval of the marking node that is more aligned with the start of the
measurement"
Please clarify what "more aligned" means. The figure seems to indicate that
the measurement interval is determined by the node with the earliest clock,
thus starting the measurement interval ahead of the other nodes.

Cheers,
Tal Mizrahi.
[As shepherd of draft-fioccola-ippm-multipoint-alt-mark]

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 30 Jan 2020 10:37:41 +0000

Dear Tal,
Please find my answers inline tagged as [GF].
Let me know if these address your comments, so I can update and submit a new version.

Regards,

Giuseppe

From: Tal Mizrahi [mailto:[email-masked]]
Sent: Wednesday, January 29, 2020 2:50 PM
To: IETF IPPM WG <[email-masked]>; [email-masked]
Subject: Shepherd review of draft-fioccola-ippm-multipoint-alt-mark-04

Dear authors,

I believe this document is ready for publication, with a few minor comments.
If the authors can kindly address these comments and post an updated version, we will proceed with the publication process.

Comments:

Section 5:
"The Monitored Network Packet Loss with n input nodes and m output nodes is given by"
Please clarify whether the metric PL is measured on a per flow (5-tuple) basis, as defined in Section 4, or measured globally for all the flows.

[GF]: The Monitored Network Packet Loss is measured for one single flow but since it is a multipoint flow, the identification fields of the 5-tuple, in general, can be selected without any constraints. I can specify better this point.

Section 5:
"The equation is applied on a per-time-interval basis."
Please note that the term time interval has not been defined before this point in the document. This would be a good point to add a sentence that explains that an "interval" is derived from an alternating marking field.

[GF]: Sure. I will add a note about the interval here referred, that is the alternate marking period as defined in RFC 8321.

Section 6:
Please clarify whether a cluster is defined on a per-flow basis, or is it assumed that all flows are monitored at all times.

[GF]: Yes, the Cluster is defined on a per-flow basis. I can add a sentence to clarify.

Section 7:
"In general the measurement interval for describing the results is the interval of the marking node that is more aligned with the start of the measurement"
Please clarify what "more aligned" means. The figure seems to indicate that the measurement interval is determined by the node with the earliest clock, thus starting the measurement interval ahead of the other nodes.

[GF]: Yes, in this case we assume that the node with the earliest clock identifies the right starting time of the measurement, but it is just an assumption and other possibilities can happen. This is to introduce the new constraint that needs to be considered for the proper function of the method. I will clarify this point as well.

Cheers,
Tal Mizrahi.

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 30 Jan 2020 13:17:06 +0200

Hi Giuseppe,

Sounds good to me.
If you can update the draft based on these responses that would be great.

Cheers,
Tal.

On Thu, Jan 30, 2020 at 12:37 PM Giuseppe Fioccola <
[email-masked]> wrote:

> *From:* Tal Mizrahi [mailto:[email-masked]]
> *Sent:* Wednesday, January 29, 2020 2:50 PM
> *To:* IETF IPPM WG <[email-masked]>;
> [email-masked]
> *Subject:* Shepherd review of draft-fioccola-ippm-multipoint-alt-mark-04
>
>
>
> Dear authors,
>
>
>
> [GF]: The Monitored Network Packet Loss is measured for one single flow
> but since it is a multipoint flow, the identification fields of the
> 5-tuple, in general, can be selected without any constraints. I can specify
> better this point.
>
>
>
> Section 5:
> [GF]: Sure. I will add a note about the interval here referred, that is
> the alternate marking period as defined in RFC 8321.
>
>
>
> Section 6:
> Please clarify what "more aligned" means. The figure seems to indicate
> that the measurement interval is determined by the node with the earliest
> clock, thus starting the measurement interval ahead of the other nodes.
>
>
>
> [GF]: Yes, in this case we assume that the node with the earliest clock
> identifies the right starting time of the measurement, but it is just an
> assumption and other possibilities can happen. This is to introduce the new
> constraint that needs to be considered for the proper function of the
> method. I will clarify this point as well.
>
>
>
>
>
> Cheers,
>
> Tal Mizrahi.
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 31 Jan 2020 10:02:42 +0000

Hi Tal,
I have just submitted the new -05 version.
Please let me know if this addresses your remarks.

Regards,

Giuseppe

From: Tal Mizrahi [mailto:[email-masked]]
Sent: Thursday, January 30, 2020 12:17 PM
To: Giuseppe Fioccola <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>; [email-masked]
Subject: Re: Shepherd review of draft-fioccola-ippm-multipoint-alt-mark-04

Hi Giuseppe,

Sounds good to me.

Cheers,
Tal.

On Thu, Jan 30, 2020 at 12:37 PM Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>> wrote:
Dear Tal,
Please find my answers inline tagged as [GF].
Let me know if these address your comments, so I can update and submit a new version.

Regards,

Giuseppe

From: Tal Mizrahi [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, January 29, 2020 2:50 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Shepherd review of draft-fioccola-ippm-multipoint-alt-mark-04

Dear authors,

Comments:

Section 5:

Section 5:

Section 6:

Section 7:

Cheers,
Tal Mizrahi.