Subject: [ippm] I-D Action: draft-ietf-ippm-ioam-direct-export-00.txt

From: [email-masked]
Date: Thu, 06 Feb 2020 00:18:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : In-situ OAM Direct Exporting
        Authors         : Haoyu Song
                          Barak Gafni
                          Tianran Zhou
                          Zhenbin Li
                          Frank Brockners
                          Shwetha Bhandari
                          Ramesh Sivakolundu
                          Tal Mizrahi
	Filename        : draft-ietf-ippm-ioam-direct-export-00.txt
	Pages           : 10
	Date            : 2020-02-06

Abstract:
   In-situ Operations, Administration, and Maintenance (IOAM) is used
   for recording and collecting operational and telemetry information.
   Specifically, IOAM allows telemetry data to be pushed into data
   packets while they traverse the network.  This document introduces a
   new IOAM option type called the Direct Export (DEX) option, which is
   used as a trigger for IOAM data to be directly exported without being
   pushed into in-flight data packets.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-ioam-direct-export/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-ioam-direct-export-00
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-ioam-direct-export-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 6 Feb 2020 10:31:27 +0200

Hi,

This is the first "draft-ietf" version of this document, with minor changes
compared to the previous version.
The main changes compared to the previous version:
- The term collector was replaced by a more general term - "receiving
entity".
- Some unused references were removed.

We would like feedback regarding the main open issue in this document
(described in Section 7), regarding the Hop Limit / Hop Count.
Specifically, we are looking for feedback about the question: do you think
the DEX option should include an explicit Hop Count field?

Cheers,
Tal.

On Thu, Feb 6, 2020 at 10:18 AM <[email-masked]> wrote:

> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 6 Feb 2020 21:11:23 +0000

Hi Tal,

Thanks for drawing my attention to this discussion,
the tradeoffs are nicely presented in section 7. [0]

After working on the AURA draft in this working group,
I see some value in the more accurate of the two
approaches described (seems to be the Hop Count approach).

I’m sure there will be other, perhaps practical aspects
to consider, too.

regards,
Al

[0] https://tools.ietf.org/html/draft-ietf-ippm-ioam-direct-export-00#page-7

From: ippm [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Thursday, February 6, 2020 3:31 AM
To: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] I-D Action: draft-ietf-ippm-ioam-direct-export-00.txt

Hi,

This is the first "draft-ietf" version of this document, with minor changes compared to the previous version.
The main changes compared to the previous version:
- The term collector was replaced by a more general term - "receiving entity".
- Some unused references were removed.

We would like feedback regarding the main open issue in this document (described in Section 7), regarding the Hop Limit / Hop Count.. Specifically, we are looking for feedback about the question: do you think the DEX option should include an explicit Hop Count field?

Cheers,
Tal.

On Thu, Feb 6, 2020 at 10:18 AM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-ioam-direct-export/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dioam-2Ddirect-2Dexport_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=nmezzKRhIWF5cxpGwy710ynabiEDp6UVmenKgyL-zjg&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-ioam-direct-export-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dioam-2Ddirect-2Dexport-2D00&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=QoleVmLxd_mykmoYrxrL8KtdsXm1IYewxRNnteE5jeY&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-ioam-direct-export-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dippm-2Dioam-2Ddirect-2Dexport-2D00&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=tQaByzestqeuffTk-Od6JUYypFXQdbIm7nz7iS1LZ-k&e=>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=al6JFGp3E3a3Vd70882JbQAi-KNenf81aHePqryv_uE&e=>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=o-g7Ufu0orxlgf11ue9Rb_mT_g94va0w8Gb7GBXgjRQ&e=>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ippm&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=a8kyEAskJ5eWnXi-x1kKjsSkB4ODEb0bZpMpSHNbjM8&s=c_7sR732SbA1UxPI84IoJ77NYcFmhB7Pj2VWbRTvCic&e=>