Subject: Re: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Fri, 5 Jun 2020 16:44:35 +0000

Hi Al,

Many thanks for serving as doc shepherd and for your comments.

Please see inline (“…FB”)

From: ippm <[email-masked]> On Behalf Of MORTON, ALFRED C (AL)
Sent: Sonntag, 31. Mai 2020 17:28
To: Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: Re: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Hi Tommy and Draft ioam-data Authors,

After completing one pass through the memo in the role of Doc Shepherd,
I ended-up with a few comments that are more like WGLC comments than
those of the shepherd.  Since we are only a few days over WGLC closure,
I have uploaded the preliminary shepherd write-up and share
the comments for optional action below (I don’t think these comments
should have any special status, IOW).

It is clear that lots of work an negotiation went into the present text.
I appreciate that fact and thank all who participated for preparing
an excellent draft.

The current shepherd’s write-up [0] is available for comment, as well.

Al
(as doc shepherd)

[0] https://datatracker.ietf.org/doc/draft-ietf-ippm-ioam-data/shepherdwriteup/

Doc Shepherd's Comments:

Closed PR https://github.com/inband-oam/ietf/pull/96
Two Comments indicate the value of a Manageability Considerations section while resolving issues in the discussion. However, the -09 version still does not have this section a year later... The important topic discussed was congestion management, but there are no instances of "congest" in the -09 text.  (more, see below)

Section 3, Scope, etc. contains the topic:
Deployment domain (or scope) of in-situ OAM deployment:, in which many operational considerations are detailed that could be part of a Manageability Considerations: section.

…FB: Deployment and Manageability is a pretty wide topic. This is why we created a dedicated document for it:
https://tools.ietf.org/html/draft-brockners-opsawg-ioam-deployment-01. Are you ok if we continue to keep it as a dedicated document, or should we consider to replicate information from draft-brockners-opsawg-ioam-deployment into draft-ietf-ippm-ioam-data? Personally I’d prefer to avoid replication between documents.

4.4 Trace Option types
...
   ...The maximum number of hops and the minimum path MTU of the IOAM domain is assumed
   to be known.

What are the consequences when they are not known?
     Looks like the Flag Bit 0 O-bit handles this case for number of hops.  (Add this here?)
…FB: Good point. We can add a sentence stating that the O-bit is there to deal with situations where the PMTU was underestimated, i.e. where the number of hops which are IOAM capable exceeds the available space in the packet.

Or, is this knowledge highly likely, and expected to be violated only under the most unexpected conditions (restoration from multiple failures)?
See point below on "minimum path MTU".

4.4.1
RemainingLen:
...
      Given that the sender knows the minimum path MTU, the sender MAY
      set the initial value of RemainingLen according to the number of
      node data bytes allowed before exceeding the MTU.
"minimum path MTU" is the smallest Maximum Transmission Unit for all links in a path, or simply the Path MTU, PMTU, right?
https://en.wikipedia.org/wiki/Path_MTU_Discovery

…FB: Good catch – sloppy language indeed. Let’s do s/minimum path MTU/PMTU/

4.5 Proof of Transit

Is there a Reference for "Shamir's Secret Sharing Schema (SSSS)" ?
Or, is it a secret?

…FB: We’ll add a reference to https://en.wikipedia.org/wiki/Shamir%27s_Secret_Sharing like we did in the PTO draft.  Martin caught the glitch as well.

7.  IANA Considerations
(apologies in advance for a long/recent/good experience with IANA, and the many other folks who try to help our friends at IANA)
This section appears to define a set of related registries.
The hierarchy could be named a bit more efficiently than:

7.1 In-Situ OAM Protocol Parameters Registry (IOAM) Protocol Parameters IANA registry

Suggest:
In-Situ OAM (IOAM) Protocol Parameters Group
7.1  IOAM Protocol Parameters Registry
     7.2  IOAM Option-Type Registry
     7.3  IOAM Trace-Type Registry
       ...
…FB: Thanks for the great suggestion.

Thanks again, Frank

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Thursday, May 28, 2020 12:43 PM
To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Our WGLC call for draft-ietf-ippm-ioam-data is now concluded! Thanks everyone.

I’ve marked the document as having WG consensus, and needing a revised I-D (to incorporate Martin’s comments). Once that is ready and we have the shepherd write-up, we’ll submit this to the IESG.

As a reminder, we are still in the WGLC for draft-ietf-ippm-stamp-option-tlv. Please review and comment if you have not already!

Thanks,
Tommy

On May 14, 2020, at 10:16 AM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Hi IPPM,

At our virtual interim meeting, we decided to put draft-ietf-ippm-ioam-data through a second last call, based on the new revisions, in mid-May. This email starts a two-week WGLC for this draft.

The latest version can be found here: https://tools.ietf.org/html/draft-ietf-ippm-ioam-data-09<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dioam-2Ddata-2D09&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=YwMkvN3mqHRxnwcgkB4l4psDqQViP1UTeOxJeyv5T7k&s=_Lv2krlY6UiX1GbDsvMqDhkXEWZf66f0UkBcR3O3csg&e=>

This last call will end on Thursday, May 28. Please reply to [email-masked]<mailto:[email-masked]> with your reviews and comments.

Thanks,
Tommy & Ian
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ippm&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=YwMkvN3mqHRxnwcgkB4l4psDqQViP1UTeOxJeyv5T7k&s=BSOHsMgZ_JR-B6_CAnlIGEEoEv1CXcvWQ-vOS7UsHRg&e=>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sat, 6 Jun 2020 20:54:57 +0000

From: Frank Brockners (fbrockne) [mailto:[email-masked]]
Sent: Friday, June 5, 2020 12:45 PM
To: MORTON, ALFRED C (AL) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Hi Al,

Many thanks for serving as doc shepherd and for your comments.
[acm]
you’re welcome. thanks for your suggested resolutions below, only one thought added.

Al

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of MORTON, ALFRED C (AL)
Sent: Sonntag, 31. Mai 2020 17:28
To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Al
(as doc shepherd)

[0] https://datatracker.ietf.org/doc/draft-ietf-ippm-ioam-data/shepherdwriteup/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dioam-2Ddata_shepherdwriteup_&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=_dJpSo8AyMTj7xfaWzhbk8adl-Q_-AVRE6UYzwvU-Bc&s=W8TGBO7MPbLasUWPzie38UkAX5N1Ur7Z7-Sep6AB04M&e=>

Doc Shepherd's Comments:

Closed PR https://github.com/inband-oam/ietf/pull/96<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_inband-2Doam_ietf_pull_96&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=_dJpSo8AyMTj7xfaWzhbk8adl-Q_-AVRE6UYzwvU-Bc&s=xO_WZxG-3r5AXaLQ1FbNPNjY1qDltlbkhtp0JlC6sj0&e=>
Two Comments indicate the value of a Manageability Considerations section while resolving issues in the discussion. However, the -09 version still does not have this section a year later... The important topic discussed was congestion management, but there are no instances of "congest" in the -09 text.  (more, see below)

…FB: Deployment and Manageability is a pretty wide topic. This is why we created a dedicated document for it:
https://tools.ietf.org/html/draft-brockners-opsawg-ioam-deployment-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dbrockners-2Dopsawg-2Dioam-2Ddeployment-2D01&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=_dJpSo8AyMTj7xfaWzhbk8adl-Q_-AVRE6UYzwvU-Bc&s=D8gqnIL9iGcfWuNOGkpQwpn69h4WQ3dDOCHC0-_Bhpc&e=>. Are you ok if we continue to keep it as a dedicated document, or should we consider to replicate information from draft-brockners-opsawg-ioam-deployment into draft-ietf-ippm-ioam-data? Personally I’d prefer to avoid replication between documents.
[acm]
Let’s avoid replication, as you suggest. An informative reference to the deployment draft WFM.
Also, I searched and did not find “congest” in the deployment draft, so it’s future work there.

4.4 Trace Option types
...

[acm]
OK, thanks

4.4.1
RemainingLen:
...
https://en.wikipedia.org/wiki/Path_MTU_Discovery<https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_Path-5FMTU-5FDiscovery&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=_dJpSo8AyMTj7xfaWzhbk8adl-Q_-AVRE6UYzwvU-Bc&s=Xr6dzIfP1p8R8AEQXSUGDdSC0w6Sv1oZi0soqYG-Amw&e=>

[acm]
wfm

4.5 Proof of Transit

…FB: We’ll add a reference to https://en.wikipedia.org/wiki/Shamir%27s_Secret_Sharing<https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_Shamir-2527s-5FSecret-5FSharing&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=_dJpSo8AyMTj7xfaWzhbk8adl-Q_-AVRE6UYzwvU-Bc&s=5yyEpJN1weB24Ht3gjGLDMkgU9E_xKxdGRZK9Tgi50Y&e=> like we did in the PTO draft.  Martin caught the glitch as well.

[acm]

good

7.  IANA Considerations

Suggest:
[acm]
NP!

Thanks again, Frank

Thanks,
Tommy

Hi IPPM,

Thanks,
Tommy & Ian

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Sun, 7 Jun 2020 12:20:58 +0000

Hi Al,

Thanks. On the “deployment and manageability” discussion: We’ll add an informational reference to the deployment draft and ensure that the next rev of the deployment draft also touches on congestion management.

Cheers, Frank

From: MORTON, ALFRED C (AL) <[email-masked]>
Sent: Samstag, 6. Juni 2020 22:55
To: Frank Brockners (fbrockne) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

From: Frank Brockners (fbrockne) [mailto:[email-masked]]
Sent: Friday, June 5, 2020 12:45 PM
To: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Hi Al,

Al

Al
(as doc shepherd)

Doc Shepherd's Comments:

4.4 Trace Option types
...

4.4.1
RemainingLen:
...

4.5 Proof of Transit

[acm]

good

7.  IANA Considerations

Suggest:

Thanks again, Frank

Thanks,
Tommy

Hi IPPM,

Thanks,
Tommy & Ian

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 9 Jun 2020 15:56:22 +0000

Quick FYI: I’ve created issues on github for all the comments received during WGLC #2 which would require document edits:

#180 draft-ietf-ippm-ioam-data-09 WGLC #2: Elaborate on consequences if PMTU is not known.<https://github.com/inband-oam/ietf/issues/180>
#179 draft-ietf-ippm-ioam-data-09 WGLC #2: Manageability discussion<https://github.com/inband-oam/ietf/issues/179>
#178 draft-ietf-ippm-ioam-data-09 WGLC #2: Editorial nits<https://github.com/inband-oam/ietf/issues/178>
#177 draft-ietf-ippm-ioam-data-09 WGLC #2: IANA Considerations Registry Titles<https://github.com/inband-oam/ietf/issues/177>
#176 draft-ietf-ippm-ioam-data-09 WGLC #2: Guidelines for expert reviewer<https://github.com/inband-oam/ietf/issues/176>
#175 draft-ietf-ippm-ioam-data-09 WGLC #2: Init values for node-list array?<https://github.com/inband-oam/ietf/issues/175>
#174 draft-ietf-ippm-ioam-data-09 WGLC #2: What happens if a node does not follow the normative requirements in section 4.4.1 (tracing)?<https://github.com/inband-oam/ietf/issues/174>
#173 draft-ietf-ippm-ioam-data-09 WGLC #2: Clarification on presence of prealloc & incremental option types.<https://github.com/inband-oam/ietf/issues/173>
#172 draft-ietf-ippm-ioam-data-09 WGLC #2: Check uppercase/lowercase normative language<https://github.com/inband-oam/ietf/issues/172>
#171 draft-ietf-ippm-ioam-data-09 WGLC #2: Number of authors<https://github.com/inband-oam/ietf/issues/171>

We’re hoping to have a new rev out shortly.

Cheers, Frank

From: Frank Brockners (fbrockne) <[email-masked]>
Sent: Sonntag, 7. Juni 2020 14:21
To: MORTON, ALFRED C (AL) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG <[email-masked]>; [email-masked]
Subject: RE: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Hi Al,

Cheers, Frank

From: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>
Sent: Samstag, 6. Juni 2020 22:55
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; IETF IPPM WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [ippm] Second WGLC for draft-ietf-ippm-ioam-data

Hi Al,

Al

Al
(as doc shepherd)

Doc Shepherd's Comments:

4.4 Trace Option types
...

4.4.1
RemainingLen:
...

4.5 Proof of Transit

[acm]

good

7.  IANA Considerations

Suggest:

Thanks again, Frank

Thanks,
Tommy

Hi IPPM,

Thanks,
Tommy & Ian