Subject: iSCSI:SCSI Mode Pages

From: "Sanjeev Bhagat \(TRIPACE/Zoetermeer\)" <[email-masked]>
Date: Tue, 18 Sep 2001 20:30:03 +0200

I have a query regarding section 3.1.2 EMDP mode parameter. Current text
says

3.1.2 E - Enable Modify Data Pointers Bit (EMDP)

......

If EMDP is set to 1, Data PDU sequences may be transferred in any order. If
EMDP is set to 0, Data PDU sequences MUST be transferred using continuously
increasing offsets.

Does this line mean that if EMDP=1 the out of order received data PDUs by
the iSCSI target be transferred directly to the actual SCSI LU (say a HDD)

or

does it mean that the if EMDP=1 the out of order received data PDUs be
stored in some external buffer provided by SCSI LU and re-assembled and
ordered there before transferring it into the SCSI LU.

Regards,

Sanjeev

---

From: "Sanjeev Bhagat \(TRIPACE/Zoetermeer\)" <[email-masked]>
Date: Wed, 19 Sep 2001 15:56:28 +0200

I agree with Bob.So basically you would like to say that option no. 2
referred by me was correct. The data is stored in external buffers only and
not trasnferred to the SCSI LU untill the buffer is full with ordered data.

But now my question comes whether the iSCSI target will have a common
externa buffer and it will allocate a part of  buffer for each SCSI LU
inside or is the every SCSI LU going to maintain its own buffers.

Is it also possible for 2 different SCSI LUs to negotiate EMDP bit 0 and 1

Sincerely,

Sanjeev Bhagat

Tripace Europe

Tel # +31 (79) 361 2444

Mob# +31 6 24685051

Please, do visit our web site for more info:

http://www.tripace.com/

SCSI Chip Set(s), SCSI Host Adapters, SCSI Software Drivers to various
Operating Systems

SCSI, USB 2.0 & ATAPI/ATA Interconnectivity Chip Solutions

C R E A T O R S O F D A T A M O V I N G W O R L D S

This e-mail is confidential and may contain legally privileged information.
You should not disclose its contents to any other person. If you are not the
intended recipient, please notify the sender above mentioned immediately.

----- Original Message -----
From: "Robert Snively" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, September 19, 2001 2:00 AM
Subject: RE: iSCSI:SCSI Mode Pages

> * From the T10 Reflector ([email-masked]), posted by:
> * Robert Snively <[email-masked]>
> *
> Note that in either case questioned by Sanjeev, it is the
> TARGET,  NOT the INITIATOR, that decides in what order the
> tranfers will be performed.
>
> In the case of a READ, EMDP = 1 allows non-contiguous setting
> of the Buffer Offset parameter.
>
> In the case of a WRITE, EMDP = 1 allows non-contiguous setting
> of the R2T Buffer Offset parameter.
>
> The target will never do such things unless it has
> committed to the proper manipulation of the data by allowing
> the EMDP bit to be set to a value other than 0.
>
> Bob Snively                        e-mail:    [email-masked]
> Brocade Communications Systems     phone:  408 487 8135
> 1745 Technology Drive
> San Jose, CA 95110
>
>
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Tuesday, September 18, 2001 3:25 PM
> > To: [email-masked]
> > Subject: Re: iSCSI:SCSI Mode Pages
> >
> >
> > * From the T10 Reflector ([email-masked]), posted by:
> > * [email-masked]
> > *
> >
> > The bit is intended to allow targets to send Modify Data
> > pointer messages,
> > which is the only mechanism to allow transmitting data out of
> > order. Data
> > that is not in order is required to be preceded with this
> > message, which
> > contains an offset to the data pointer to indicate where in
> > the data stream
> > the chunk of data belongs. This feature is considered a pain
> > to implement
> > and ususally isn't supported on most devices anyway.
> >
> > If you still think you want to try this out, generally the
> > Logical Unit is
> > required to buffer the data and rearrange it as needed (it
> > may not need to
> > rearrange the data, it will probably rearrange the transfer
> > to/from media
> > activity to get it organized right).
> >
> >
> >
> >
> >
> > "Sanjeev Bhagat \(TRIPACE/Zoetermeer\)" <[email-masked]>
> > @t10.org on 09/18/2001 01:30:03 PM
> >
> > Sent by:  [email-masked]
> >
> >
> > To:   "IPS Refelctor" <[email-masked]>, "T10 Reflector" <[email-masked]>
> > cc:
> >
> > Subject:  iSCSI:SCSI Mode Pages
> >
> >
> > * From the T10 Reflector ([email-masked]), posted by:
> > * "Sanjeev Bhagat \(TRIPACE/Zoetermeer\)"
> > <[email-masked]>
> > *
> > *
> > * For T10 Reflector information, send a message with
> > * 'info t10' (no quotes) in the message body to [email-masked]
> >
> >
> >
> > *
> > * For T10 Reflector information, send a message with
> > * 'info t10' (no quotes) in the message body to [email-masked]
> >
> *
> * For T10 Reflector information, send a message with
> * 'info t10' (no quotes) in the message body to [email-masked]
>