Subject: iscsi : MaximumBurstSize & FirstBurstSize values.

From: Santosh Rao <[email-masked]>
Date: Fri, 21 Sep 2001 11:43:15 -0700

All,

I believe the FirstBurstSize setting has to be <= MaximumBurstSize ? I
suggest that this be explicitly called out in the definition of
FirstBurstSize.

If this rule is not followed, an initiator would need to break the
un-solicited data it sends into more than 1 data-out sequence, and in
setting the F bit to indicate end-of-sequence, it can confuse the target
into thinking its end of un-solicited data.

The definitions currently read :

"4.1.1 MaximumBurstSize Field (16 bit)

This field defines the maximum SCSI data payload in an iSCSI sequence (a
sequence of Data-In or Data-Out PDUs ending with a Data-In or Data-Out
PDU with the F bit set to one) in units of 512 bytes. The      default
value assumed for a new iSCSI session (I_T nexus) is 512 units.

4.1.3 FirstBurstSize Field (16 bit)

This field defines the maximum amount of unsolicited data an iSCSI
initiator may to send to the target in units of 512 bytes. The default
value assumed for a new iSCSI session (I_T nexus) is 128 units. "

Regards,
Santosh

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 22 Sep 2001 07:47:32 +0300

I'll spell it out. julo

                    Santosh Rao                                                         
                    <santoshr@cup.       To:     IPS Reflector <[email-masked]>        
                    hp.com>              cc:                                            
                    Sent by:             Subject:     iscsi : MaximumBurstSize &        
                    owner-ips@ece.        FirstBurstSize values.                        
                    cmu.edu                                                             

                    21-09-01 21:43                                                      
                    Please respond                                                      
                    to Santosh Rao                                                      

All,

Regards,
Santosh

#### santoshr.vcf has been removed from this note on September 22 2001 by
Julian Satran