Subject: iscsi : MaximumBurstSize & data-out sequences.

From: Santosh Rao <[email-masked]>
Date: Thu, 27 Sep 2001 15:54:53 -0700

Julian & All,

Can initiators assume that it is the target's responsibility to ensure
that an R2T request it issues will not exceed MaximumBurstSize ?

If initiators cannot assume the above, they will need to send data-out
pdu's in response to an R2T in multiple sequences, if the R2T "Desired
Data Length" > MaximumBurstSize. If this were to happen, it could
confuse the target into thinking the initiator has sent all the
requested data in response to the R2T, when in fact, the initiator has
only sent the first of several sequences of data-out in response to the
R2T.

I suggest that the draft explicitly mention [in the definition of
MaxBurstSize as well as R2T] that R2T requests MUST NOT exceed
MaximumBurstSize.

Related Definitions (from rev 7.98) :
-------------------------------------

" For outgoing data, the F bit is 1 for the last PDU of unsolicited data
or the last PDU of a sequence answering an R2T."

" 4.1.1 MaxBurstSize Field (16 bit) 
         
This field is used by iSCSI to define the maximum SCSI data payload in
an iSCSI sequence (a sequence of Data-In or Data-Out PDUs ending with a
Data-In or Data-Out PDU with the F bit set to one) in units of 512
bytes. This value can be set by a text-mode key=value pair
(MaxBurstSize). "

Thanks,
Santosh

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 28 Sep 2001 07:24:11 +0300

will do - thanks, julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     IPS Reflector <[email-masked]>                 
                    hp.com>              cc:                                                     
                    Sent by:             Subject:     iscsi : MaximumBurstSize & data-out        
                    owner-ips@ece.        sequences.                                             
                    cmu.edu                                                                      

                    28-09-01 00:54                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

Julian & All,

Thanks,
Santosh