Subject: RE: iSCSI: login issue - partial consensus call

From: David Dillard <[email-masked]>
Date: Tue, 11 Sep 2001 09:28:05 -0400

Not to turn this into a Microsoft Windows driver reflector but...

> There are a number of conditions which can cause this information
> to be incorrect. (As an example two different controller models
> supported by the same driver will each be treated as instance 0
> and get the same command line.)

There is a documented way of handling this issue.  See KB article Q133706.

I believe there is a much larger issue, that you brought up in a later
posting: that miniports cannot legally, and perhaps illegally, use the
registry access routines.

David

---

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 12 Sep 2001 14:38:29 -0400

One thing to keep in mind when assigning the ISID's via the registry is that
the drivers will have to get the same set of ISID's when they re-boot after
a failure.

Considering the following, is that possible?

- the client crashes
- maintenance notices that the reason for the crash was due to a short in
one of the iSCSI HBA's
- so, maintenance pulls out that HBA
- he re-boots
- during the re-boot, the drivers come up in a different order because one
is missing

Eddy

-----Original Message-----
From: David Dillard [mailto:[email-masked]]
Sent: Tuesday, September 11, 2001 9:28 AM
To: 'Martin, Nick'
Cc: [email-masked]'
Subject: RE: iSCSI: login issue - partial consensus call

David