Subject: Re: iSCSI: more comments on draft -07-97

From: "Julian Satran" <[email-masked]>
Date: Wed, 26 Sep 2001 22:41:36 +0300

Steve,

As we said earlier many of the key names are directly borrowed from other
RFCs.

Although they are from the same "series" (GSS) the have no systematic
name-formation rules and we have just followed whatever was out there.
Should we change SPKM to use underscore too? I will try to clean it up a
bit and make all keys use underscore.

As for coding I think that we don't have good reasons (experience?) to
impose coding.

Please recall that we left both decimal and hex to allow for manual entry
and cut and paste.

Julo

                    Steve Senum                                                                  
                    <ssenum@cisco.       To:     Julian Satran/Haifa/IBM@IBMIL                   
                    com>                 cc:                                                     
                                         Subject:     iSCSI: more comments on draft -07-97       
                    26-09-01 18:05                                                               
                    Please respond                                                               
                    to Steve Senum                                                               

Hi Julian,

A couple of further comments to add to my last message.

9. The key names in Appendix A use both '-' and '_'.
   You might consider having all of them use '-':

   CHAP-N not CHAP_N.

10. I think it would be benenfical to have some guidelines
for the different encoding methods for numbers,

if value <= unsigned 32 bits
    use decimal or hexadecimal
else if value <= (255 - 2) hexadecimal digits
    use hexadecimal or base 64,
else
    use base 64
end

or perhaps

if value <= unsigned 32 bits
    use decimal or hexadecimal
else
    use base 64
end

The point is to always use an efficient encoding for
numbers > unsigned 32 bits.

Regards,
Steve Senum

---

From: Steve Senum <[email-masked]>
Date: Wed, 26 Sep 2001 16:33:54 -0500

Julian,

> bit and make all keys use underscore.

Actually, I was suggesting using dashes, not underscores.  Either way,
I thought the usage convention could be more consistent.

> Please recall that we left both decimal and hex to allow for manual entry

I have doubts about the wisdom of allowing someone to cut and paste
values directly into the iSCSI text stream.

I think for the sake of encode/decode efficiency, values that
can exceed 32 bits should be hexadecimal of base64.

Regards,
Steve Senum