Subject: iscsi : Data ACKs already been included into draft (?)

From: Santosh Rao <[email-masked]>
Date: Wed, 26 Sep 2001 12:21:27 -0700 (PDT)

Julian & All,

It looks like the Data ACK scheme you proposed has already been included
into the Rev 7.97 draft !(?) I don't recollect the group having reached
consensus on re-inclusion of this feature, nor consensus on the mechanism
used for the data ack. Given this, why is the change already present in
the draft ?

I would like to request that any changes to the draft be first posted to
the reflector for review and only upon its acceptance on the reflector
should it be included in the draft. Incorporating changes into the draft 
prior to their acceptance on the reflector is only going to slow down the 
stabilization of the draft further.

At this late stage in the draft, every sentence modified must be subject
to review prior to inclusion in the draft.

Thanks,
Santosh

-- 
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 26 Sep 2001 23:02:22 +0300

Santosh,

What you see is an editor version and not the submission. I did show only
how it will look.
The difference is in the range of 10 lines (probably even less in code
lines :-)).
No need to panic and shout.

Julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     [email-masked] (ips)                           
                    hp.com>              cc:     [email-masked] (David Black)               
                    Sent by:             Subject:     iscsi : Data ACKs already been included    
                    owner-ips@ece.        into draft (?)                                         
                    cmu.edu                                                                      

                    26-09-01 21:21                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

Julian & All,

Thanks,
Santosh

---

From: Michael Schoberg <[email-masked]>
Date: Wed, 26 Sep 2001 17:03:28 -0500

Missed the reflector the first time so I'll try this one again...

I'm still in favor for moving R2T and Data-IN into the StatSN realm (remove
DataSN).  Looking at it, I wonder why there was this split to begin with.
If the initiator is able to request retransmission of any/all T->I PDUs, it
stands to reason that there should never be gaps in the Data-IN/R2T stream
(unless the target is broken).  Separating Data-IN & R2T ACKs from the
normal StatSN stream means requiring an equivalent protection mechanism be
created.  Bottom line is that will add complexity to iSCSI.

If Data-IN/R2T were moved in StatSN, there's still the problem of the
requirement of optional support.  Lightweight systems may not be able to
buffer much data to allow for long T->I message queues and the current draft
lists SNACK support as optional (for this reason?)  To support this, we may
need to have different flavors of R2T & Data-IN: one with StatSN and one
without.

I'm kind of surprised there hasn't been much discussion along this line.
There seems to be two extremes being expressed (in-favor of a Data-ACK even
if it involves writing new message engines -OR- in-favor or completely
removing Data-ACK to avoid overhead).  It seems like optionally moving
Data-IN/R2T into the StatSN queue would allow for both without adding much
complexity to the code.

: -----Original Message-----
: From: Santosh Rao [mailto:[email-masked]]
: Sent: Wednesday, September 26, 2001 2:21 PM
: To: [email-masked]
: Cc: [email-masked]
: Subject: iscsi : Data ACKs already been included into draft (?)
: 
: 
: Julian & All,
: 
: It looks like the Data ACK scheme you proposed has already 
: been included
: into the Rev 7.97 draft !(?) I don't recollect the group 
: having reached
: consensus on re-inclusion of this feature, nor consensus on 
: the mechanism
: used for the data ack. Given this, why is the change already 
: present in
: the draft ?
: 
: I would like to request that any changes to the draft be 
: first posted to
: the reflector for review and only upon its acceptance on the reflector
: should it be included in the draft. Incorporating changes 
: into the draft 
: prior to their acceptance on the reflector is only going to 
: slow down the 
: stabilization of the draft further.
: 
: At this late stage in the draft, every sentence modified must 
: be subject
: to review prior to inclusion in the draft.
: 
: Thanks,
: Santosh
: 
: -- 
: #################################
: Santosh Rao
: Software Design Engineer,
: HP, Cupertino.
: email : [email-masked]
: Phone : 408-447-3751
: #################################
:

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 13:18:36 +0300

Michael,

I went through a 1 and 2 tier counting scheme a year ago.
The short answer is that a one tier has severe head of queue impact and a 2
tier with a continuously running and a separate one for data (roughly what
I think Santosh suggested a day or two ago) needs to carry 2 counters in
many input PDU's and is very messy to handle with it recovery.

If you want to do more about it write a draft.

Regards,
Julo

                    Michael Schoberg                                                               
                    <michael_schober       To:     "IPS Reflector (E-mail)" <[email-masked]>      
                    [email-masked]>             cc:                                                     
                    Sent by:               Subject:     RE: iscsi : Data ACKs already been         
                    [email-masked]        included into draft (?)                                
                    u.edu                                                                          

                    27-09-01 00:03                                                                 
                    Please respond                                                                 
                    to Michael                                                                     
                    Schoberg                                                                       

buffer much data to allow for long T->I message queues and the current
draft

---

From: [email-masked]
Date: Thu, 27 Sep 2001 09:09:44 -0400

Julian,

Given that you've described the 07-9x versions of the draft on
your web site as near-final versions of the -08 draft to be
submitted, I think it's fair to expect that they represent
the rough consensus of the WG and not contain speculative
additions.  In other words - Santosh is right, that text
should not be in 07-97 and needs to be removed or moved to
a version that's clearly marked as not being on the main
course of editing to produce the -08 version.

Thanks,
--David

> -----Original Message-----
> From: Julian Satran [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 4:02 PM
> To: Santosh Rao
> Cc: [email-masked]; [email-masked]
> Subject: Re: iscsi : Data ACKs already been included into draft (?)
> 
> 
> Santosh,
>

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 19:19:54 +0300

David,

I did not raise the issue at all - it was raised by some candid souls that
are as concerned as I am about the target resources and that belong to the
same organization that the most vocal opponent of data-ack belongs to; that
lead me to the wrong assumption that he might have "seen the light".  As
such I've made 2 changes:

   a minor change in format (SNACK has a type field and not a single bit);
   that is good for extensions and will stay
   the addition of data ack (that is clearly distinguishable text) that
   might go if the list wants so

Julo

                    Black_David@em                                                               
                    c.com                To:     Julian Satran/Haifa/IBM@IBMIL, [email-masked]  
                                         cc:                                                     
                    27-09-01 15:09       Subject:     RE: iscsi : Data ACKs already been         
                    Please respond        included into draft (?)                                
                    to Black_David                                                               

Julian,