Subject: RE: iscsi : default iscsi mode page settings - Consensus call

From: Robert Snively <[email-masked]>
Date: Wed, 26 Sep 2001 16:54:32 -0700

I object.

SCSI knows how to handle these.  These are 
properties of LUs and have nothing to do with
the transport mechanism itself.

Bob

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 4:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: iscsi : default iscsi mode page settings - Consensus call
> 
> 
> My reading of this mail thread is that there is rough consensus
> to negotiate/set FirstBurstSize and MaxBurstSize via iSCSI
> login/text keys and only via such keys.  If some aspect of the
> SCSI protocol requires that they be readable via a mode page,
> the mode page values will be read-only.  Julian's objection to
> this is noted - anyone else who objects to this should post to
> the list.
> 
> Thanks,
> --David
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------
> 
> 
>

---

From: Santosh Rao <[email-masked]>
Date: Wed, 26 Sep 2001 19:02:46 -0700

David,

By specifying that these values be read-only in mode pages, we have
retained some of the complexity that lies in having to go across layers
to communicate the defaults to the scsi layer, or alternatively to have
the target's iscsi layer snoop for such mode sense commands and respond
to them.

I would prefer to see iscsi declare these fields as reserved in the
iscsi definition of the mode pages [like is done in SPI-4 for
FirstBurstSize] so that this issue does not arise at all.

Thanks,
Santosh

> > If some aspect of the
> > the mode page values will be read-only.