Subject: iSCSI - do we need anything in the mode pages?

From: "Julian Satran" <[email-masked]>
Date: Fri, 28 Sep 2001 06:50:16 +0300

Dear colleagues:

We have now only two scraps of information in the iSCSI mode page:

   EMDP
   CRN

I suggest we take EMDP out (for simplicity) and reintroduce
DataSequenceInOrder

Unfortunately we can't do anything about CRN - but since it is not strictly
an iSCSI issue
we can just as for it to be placed honorably in commonly used per-LU page
by T10.

Please comment.

Julo

---

From: Santosh Rao <[email-masked]>
Date: Thu, 27 Sep 2001 22:18:48 -0700 (PDT)

Julian,

I fully support this move. 

The "Enable CRN" bit should be a SCSI ULP feature. The EPDC bit of FCP-2 
is a layering mess-up in FCP-2 since it is not clear if
they are testing for CRN support in their target FCP layer's FCP_CMD IU,
or whether they are testing their device server or both.

A new bit can be introduced in the "Control Mode Page" which is bag of
bits that verify SCSI ULP features currently. This "Enable CRN" bit should
purely test the device server since this is a ULP peer to peer check. In
addition, the FCP-2 folks would check the EPDC bit to test their target
SCSI LLP's capability to handle the CRN in its FCP_CMD IU.

Perhaps, this can be one of the iscsi requests for change in T10, along
with the rest of the changes that iscsi is driving. iSCSI would then
attach no special semantics to any of its mode pages.

Thanks,
Santosh

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Rod Harrison" <[email-masked]>
Date: Fri, 28 Sep 2001 08:49:34 +0100

I am in favour of this.

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Friday, September 28, 2001 4:50 AM
To: [email-masked]
Subject: iSCSI - do we need anything in the mode pages?
Importance: High

Dear colleagues:

   EMDP
   CRN

Unfortunately we can't do anything about CRN - but since it is not
strictly
an iSCSI issue
we can just as for it to be placed honorably in commonly used per-LU
page
by T10.

Please comment.

Julo

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 28 Sep 2001 11:34:19 -0400

Good, this relieves a long back concern of mine too.

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, September 27, 2001 11:50 PM
To: [email-masked]
Subject: iSCSI - do we need anything in the mode pages? 
Importance: High

Dear colleagues:

   EMDP
   CRN

Please comment.

Julo