Subject: Re: ISCSI: question about text command data

From: "Julian Satran" <[email-masked]>
Date: Tue, 18 Sep 2001 10:21:12 +0300

I think that it is as easy to discard as to check and sending an error for
non-conformance is
costly.

Julo

Mark Bakke <[email-masked]>@cisco.com on 17-09-2001 15:57:24

Please respond to Mark Bakke <[email-masked]>

Sent by:  [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Re: ISCSI: question about text command data

Julian-

Wouldn't it be simpler to just say "exactly one".  The last
part of Buck's question mentioned that he didn't see why
anyone would want more than one, and nobody responded saying
they did.

Thanks,

Mark

Julian Satran wrote:
>
> I've changed it the text to "at least one" to avoid errors hard to list.
>
> Julo
>
> "Buck Landry" <[email-masked]>@ece.cmu.edu on 13-09-2001 01:25:36
>
> Please respond to "Buck Landry" <[email-masked]>
>
> Sent by:  [email-masked]
>
> To:   <[email-masked]>
> cc:
> Subject:  ISCSI: question about text command data
>
> I have a small question about what separates the "key=value" pairs in
> the data segment of an iscsi text command.  On pg. 78 of the iscsi v7-90
> draft (2.10.5), it states:
>
> >>>
> Every key=value pair (including the last or only pair) MUST be followed
> by null (0x00) delimiter.
> <<<
>
> The question: is it legal to have *more* than one null char between
> key=value pairs?  (no, I don't know why anybody would particularly want
> to do this.)
>
> Thanks,
> buck

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Tue, 18 Sep 2001 07:39:43 -0500

OK; I'll buy that.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054