Subject: iscsi : default iscsi mode page settings - Consensus call

From: [email-masked]
Date: Wed, 26 Sep 2001 18:59:32 -0400

My reading of this mail thread is that there is rough consensus
to negotiate/set FirstBurstSize and MaxBurstSize via iSCSI
login/text keys and only via such keys.  If some aspect of the
SCSI protocol requires that they be readable via a mode page,
the mode page values will be read-only.  Julian's objection to
this is noted - anyone else who objects to this should post to
the list.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Sanjeev Bhagat \(TRIPACE/Zoetermeer\)" <[email-masked]>
Date: Thu, 27 Sep 2001 12:29:24 +0200

I am in favour of putting FirstBurstSize and MaxBurstSize in login/text keys
but i object in removing it from SCSI mode Page. I am not sure if it is a
good idea to keep SCSI mode page parameters as read only because it also
goes against the semantics of mode parameter definitions. However it leads
to a lot of complexities if an initiator is allowed to change mode
parameters both by login keys as well as mode select command. I guess it is
still a debatable issue.

Sanjeev

---

From: Ralph Weber <[email-masked]>
Date: Sun, 30 Sep 2001 19:53:33 -0500

I object to the proposal that Maximum Burst Size
be made "reserved" in the Disconnect-Reconnect
mode page. iSCSI has a Maximum Burst Size and
I read SPC-2 to promise applications that such
a value will appear in the proper field in the
Disconnect-Reconnect mode page.

Recourse to the SPI-4 definition of First Burst Size
is a lame defense since SPI-4 simply has no First
Burst Size concept to present in the Disconnect-
Reconnect mode page. First Burst Size was invented
for FCP-2 and never had any meaning for the
parallel SCSI bus.

Since SCSI-2 there has been a promise that the
Maximum Burst Size field in the Disconnect-Reconnect
mode page will have meaning. Any application that
sees zero (the preferred value for "reserved") in
that field has every right to assume it means what
SPC-2 says zero means, to whit: "A value of zero
indicates there is no limit on the amount of data
transferred per data transfer operation."

I disapprove of the proposal that First Burst Size
be made "reserved" in the Disconnect-Reconnect
mode page, since iSCSI has a First Burst Size
value that could appear in the mode page. But
owning to the parallel SCSI usage, the most that
can be said about iSCSI making the field reserved
is that doing so would be very bad form.

There is no basis for insisting that either of
these parameters be "changeable" via a MODE SELECT
command, and I leave that choice to iSCSI.

However, you all might consider remaining silent on
the subject and thus allowing vendors whose customers
have real needs the option of making the parameters
changeable without failing to meet iSCSI compliance
tests.

Knowing when to say nothing also is part of the
art of standards writing.

Thanks for your consideration.

Ralph Weber
SPC-2 technical editor