Subject: RE: ISCSI: question about text command data

From: "CONGDON,PAUL (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 18 Sep 2001 08:11:00 -0700

I disagree.  There is no reason why the spec shouldn't be very specific
about what behavior to take.  In the interest of simplicity, the spec should
state 'exactly one null character' as Mark and Buck request.   If people
follow the spec, there won't be a need to invoke costly error response.

Paul

-----Original Message-----
From: Steve Senum [mailto:[email-masked]]
Sent: Monday, September 17, 2001 8:27 AM
To: ietf-ips
Subject: Re: ISCSI: question about text command data

Mark,

I agree with Julian on this issue.

Steve Senum

Mark Bakke wrote:
> 
> Julian-
> 
> Wouldn't it be simpler to just say "exactly one".  The last
> part of Buck's question mentioned that he didn't see why
> anyone would want more than one, and nobody responded saying
> they did.
> 
> Thanks,
> 
> Mark
> 
> Julian Satran wrote:
> >
> > I've changed it the text to "at least one" to avoid errors hard to list.
> >
> > Julo
> >
> > "Buck Landry" <[email-masked]>@ece.cmu.edu on 13-09-2001
01:25:36
> >
> > Please respond to "Buck Landry" <[email-masked]>
> >
> > Sent by:  [email-masked]
> >
> > To:   <[email-masked]>
> > cc:
> > Subject:  ISCSI: question about text command data
> >
> > I have a small question about what separates the "key=value" pairs in
> > the data segment of an iscsi text command.  On pg. 78 of the iscsi v7-90
> > draft (2.10.5), it states:
> >
> > >>>
> > Every key=value pair (including the last or only pair) MUST be followed
> > by null (0x00) delimiter.
> > <<<
> >
> > The question: is it legal to have *more* than one null char between
> > key=value pairs?  (no, I don't know why anybody would particularly want
> > to do this.)
> >
> > Thanks,
> > buck
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054

---

From: "Dev" <[email-masked]>
Date: Tue, 18 Sep 2001 11:12:12 -0700

Yes. The spec should specifically state that there has to 'exactly one NULL
character'.

Deva
Adaptec

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
CONGDON,PAUL (HP-Roseville,ex1)
Sent: Tuesday, September 18, 2001 8:11 AM
To: 'Steve Senum'; ietf-ips
Subject: RE: ISCSI: question about text command data

Paul

-----Original Message-----
From: Steve Senum [mailto:[email-masked]]
Sent: Monday, September 17, 2001 8:27 AM
To: ietf-ips
Subject: Re: ISCSI: question about text command data

Mark,

Steve Senum

01:25:36

---

From: Santosh Rao <[email-masked]>
Date: Tue, 18 Sep 2001 11:35:49 -0700

I agree with Paul, Mark, Dev that the spec must require that login "key=value"
pairs MUST be seperated by EXACTLY 1 null (0x00) delimiter. Failure to comply
results in the target detecting a format error on the login PDU.

- Santosh