Subject: iSCSI 07-95 Comment 1

From: Thomas Dineen <[email-masked]>
Date: Tue, 25 Sep 2001 18:15:00 -0700

GentlePeople:

"3.2.1.1 X
The X bit is used as a Retry/Restart indicator for request PDUs (PDUs
from initiator to target). This bit is always 1 for response PDUs
(PDUs from target to initiator)."

"3.2.1.2 I
The I bit is used as immediate delivery marker for request PDUs (PDUs
from initiator to target). This bit is always 1 for response PDUs
(PDUs from target to initiator)."

- Reading the above paragraphs I do not get a sence of whether the
X and I bits are active for a one or zero state. Please specify the
logical function of both the X and I bits for both the one and zero
states.

Thomas Dineen

---

From: [email-masked]
Date: Wed, 26 Sep 2001 18:54:17 -0400

Like all other bits, the X bit is active when set to '1'.  --David

> -----Original Message-----
> From: Thomas Dineen [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 5:35 PM
> To: Sanjeev Bhagat (TRIPACE/Zoetermeer)
> Cc: [email-masked]; Thomas Dineen
> Subject: Re: iSCSI 07-95 Comment 1
> 
> 
> Sanjeev:
> 
>   I disagree!
> 
>   Maybe I should have provided a few more words in my 
> original comment.
> 
>   For example the X Bit: Dose a one state mean Retry? Dose a zero mean
> Restart?
> 
>   We need to specify what happens when the bit is one and what if
> anything happens
> when the bit is zero.
> 
>    These details are specified for other variables in the draft.
> 
> Thomas Dineen
> 
> 
> "Sanjeev Bhagat (TRIPACE/Zoetermeer)" wrote:
> > 
> > Gentleman :),
> > 
> > The PDU described is a data structure and not a hardware 
> signal on a bus. So
> > it is not necessary to define it as active or negative.
> > 
> > Am I wrong??
> > 
> > Sanjeev
> > 
> > -----Original Message-----
> > From: Thomas Dineen [mailto:[email-masked]]
> > Sent: Wednesday, September 26, 2001 3:15 AM
> > To: [email-masked]; Thomas Dineen
> > Subject: iSCSI 07-95 Comment 1
> > 
> > GentlePeople:
> > 
> > "3.2.1.1 X

---

From: Robert Snively <[email-masked]>
Date: Wed, 26 Sep 2001 16:58:35 -0700

IEEE and ANSI have discovered that such misunderstandings
and misinterpretations are so common that their convention
is to explicitly define the
behavior when a bit is "1" and when a bit is "0".  The classics
are bits with a double negative, like "disable checking".
I would recommend we consider following the same
conventions, even if they are not explicitly required by
IETF conventions.

Bob

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 3:54 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: iSCSI 07-95 Comment 1
> 
>