Subject: iscsi : Re : iSCSI PDU Formats

From: Santosh Rao <[email-masked]>
Date: Wed, 26 Sep 2001 11:49:29 -0700 (PDT)

Julian & All,

I support Bob Russell's suggestion below to split the CXnSG field into 2
separate fields, namely, CS & NS. This keeps the coding and manipulation
of this structure field simpler.

Thanks,
Santosh

Bob Russell wrote :

> 2. The Login Request and Login Response PDUs now have a new 4-bit
>    field labelled CNxSG.  This field consists of 2 2-bit parts.
> 
>    I propose labeling each part separately -- bits 0-1 to be
>    labeled "CS" for Current Stage, bits 2-3 "NS" for Next Stage.
>  
>  I believe this makes understanding and coding much simpler,
>  because in all cases these fields are interpreted separately,
>  and when the T bit is 0 the Next Stage has to be ignored.
>  It is a lot easier to ignore it if it is a separate field.
>
>
>Thank you.
>
>Bob Russell
>InterOperability Lab
>University of New Hampshire
>[email-masked]
>603-862-3774

-- 
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 26 Sep 2001 22:57:28 +0300

It has been done already - Julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     [email-masked] (ips)                           
                    hp.com>              cc:                                                     
                    Sent by:             Subject:     iscsi : Re : iSCSI PDU Formats             
                    owner-ips@ece.                                                               
                    cmu.edu                                                                      

                    26-09-01 20:49                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

Julian & All,

Thanks,
Santosh