Subject: Re: iSCSI - Recovery Levels

From: "Julian Satran" <[email-masked]>
Date: Tue, 4 Sep 2001 06:54:10 +0300

John,

It is only a placeholder - I will put in a TBD there too!

Julo

John Hufferd@IBMUS
03-09-2001 22:14

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
From: John Hufferd/San Jose/IBM@IBMUS
Subject:  Re: iSCSI - Recovery Levels  (Document link: Julian Satran -
      Mail)

Julian,
The way you have written it, only two levels can be specified, since level
one contains all the currently know levels.  Perhaps, you need to leave
some space between Zero and Everything currently known, by assigning
Everything to be number 2, or, 3 etc.  If we define it to be the number 2
for instance then it is possible that we only define 0 and 2 but it would
leave room for a 1 if one was defined.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]

Julian Satran/Haifa/IBM@[email-masked] on 09/03/2001 06:59:38 AM

Sent by:  [email-masked]

To:   [email-masked]
cc:
Subject:  iSCSI - Recovery Levels

There seems to be consensus around the fact the recovery leves are good and
no
clear consensus about hpow many should there be (2 or 3).

As there is no chance to settle this until 08 gets out I suggest
intrdocucing
a generic key=value pair (RecoveryLevel) and remove the existing keys
(CommmandFailoverSupport and CommandReplaySupport).

RecoveryLevel will be defined as follows:

01   RecoveryLevel

   Use: LO
   Who can send: Initiator and Target

   RecoveryLevel=<0 to x>

   Default is 0.

   Initiator and target negotiate the recovery level supported.
   The minimum of the two values is selected.

   Recovery levels represent a combination of recovery capabilities.
   Each recovery level includes all the capabilities of the lower recovery
   levels and adds to them some new ones.

   In the recovery mechanisms descriptions some specific recovery
   capabilities are used.

   Those are mapped to levels as follows:

      0 - SessionRecovery
      1 - CommandFailoverSupport and CommandReplaySupport
      [TBD]

 Comments?

 Julo

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 04 Sep 2001 11:03:24 PDT

Julian,

As per our conversation over the phone last Friday (8/28),
I thought I am doing this error recovery editing (in fact 
I am mostly done to send the doc in a few hours to you!).

Also, I thought we both agreed that I would capture what 
was presented in London in rev08 and state clearly that it's 
still under debate.  That is exactly what I summarized and sent
an email to ips on Friday afternoon!

*Please* allow us to stick to this plan, so I can manage 
to complete my editing today.  I do not want to get into 
a debate on the striation details *until* we publish rev08 -
which I thought we plan to publish by tomorrow.

Regards.
--
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 04 Sep 2001 12:52:09 PDT

To those interested in this bit of editing confusion...

Good news is that Julian and I are still thinking the
same on error recovery plans for rev08 :-)  I misunderstood 
what Julian implied when he outlined only two levels, when
we had 0-4 levels in London proposals.  Julian was 
in fact suggesting London proposals to be put in rev08.

Apologies to Julian since my quick note of surprise seems 
to have surprised him.
--
Mallikarjun 

Mallikarjun Chadalapaka