Subject: Re: iscsi : default iscsi mode page settings - Consensus call

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 10:10:05 +0300

I never really objected to (this the way I had them). I wanted to remove
the former objections of having the same information in 2 places although
it was read-only in mode pages in 07 already.

Julo

                    Black_David@em                                                               
                    c.com                To:     Julian Satran/Haifa/IBM@IBMIL                   
                                         cc:     [email-masked]                                 
                    27-09-01 00:59       Subject:     iscsi : default iscsi mode page settings - 
                    Please respond        Consensus call                                         
                    to Black_David                                                               

My reading of this mail thread is that there is rough consensus
to negotiate/set FirstBurstSize and MaxBurstSize via iSCSI
login/text keys and only via such keys.  If some aspect of the
SCSI protocol requires that they be readable via a mode page,
the mode page values will be read-only.  Julian's objection to
this is noted - anyone else who objects to this should post to
the list.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 10:19:12 +0300

I never really objected to (this the way I had them). I wanted to remove
the former objections of having the same information in 2 places although
it was read-only in mode pages in my first changes to 07 already.

Julo

                    Black_David@em                                                               

Thanks,
--David

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 10:25:37 +0300

Julo

                    Black_David@em                                                               

Thanks,
--David

---

From: "Binford, Charles" <[email-masked]>
Date: Thu, 27 Sep 2001 08:05:26 -0400

I disagree that read only mode parameters goes against the semantics of mode
parameter definitions.  SCSI even has a special option to the mode sense
command to allow an initiator to determine if a parameter is read only or
read/write (changeable).  That said, I still do not see a compelling reason
to expose the login/text key value of firstBurstSize in the mode page.

Charles Binford
Pirus Networks
316.315.0382 x222

-----Original Message-----
From: Sanjeev Bhagat (TRIPACE/Zoetermeer)
[mailto:[email-masked]]
Sent: Thursday, September 27, 2001 5:29 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: iscsi : default iscsi mode page settings - Consensus call

I am in favour of putting FirstBurstSize and MaxBurstSize in login/text keys
but i object in removing it from SCSI mode Page. I am not sure if it is a
good idea to keep SCSI mode page parameters as read only because it also
goes against the semantics of mode parameter definitions. However it leads
to a lot of complexities if an initiator is allowed to change mode
parameters both by login keys as well as mode select command. I guess it is
still a debatable issue.

Sanjeev

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 19:47:21 +0300

Is the disconnect reconnect page usually initiator specific?

Julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     Julian Satran/Haifa/IBM@IBMIL                   
                    hp.com>              cc:     [email-masked]                                 
                    Sent by:             Subject:     Re: iscsi : default iscsi mode page        
                    [email-masked]        settings - Consensus call                              
                    p.com                                                                        

                    27-09-01 18:35                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

Julian,

As we've discussed earlier, SCSI level software looking at transport
specific mode pages MUST be aware of the format of those mode pages for
the given transport. (For example : The format of the
disconnect-reconnect mode page is different for SPI-4, FCP-2, SRP &
iSCSI).

Thus, any SCSI level software needs to first be upgraded when new SCSI
transports come along, before it can understand the mode page formats of
that transport.

By declaring the iscsi mode page fields as reserved, you would not be
breaking any legacy software. There is no legacy issue here.

Regards,
Santosh

Julian Satran wrote:
>
> Santosh,
>
> You ignore the fact that there might be SCSI level software that may want
> those values.
>
> Julo
>
>
>                     Santosh Rao
>                     <santoshr@cup.       To:     "[email-masked]'"
<[email-masked]>,
>                     hp.com>               [email-masked]
>                     Sent by:             cc:
>                     owner-ips@ece.       Subject:     Re: iscsi : default
iscsi mode page
>                     cmu.edu               settings - Consensus call
>
>
>                     27-09-01 04:02
>                     Please respond
>                     to Santosh Rao
>
>
>
> David,
>
> By specifying that these values be read-only in mode pages, we have
> retained some of the complexity that lies in having to go across layers
> to communicate the defaults to the scsi layer, or alternatively to have
> the target's iscsi layer snoop for such mode sense commands and respond
> to them.
>
> I would prefer to see iscsi declare these fields as reserved in the
> iscsi definition of the mode pages [like is done in SPI-4 for
> FirstBurstSize] so that this issue does not arise at all.
>
> Thanks,
> Santosh
>
> > > If some aspect of the
> > > the mode page values will be read-only.
>
> #### santoshr.vcf has been removed from this note on September 27 2001 by
> Julian Satran

--
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################