Subject: iSCSI: Async events - SCSI and iSCSI

From: Mark Bakke <[email-masked]>
Date: Wed, 05 Sep 2001 15:09:12 -0500

Julian-

I was looking at Async Message some more, and noticed that there
is nothing to stop a target from sending a message that includes
both iSCSI and SCSI events, since each of these are communicated
with a different set of fields.  I would guess that this is not
what is intended, and that the target ought to send one or the other.

Can we add some text to say:

   A target may send this message as either a SCSI Event or an
   iSCSI Event, but not both.  Either the SCSI Event or iSCSI
   Event field MUST be zero.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 6 Sep 2001 11:18:24 -0400

In this case, why not just combine the fields?

Eddy

-----Original Message-----
From: Mark Bakke [mailto:[email-masked]]
Sent: Wednesday, September 05, 2001 4:09 PM
To: IPS
Subject: iSCSI: Async events - SCSI and iSCSI

Julian-

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054