Subject: Re: iscsi : default iscsi mode page settings - Consensus call

From: "Julian Satran" <[email-masked]>
Date: Thu, 27 Sep 2001 11:58:01 +0300

Santosh,

You ignore the fact that there might be SCSI level software that may want
those values.

Julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     "[email-masked]'" <[email-masked]>,  
                    hp.com>               [email-masked]                                        
                    Sent by:             cc:                                                     
                    owner-ips@ece.       Subject:     Re: iscsi : default iscsi mode page        
                    cmu.edu               settings - Consensus call                              

                    27-09-01 04:02                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

David,

By specifying that these values be read-only in mode pages, we have
retained some of the complexity that lies in having to go across layers
to communicate the defaults to the scsi layer, or alternatively to have
the target's iscsi layer snoop for such mode sense commands and respond
to them.

I would prefer to see iscsi declare these fields as reserved in the
iscsi definition of the mode pages [like is done in SPI-4 for
FirstBurstSize] so that this issue does not arise at all.

Thanks,
Santosh

> > If some aspect of the
> > SCSI protocol requires that they be readable via a mode page,
> > the mode page values will be read-only.

#### santoshr.vcf has been removed from this note on September 27 2001 by
Julian Satran

---

From: Santosh Rao <[email-masked]>
Date: Thu, 27 Sep 2001 09:35:50 -0700

Julian,

As we've discussed earlier, SCSI level software looking at transport
specific mode pages MUST be aware of the format of those mode pages for
the given transport. (For example : The format of the
disconnect-reconnect mode page is different for SPI-4, FCP-2, SRP &
iSCSI).

Thus, any SCSI level software needs to first be upgraded when new SCSI
transports come along, before it can understand the mode page formats of
that transport.

By declaring the iscsi mode page fields as reserved, you would not be
breaking any legacy software. There is no legacy issue here. 

Regards,
Santosh

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################