Subject: ISCSI: question about text command data

From: "Buck Landry" <[email-masked]>
Date: Wed, 12 Sep 2001 17:25:36 -0500

I have a small question about what separates the "key=value" pairs in
the data segment of an iscsi text command.  On pg. 78 of the iscsi v7-90
draft (2.10.5), it states:

Every key=value pair (including the last or only pair) MUST be followed
by null (0x00) delimiter.
<<<

The question: is it legal to have *more* than one null char between
key=value pairs?  (no, I don't know why anybody would particularly want
to do this.)

Thanks,
buck

---

From: "Lee Xing" <[email-masked]>
Date: Tue, 18 Sep 2001 14:23:26 -0500

Agree with Santosh, Paul, Mark and Dev.  The statement on page 64 of
v.07 "Every key=value pair (including the last or only pair) MUST be
followed by null (0x00) delimiter." implies **one** null should be used.
It's better to explicitly address that EXACTLY one null MUST be used to
separate "key=value" pairs.  Also, using two nulls (0x00) after the last
or only "key=value" pair is handy for programmers.

Thanks.

Lee
Crossroads Systems, Inc.

-----Original Message-----
From: Santosh Rao [mailto:[email-masked]]
Sent: Tuesday, September 18, 2001 1:36 PM
To: ietf-ips
Subject: Re: ISCSI: question about text command data

I agree with Paul, Mark, Dev that the spec must require that login
"key=value"
pairs MUST be seperated by EXACTLY 1 null (0x00) delimiter. Failure to
comply
results in the target detecting a format error on the login PDU.

- Santosh

Dev wrote:

> Yes. The spec should specifically state that there has to 'exactly one
NULL
> character'.
>
> Deva
> Adaptec
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> CONGDON,PAUL (HP-Roseville,ex1)
> Sent: Tuesday, September 18, 2001 8:11 AM
> To: 'Steve Senum'; ietf-ips
> Subject: RE: ISCSI: question about text command data
>
> I disagree.  There is no reason why the spec shouldn't be very
specific
> about what behavior to take.  In the interest of simplicity, the spec
should
> state 'exactly one null character' as Mark and Buck request.   If
people
> follow the spec, there won't be a need to invoke costly error
response.
>
> Paul
>
> -----Original Message-----
> From: Steve Senum [mailto:[email-masked]]
> Sent: Monday, September 17, 2001 8:27 AM
> To: ietf-ips
> Subject: Re: ISCSI: question about text command data
>
> Mark,
>
> I agree with Julian on this issue.
>
> Steve Senum
>
> Mark Bakke wrote:
> >
> > Julian-
> >
> > Wouldn't it be simpler to just say "exactly one".  The last
> > part of Buck's question mentioned that he didn't see why
> > anyone would want more than one, and nobody responded saying
> > they did.
> >
> > Thanks,
> >
> > Mark
> >
> > Julian Satran wrote:
> > >
> > > I've changed it the text to "at least one" to avoid errors hard to
list.
> > >
> > > Julo
> > >
> > > "Buck Landry" <[email-masked]>@ece.cmu.edu on 13-09-2001
> 01:25:36
> > >
> > > Please respond to "Buck Landry" <[email-masked]>
> > >
> > > Sent by:  [email-masked]
> > >
> > > To:   <[email-masked]>
> > > cc:
> > > Subject:  ISCSI: question about text command data
> > >
> > --
> > Mark A. Bakke
> > Cisco Systems
> > [email-masked]
> > 763.398.1054

---

From: Dave Sheehy <[email-masked]>
Date: Tue, 18 Sep 2001 13:34:50 PDT

> anyone would want more than one, and nobody responded saying

Agreed.

Dave Sheehy

---

From: "Buck Landry" <[email-masked]>
Date: Tue, 18 Sep 2001 16:21:31 -0500

The below might imply that I actually take a position on what should
appear in the data segment after a key-value pair.

I don't care much *what* goes in there, both approaches have good
reasoning; I would just like to see it specified as 'exactly one', or
'one or more', so there's no confusion.

If we decide on 'exactly one' .. (are leading NULLs allowed?) .. that
would seem to preclude using "double nulls" as Lee speaks of. (unless
julian somehow takes that into account in his wording)

regards,
Buck

-----Original Message-----
From: CONGDON,PAUL (HP-Roseville,ex1) [mailto:[email-masked]]
Sent: Tuesday, September 18, 2001 10:11 AM
To: 'Steve Senum'; ietf-ips
Subject: RE: ISCSI: question about text command data

I disagree.  There is no reason why the spec shouldn't be very specific
about what behavior to take.  In the interest of simplicity, the spec
should
state 'exactly one null character' as Mark and Buck request.   If people
follow the spec, there won't be a need to invoke costly error response.

Paul

-----Original Message-----
From: Steve Senum [mailto:[email-masked]]
Sent: Monday, September 17, 2001 8:27 AM
To: ietf-ips
Subject: Re: ISCSI: question about text command data

Mark,

Steve Senum

list.
01:25:36

---

From: Bart Crane <[email-masked]>
Date: Wed, 26 Sep 2001 19:50:40 -0700

Because there is no guarantee that the terminating nul is actually there,
you have to examine every character up to the last according to the data
segment size.  Thus, "at least one" has negligible effect on performance.

Some implementations may keep their strings on 4- or 8-byte boundaries,
zero-padded to a multiple of 4 bytes, use 2 fewer bits to represent their
size, and dma them directly into the network adapter.  In this case, "only
one" could impact performance negatively.  

The double-null can be handy, but it can also be viewed as a waste of a
byte;  an "implied" terminating null exists at the character pointed to in
the data segment at the offset specified by the size of the data segment.
And because that null is not guaranteed to be there, it may as well exist by
implication only.

I vote for "at least one" null.  

-----Original Message-----
From: Buck Landry [mailto:[email-masked]]
Sent: Tuesday, September 18, 2001 2:22 PM
To: ietf-ips
Subject: RE: ISCSI: question about text command data

regards,
Buck

-----Original Message-----
From: CONGDON,PAUL (HP-Roseville,ex1) [mailto:[email-masked]]
Sent: Tuesday, September 18, 2001 10:11 AM
To: 'Steve Senum'; ietf-ips
Subject: RE: ISCSI: question about text command data

Paul

-----Original Message-----
From: Steve Senum [mailto:[email-masked]]
Sent: Monday, September 17, 2001 8:27 AM
To: ietf-ips
Subject: Re: ISCSI: question about text command data

Mark,

Steve Senum

list.
01:25:36