Subject: Re: iscsi : numerical negotiation wording is ambiguous

From: "Julian Satran" <[email-masked]>
Date: Wed, 26 Sep 2001 22:49:19 +0300

Santosh,

I am missing something. The rule states what value both parties should have
after both have seen the two values.
Obviously we assume that no error occurs and the responder value is seen y
the offering party or the negotiation fails.

What exactly is ambiguous about it?

Julo

                    Santosh Rao                                                                  
                    <santoshr@cup.       To:     [email-masked] (ips)                           
                    hp.com>              cc:                                                     
                    Sent by:             Subject:     iscsi : numerical negotiation wording is   
                    owner-ips@ece.        ambiguous                                              
                    cmu.edu                                                                      

                    26-09-01 19:59                                                               
                    Please respond                                                               
                    to Santosh Rao                                                               

Julian & All,

The definition of numerical negotiation in Section 2.2.4 of Rev 7.97
reads :

"In numerical negotiations, the offering and responding party state
 a numerical value. The result of the negotiation is key dependent;
 frequently the lower or the higher of the two values is used."

The above definition is ambiguous, since it does not specify whether it is
the originator or the responder that computes the result of the
negotiation.

i.e. Is it the responsibility of the target to pick the higher or lower of
the 2 values and respond with the result of the negotiation ?

OR :
Is it the originator that has to pick the result of the negotiation
based on the key it sent and the key it got back ?

I would suggest that the wording be clarified to indicate that the
responder picks the result of the negotiation and sends this result back
in its response for this key.

Perhaps, some re-wording along the following lines may be in order :

"In numerical negotiations, the offering party states a numerical
 value, and the responding party states the result (operational value)
 after the negotiation.  The result of the negotiation is key
 dependent; responder determines it based on the lower or the higher
 of the two values - offering party's value, and what the responder
 can support."

Comments ?

Regards,
Santosh

--
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: Santosh Rao <[email-masked]>
Date: Wed, 26 Sep 2001 14:16:11 -0700

Julian,

What is the responding party supposed to offer ? Is it supposed to determine the result of the
negotiation (higher or lower value, as the case may be) and send that as its response ?

Or, is it supposed to send in its numerical value and the initiator picks the higher or lower of
the 2 ?

This does'nt come across clear enough in the definition and is open to mis-interpretation. Please
see the suggested re-word in its place.

Thanks,
Santosh