Subject: [Ips] What is the max size of value for CHAP_C for iSCSI

From: "Chaofeng Kao" <[email-masked]>
Date: Fri, 02 Sep 2005 09:35:33 -0600

I want to know do we have the maximum size of value for CHAP challenge
(CHAP_C) for iSCSI login process?

Thanks,

Chaofeng Kao
Platform Services
1-5458
[email-masked]
Novell, Inc., the leading provider of Net Services Software

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Paul Koning <[email-masked]>
Date: Fri, 2 Sep 2005 11:56:03 -0400

>>>>> "Chaofeng" == Chaofeng Kao <[email-masked]> writes:

 Chaofeng> I want to know do we have the maximum size of value for
 Chaofeng> CHAP challenge (CHAP_C) for iSCSI login process?

Section 11.1.4 says 1024 bytes.  If it's a strong random number (as it
should be) that's much more than is useful -- 16 bytes would be the
minimum adequate length, a bit more (up to 32 or so) would ok too.

	paul