Subject: [Ips] DataSequenceInOrder for non-immediate unsolicited

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 15 Sep 2005 09:26:58 -0400

12.9 DataSequenceInOrder

   If DataSequenceInOrder is set to Yes, Data Sequences MUST be
   transferred using continuously non-decreasing sequence offsets (R2T
   buffer offset for writes, or the smallest SCSI Data-In buffer offset
   within a read data sequence).

Up to the paren, this seems to apply to even non-immediate unsolicited but there is a slight implication here, by distinctly referencing the R2T, that this may not apply to non-immediate unsolicited PDUs. What is the correct interpretation?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Thu, 15 Sep 2005 21:38:28 +0300

Eddy,

The unsolicited data start at offset zero. DataSequenceInOrder governs 
only the sequence ordering.
Ordering within sequence is governed by DataPDUinOrder. 

Julo

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked]
15-09-05 16:26

To
<[email-masked]>
cc

Subject
[Ips] DataSequenceInOrder for non-immediate unsolicited

12.9 DataSequenceInOrder

Up to the paren, this seems to apply to even non-immediate unsolicited but 
there is a slight implication here, by distinctly referencing the R2T, 
that this may not apply to non-immediate unsolicited PDUs. What is the 
correct interpretation?
 
Eddy_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 15 Sep 2005 19:04:37 -0400

I understand that. My question is "does this also apply to non-immediate unsolicited"? I think the answer is yes but I need to get a clarification on that.

Perhaps Mallikarjun could change it to (unsolicited and R2T ... ).

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Thursday, September 15, 2005 2:38 PM
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

  Eddy, 

  The unsolicited data start at offset zero. DataSequenceInOrder governs only the sequence ordering. 
  Ordering within sequence is governed by DataPDUinOrder. 

  Julo 

        "Eddy Quicksall" <[email-masked]> 
        Sent by: [email-masked] 
        15-09-05 16:26 
       To <[email-masked]>  
              cc  
              Subject [Ips] DataSequenceInOrder for non-immediate unsolicited 

  12.9 DataSequenceInOrder 

    

------------------------------------------------------------------------------

---

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 09:22:04 +0300

The unsolicited data is always in order (it always start at offset zero). 
What has to apply? Why should Mallikarjun add the text? What is the 
question (please reformulate I have trouble understanding your point).

Julo

16-09-05 02:04

To
Julian Satran/Haifa/IBM@IBMIL
cc
<[email-masked]>, "Mallikarjun C." <[email-masked]>
Subject
Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

I understand that. My question is "does this also apply to non-immediate 
unsolicited"? I think the answer is yes but I need to get a clarification 
on that.

Eddy
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

Eddy, 

Julo 

To
<[email-masked]> 
cc

Subject

12.9 DataSequenceInOrder

---

From: "Surekha.PC" <[email-masked]>
Date: Fri, 16 Sep 2005 12:40:20 +0530

Hi Eddy,
 
I think DataSequenceInOrder "does not apply to non-immediate unsolicited Data PDUs" since only the
first outgoing sequence can be sent unsolicited, it always starts at offset 0 and is in order as
mentioned by Julian.
 
3.5.1.5 SCSI Data-out and SCSI Data-in
An outgoing sequence is either unsolicited (only the first sequence can be unsolicited) or consists
of all the Data-Out PDUs sent in response to an R2T.

So in my opinion the below text rightly says "DataSequenceInOrder applies only to R2T and SCSI Data
in buffer offsets". Hence I think there is no need for a change.
 
----------------------------------------------------------------------------------------------------
12.9 DataSequenceInOrder 
 
----------------------------------------------------------------------------------------------------
--
 
Pls let me know your comments.
 
Thanks,
Surekha

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Julian Satran
Sent: Friday, September 16, 2005 11:52 AM
To: Eddy Quicksall
Cc: [email-masked]; Mallikarjun C.
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

The unsolicited data is always in order (it always start at offset zero). What has to apply? Why
should Mallikarjun add the text? What is the question (please reformulate I have trouble
understanding your point). 

Julo 

16-09-05 02:04 

To

cc

Subject

I understand that. My question is "does this also apply to non-immediate unsolicited"? I think the
answer is yes but I need to get a clarification on that. 

Eddy 
----- Original Message ----- 
From:  <mailto:[email-masked]> Julian Satran 
To:  <mailto:[email-masked]> Eddy Quicksall 
Cc:  <mailto:[email-masked]> [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM 
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Eddy, 

Julo 

"Eddy Quicksall" < <mailto:[email-masked]>
[email-masked]> 
Sent by:  <mailto:[email-masked]> [email-masked] 

15-09-05 16:26 

To
< <mailto:[email-masked]> [email-masked]> 

cc

Subject

12.9 DataSequenceInOrder 

Up to the paren, this seems to apply to even non-immediate unsolicited but there is a slight
implication here, by distinctly referencing the R2T, that this may not apply to non-immediate
unsolicited PDUs. What is the correct interpretation? 

  _____

---

From: Paul Koning <[email-masked]>
Date: Fri, 16 Sep 2005 09:53:48 -0400

>>>>> "Surekha" == Surekha PC <Surekha.PC> writes:

 Surekha> Hi Eddy, I think DataSequenceInOrder "does not apply to
 Surekha> non-immediate unsolicited Data PDUs" since only the first
 Surekha> outgoing sequence can be sent unsolicited, it always starts
 Surekha> at offset 0 and is in order as mentioned by Julian.
 
 Surekha> 3.5.1.5 SCSI Data-out and SCSI Data-in An outgoing sequence
 Surekha> is either unsolicited (only the first sequence can be
 Surekha> unsolicited) or consists of all the Data-Out PDUs sent in
 Surekha> response to an R2T.

That text says "starts at offset 0" but it doesn't say "always in
order". 

	paul

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 16 Sep 2005 10:41:05 -0400

My point is that the information in parens mentions two things specifically (R2T
 buffer offset for writes, or the smallest SCSI Data-In buffer offset
 within a read data sequence). Since there is no "e.g." then this implies that these two things are the ones he is talking about.

What I'm saying is that if it were changed to say:

(non-immediate unsolicited, R2T
 buffer offset for writes, or the smallest SCSI Data-In buffer offset
 within a read data sequence)

then there would be no ambiguity.

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] ; Mallikarjun C. 
  Sent: Friday, September 16, 2005 2:22 AM
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

  The unsolicited data is always in order (it always start at offset zero). What has to apply? Why should Mallikarjun add the text? What is the question (please reformulate I have trouble understanding your point). 

  Julo 

        "Eddy Quicksall" <[email-masked]> 
        16-09-05 02:04 
       To Julian Satran/Haifa/IBM@IBMIL  
              cc <[email-masked]>, "Mallikarjun C." <[email-masked]>  
              Subject Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

    
    
  Eddy 
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Thursday, September 15, 2005 2:38 PM 
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  Eddy, 

  Julo 
       
              To <[email-masked]>  
              cc  

  12.9 DataSequenceInOrder

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 16 Sep 2005 10:44:00 -0400

The non-immediate unsolicited could be received out of order by the following events:

I-T Command
T-I R2T

If the initiator receives the R2T before it has begun to send the non-immediate unsolicited then, if DataSequenceInOrder is no, it could send the solicited data before sending the non-immediate unsolicited.

Eddy
  ----- Original Message ----- 
  From: Surekha.PC 
  To: 'Julian Satran' ; 'Eddy Quicksall' 
  Cc: [email-masked] ; 'Mallikarjun C.' 
  Sent: Friday, September 16, 2005 3:10 AM
  Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited

  Hi Eddy,

  I think DataSequenceInOrder "does not apply to non-immediate unsolicited Data PDUs" since only the first outgoing sequence can be sent unsolicited, it always starts at offset 0 and is in order as mentioned by Julian.

  3.5.1.5 SCSI Data-out and SCSI Data-in
  An outgoing sequence is either unsolicited (only the first sequence can be unsolicited) or consists of all the Data-Out PDUs sent in response to an R2T.

  So in my opinion the below text rightly says "DataSequenceInOrder applies only to R2T and SCSI Data in buffer offsets". Hence I think there is no need for a change.

  ------------------------------------------------------------------------------------------------------

  Thanks,
  Surekha

----------------------------------------------------------------------------

    Julo 

         

      
    Eddy 
    ----- Original Message ----- 
    From: Julian Satran 
    To: Eddy Quicksall 
    Cc: [email-masked] 
    Sent: Thursday, September 15, 2005 2:38 PM 
    Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

    Eddy, 

    Julo 
         
                To <[email-masked]>  
                cc  

    12.9 DataSequenceInOrder 

     

----------------------------------------------------------------------------

---

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 19:48:09 +0300

There is only one unsolicited sequence and it is the first and starting 
with 0 makes it ordered always.
I am bit tired about all this gibberish.

Julo

Paul Koning <[email-masked]> 
16-09-05 16:53

To
[email-masked]
cc
Julian Satran/Haifa/IBM@IBMIL, [email-masked], 
[email-masked], [email-masked]
Subject
RE: [Ips] DataSequenceInOrder for non-immediate unsolicited

 

                 paul

---

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 19:48:10 +0300

The unsolicited data is part of the "unsolicited sequence" (it has to end 
with the F bit set to one). The immediate part starts always at 0.
Al the unsolicited data-PDUs order is governed by the DataPDUinorder. I 
really don't see the need for any change in text.

Julo

16-09-05 17:41

To

My point is that the information in parens mentions two things 
specifically (R2T
 buffer offset for writes, or the smallest SCSI Data-In buffer offset
 within a read data sequence). Since there is no "e.g." then this implies 
that these two things are the ones he is talking about.

 
 
Eddy
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] ; Mallikarjun C. 
Sent: Friday, September 16, 2005 2:22 AM
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

Julo 

To

  
Eddy 
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM 
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Eddy, 

Julo 

To
<[email-masked]> 
cc

Subject

12.9 DataSequenceInOrder

---

From: Paul Koning <[email-masked]>
Date: Fri, 16 Sep 2005 12:52:17 -0400

>>>>> "Julian" == Julian Satran <[email-masked]> writes:

 Julian> There is only one unsolicited sequence and it is the first
 Julian> and starting with 0 makes it ordered always.  I am bit tired
 Julian> about all this gibberish.

Never mind, I was thinking about DataPDUInOrder.

      paul