Subject: Re: [Ips] Data Out PDU's

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 07 Sep 2005 09:16:16 -0700

While a literal reading of the text indeed implies what Gwendal says 
below, I do not believe that was really the intent of the RFC.  The rest 
of the paragraph text only discusses R2T handling within a task, not 
across tasks.  There are a couple of issues with the "must satisfy R2Ts 
in order across tasks" interpretation:

Since other transports, FC and SAS included, do not require in-order 
data sequence transfers (on R2T-analogs) across tasks, building bridge 
devices becomes complex.

With virtualizers, each task may in fact be serviced by a different 
"real" initiator, so enforcing order across them is complex.

For these reasons, I intend to clarify in the implementer's guide that 
RFC3720's intended servicing order of R2Ts is only within a task but not 
across tasks.  If you have concerns or questions on this proposed 
change, please speak up.

Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
StorageWorks Division
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

Gwendal Grignou wrote:
> 
> On Tue, 2005-08-30 at 14:18 -0400, Paul Koning wrote:
> 
>>>>>>>"Ken" == Ken Craig <[email-masked]> writes:
>>
>> Ken> I have a question about Data Out PDUs.  I, as a Target, have
>> Ken> negotiated DataSequenceInOrder and DataPDUInOrder.  If I
>> Ken> generate a R2T for two Write commands does the spec allow the
>> Ken> Data Out PDUs for those two R2T's to be intermingled even though
>> Ken> each Data Out PDU is in sequence and in order?  
>>
>>Yes -- the ordering requirement is for order within a transfer, i.e.,
>>a single write command.
> 
> I don't think so [10.8]:
> 
> Within a CONNECTION outstanding R2Ts MUST be fulfilled by the initiator
> in the order in which they were received.
> 
> Gwendal.
> 
> 
>>  paul
>>
>>
>>_______________________________________________
>>Ips mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/ips
> 
> 
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: William Studenmund <[email-masked]>
Date: Wed, 7 Sep 2005 10:49:20 -0700

On Sep 7, 2005, at 9:16 AM, Mallikarjun C. wrote:

> below, I do not believe that was really the intent of the RFC.  The 
> rest of the paragraph text only discusses R2T handling within a task, 
> not across tasks.  There are a couple of issues with the "must satisfy 
> R2Ts in order across tasks" interpretation:
>
> RFC3720's intended servicing order of R2Ts is only within a task but 
> not across tasks.  If you have concerns or questions on this proposed 
> change, please speak up.

I am fine with this change, and feel it reflects what was really 
intended.

Take care,

Bill