Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 19:48:10 +0300

That is not correct. The unsolicited data is a sequence and it has to be 
ended before anything else happens. Unsolicited data is equivalent to a 
"virtual R2T" with offset 0
and R2Ts have to be honored in order.

Julo
----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 -----

"Eddy Quicksall" <[email-masked]> 
16-09-05 17:44

To
"Surekha.PC" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
cc
<[email-masked]>, "'Mallikarjun C.'" <[email-masked]>
Subject
Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

The non-immediate unsolicited could be received out of order by the 
following events:
 
I-T Command
T-I R2T
 
If the initiator receives the R2T before it has begun to send the 
non-immediate unsolicited then, if DataSequenceInOrder is no, it could 
send the solicited data before sending the non-immediate unsolicited.
 
Eddy
----- Original Message ----- 
From: Surekha.PC 
To: 'Julian Satran' ; 'Eddy Quicksall' 
Cc: [email-masked] ; 'Mallikarjun C.' 
Sent: Friday, September 16, 2005 3:10 AM
Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited

Hi Eddy,
 
I think DataSequenceInOrder "does not apply to non-immediate unsolicited 
Data PDUs" since only the first outgoing sequence can be sent unsolicited, 
it always starts at offset 0 and is in order as mentioned by Julian.
 
3.5.1.5 SCSI Data-out and SCSI Data-in
An outgoing sequence is either unsolicited (only the first sequence can be 
unsolicited) or consists of all the Data-Out PDUs sent in response to an 
R2T.
So in my opinion the below text rightly says "DataSequenceInOrder applies 
only to R2T and SCSI Data in buffer offsets". Hence I think there is no 
need for a change.
 
----------------------------------------------------------------------------------------------------
12.9 DataSequenceInOrder 
 
  If DataSequenceInOrder is set to Yes, Data Sequences MUST be
 transferred using continuously non-decreasing sequence offsets (R2T
 buffer offset for writes, or the smallest SCSI Data-In buffer offset
 within a read data sequence). 
------------------------------------------------------------------------------------------------------
 
Pls let me know your comments.
 
Thanks,
Surekha
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Julian Satran
Sent: Friday, September 16, 2005 11:52 AM
To: Eddy Quicksall
Cc: [email-masked]; Mallikarjun C.
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

The unsolicited data is always in order (it always start at offset zero). 
What has to apply? Why should Mallikarjun add the text? What is the 
question (please reformulate I have trouble understanding your point). 

Julo 

"Eddy Quicksall" <[email-masked]> 
16-09-05 02:04 

To
Julian Satran/Haifa/IBM@IBMIL 
cc
<[email-masked]>, "Mallikarjun C." <[email-masked]> 
Subject
Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

I understand that. My question is "does this also apply to non-immediate 
unsolicited"? I think the answer is yes but I need to get a clarification 
on that. 
  
Perhaps Mallikarjun could change it to (unsolicited and R2T ... ). 
  
Eddy 
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM 
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Eddy, 

The unsolicited data start at offset zero. DataSequenceInOrder governs 
only the sequence ordering. 
Ordering within sequence is governed by DataPDUinOrder. 

Julo 
"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked] 
15-09-05 16:26 

To
<[email-masked]> 
cc

Subject
[Ips] DataSequenceInOrder for non-immediate unsolicited

12.9 DataSequenceInOrder 
 
  If DataSequenceInOrder is set to Yes, Data Sequences MUST be
 transferred using continuously non-decreasing sequence offsets (R2T
 buffer offset for writes, or the smallest SCSI Data-In buffer offset
 within a read data sequence). 
 
Up to the paren, this seems to apply to even non-immediate unsolicited but 
there is a slight implication here, by distinctly referencing the R2T, 
that this may not apply to non-immediate unsolicited PDUs. What is the 
correct interpretation? 
 
Eddy_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 16 Sep 2005 12:56:43 -0400

Julian, this is not gibberish. We are in the process of clearing up some cases for misunderstanding and I believe this is one such case. If you just remove the parened information then it would not be ambiguous.

Eddy

  ----- Original Message ----- 
  From: Julian Satran 
  To: [email-masked] 
  Cc: Surekha.PC ; [email-masked] ; Eddy Quicksall 
  Sent: Friday, September 16, 2005 12:48 PM
  Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

  That is not correct. The unsolicited data is a sequence and it has to be ended before anything else happens. Unsolicited data is equivalent to a "virtual R2T" with offset 0 
  and R2Ts have to be honored in order. 

  Julo 
  ----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 ----- 
        "Eddy Quicksall" <[email-masked]> 
        16-09-05 17:44 
       To "Surekha.PC" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL  
              cc <[email-masked]>, "'Mallikarjun C.'" <[email-masked]>  
              Subject Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  The non-immediate unsolicited could be received out of order by the following events: 
    
  I-T Command 
  T-I R2T 
    
  If the initiator receives the R2T before it has begun to send the non-immediate unsolicited then, if DataSequenceInOrder is no, it could send the solicited data before sending the non-immediate unsolicited. 
    
  Eddy 
  ----- Original Message ----- 
  From: Surekha.PC 
  To: 'Julian Satran' ; 'Eddy Quicksall' 
  Cc: [email-masked] ; 'Mallikarjun C.' 
  Sent: Friday, September 16, 2005 3:10 AM 
  Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  Hi Eddy, 
    
  I think DataSequenceInOrder "does not apply to non-immediate unsolicited Data PDUs" since only the first outgoing sequence can be sent unsolicited, it always starts at offset 0 and is in order as mentioned by Julian. 
    
  3.5.1.5 SCSI Data-out and SCSI Data-in 
  An outgoing sequence is either unsolicited (only the first sequence can be unsolicited) or consists of all the Data-Out PDUs sent in response to an R2T. 
  So in my opinion the below text rightly says "DataSequenceInOrder applies only to R2T and SCSI Data in buffer offsets". Hence I think there is no need for a change. 

    
    
  Thanks, 
  Surekha 

------------------------------------------------------------------------------
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Julian Satran
  Sent: Friday, September 16, 2005 11:52 AM
  To: Eddy Quicksall
  Cc: [email-masked]; Mallikarjun C.
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

  The unsolicited data is always in order (it always start at offset zero). What has to apply? Why should Mallikarjun add the text? What is the question (please reformulate I have trouble understanding your point). 

  Julo 

              To Julian Satran/Haifa/IBM@IBMIL  
              cc <[email-masked]>, "Mallikarjun C." <[email-masked]>  
              Subject Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  I understand that. My question is "does this also apply to non-immediate unsolicited"? I think the answer is yes but I need to get a clarification on that. 

  Eddy 
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Thursday, September 15, 2005 2:38 PM 
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  Eddy, 

  The unsolicited data start at offset zero. DataSequenceInOrder governs only the sequence ordering. 
  Ordering within sequence is governed by DataPDUinOrder. 

  Julo "Eddy Quicksall" <[email-masked]> 
        Sent by: [email-masked] 
        15-09-05 16:26 
       
              To <[email-masked]>  
              cc  
              Subject [Ips] DataSequenceInOrder for non-immediate unsolicited 

  12.9 DataSequenceInOrder 

  Up to the paren, this seems to apply to even non-immediate unsolicited but there is a slight implication here, by distinctly referencing the R2T, that this may not apply to non-immediate unsolicited PDUs. What is the correct interpretation? 

------------------------------------------------------------------------------

------------------------------------------------------------------------------

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 16 Sep 2005 13:04:36 -0400

>From RFC 3720 3.2.4.2: "on each connection . command N+1 MAY be sent before the unsolicited Data-Out PDUs for command N, but the unsolicited Data-out PDUs for command N MUST precede the unsolicited Data-Out PDUs of command N+1."

Is this what you are referring to? If so it doesn't say what you have stated below.

Eddy

  ----- Original Message ----- 
  From: Julian Satran 
  To: [email-masked] 
  Cc: Surekha.PC ; [email-masked] ; Eddy Quicksall 
  Sent: Friday, September 16, 2005 12:48 PM
  Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

  Julo 
  ----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 ----- 

    
  I-T Command 
  T-I R2T 

  Eddy 
  ----- Original Message ----- 
  From: Surekha.PC 
  To: 'Julian Satran' ; 'Eddy Quicksall' 
  Cc: [email-masked] ; 'Mallikarjun C.' 
  Sent: Friday, September 16, 2005 3:10 AM 
  Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  Hi Eddy, 

    

    
  Thanks, 
  Surekha 

  Julo 

              

   
  Eddy 
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Thursday, September 15, 2005 2:38 PM 
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

  Eddy, 

       
              To <[email-masked]>  
              cc  

  12.9 DataSequenceInOrder

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 16 Sep 2005 13:18:11 -0400

I'll accept that this may just be due to the way I read English and if others agree that the paren'd text does not exclude non-immediate unsolicited then just let me know that and I'll accept it.

Eddy
  ----- Original Message ----- 
  From: Eddy Quicksall 
  To: [email-masked] ; Julian Satran 
  Cc: [email-masked] 
  Sent: Friday, September 16, 2005 1:04 PM
  Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

  Eddy

    ----- Original Message ----- 
    From: Julian Satran 
    To: [email-masked] 
    Cc: Surekha.PC ; [email-masked] ; Eddy Quicksall 
    Sent: Friday, September 16, 2005 12:48 PM
    Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

    Julo 
    ----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 ----- 

      
    I-T Command 
    T-I R2T 

    Eddy 
    ----- Original Message ----- 
    From: Surekha.PC 
    To: 'Julian Satran' ; 'Eddy Quicksall' 
    Cc: [email-masked] ; 'Mallikarjun C.' 
    Sent: Friday, September 16, 2005 3:10 AM 
    Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited 

    Hi Eddy, 

      

      
    Thanks, 
    Surekha 

----------------------------------------------------------------------------

    Julo 

                

     
    Eddy 
    ----- Original Message ----- 
    From: Julian Satran 
    To: Eddy Quicksall 
    Cc: [email-masked] 
    Sent: Thursday, September 15, 2005 2:38 PM 
    Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

    Eddy, 

         
                To <[email-masked]>  
                cc  

    12.9 DataSequenceInOrder 

----------------------------------------------------------------------------

----------------------------------------------------------------------------

---

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 21:56:34 +0300

Eddy,

There is no ambiguity IMHO.

Julo

16-09-05 19:56

To
<[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
cc
"Surekha.PC" <[email-masked]>, <[email-masked]>
Subject
Re: [Ips] DataSequenceInOrder for non-immediate unsolicited

Julian, this is not gibberish. We are in the process of clearing up some 
cases for misunderstanding and I believe this is one such case. If you 
just remove the parened information then it would not be ambiguous.
 
Eddy
----- Original Message ----- 
From: Julian Satran 
To: [email-masked] 
Cc: Surekha.PC ; [email-masked] ; Eddy Quicksall 
Sent: Friday, September 16, 2005 12:48 PM
Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

Julo 
----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 ----- 

To

I-T Command 
T-I R2T 

Eddy 
----- Original Message ----- 
From: Surekha.PC 
To: 'Julian Satran' ; 'Eddy Quicksall' 
Cc: [email-masked] ; 'Mallikarjun C.' 
Sent: Friday, September 16, 2005 3:10 AM 
Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Hi Eddy, 

  

12.9 DataSequenceInOrder 

  
Thanks, 
Surekha 

Julo 

To

 
Eddy 
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM 
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Eddy, 

Julo 

To
<[email-masked]> 
cc

Subject

12.9 DataSequenceInOrder

---

From: Julian Satran <[email-masked]>
Date: Fri, 16 Sep 2005 21:56:34 +0300

There is another paragraph that specifies that R2Ts must be served in the 
order they where received and the "virtual one" is the first.

Julo

16-09-05 20:04

To

>From RFC 3720 3.2.4.2: ?on each connection ? command N+1 MAY be sent 
before the unsolicited Data-Out PDUs for command N, but the unsolicited 
Data-out PDUs for command N MUST precede the unsolicited Data-Out PDUs of 
command N+1.?
 
Is this what you are referring to? If so it doesn't say what you have 
stated below.
 
Eddy
----- Original Message ----- 
From: Julian Satran 
To: [email-masked] 
Cc: Surekha.PC ; [email-masked] ; Eddy Quicksall 
Sent: Friday, September 16, 2005 12:48 PM
Subject: Fw: [Ips] DataSequenceInOrder for non-immediate unsolicited

Julo 
----- Forwarded by Julian Satran/Haifa/IBM on 16-09-05 19:37 ----- 

To

I-T Command 
T-I R2T 

Eddy 
----- Original Message ----- 
From: Surekha.PC 
To: 'Julian Satran' ; 'Eddy Quicksall' 
Cc: [email-masked] ; 'Mallikarjun C.' 
Sent: Friday, September 16, 2005 3:10 AM 
Subject: RE: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Hi Eddy, 

  

12.9 DataSequenceInOrder 

  
Thanks, 
Surekha 

Julo 

To

 
Eddy 
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Thursday, September 15, 2005 2:38 PM 
Subject: Re: [Ips] DataSequenceInOrder for non-immediate unsolicited 

Eddy, 

Julo 

To
<[email-masked]> 
cc

Subject

12.9 DataSequenceInOrder