Subject: [Ips] timeout for R2T PDUs?

From: "Erez Zilber" <[email-masked]>
Date: Thu, 6 Nov 2008 09:24:34 +0200

Hi,

I couldn't find an answer to the following question in iSCSI spec:

During the execution of a WRITE command, an R2T PDU is sent from the
target to the initiator. What should happen if a bug in the initiator
causes it not to send the data-out PDU? Is there any timeout that will
allow the target to abort this command?

Thanks,
Erez
_______________________________________________
Ips mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ips

---

From: "Deva Ranganathan" <[email-masked]>
Date: Thu, 6 Nov 2008 14:49:51 +0530

On Thu, Nov 6, 2008 at 2:46 PM, Deva Ranganathan <[email-masked]
> wrote:

> Erez,
>
> I think that this s a target implementation issue wherein the
> implementation can choose the timeout  depending on the availability of
> resources  and the software architecture. A target also has a NOP-IN sent
> periodically and can use this to cleanup  the stale resources as well.
>
> thanks
>
> Deva
> HCL Technologies.
>
>
>
> On Thu, Nov 6, 2008 at 12:54 PM, Erez Zilber <[email-masked]>wrote:
>
>> Hi,
>>

---

From: Julian Satran <[email-masked]>
Date: Thu, 6 Nov 2008 08:09:32 -0500

Correct - there is no standard time-out. Regards, Julo

From:
"Deva Ranganathan" <[email-masked]>
To:
"Erez Zilber" <[email-masked]>
Cc:
[email-masked]
Date:
06/11/2008 04:20
Subject:
Re: [Ips] timeout for R2T PDUs?

On Thu, Nov 6, 2008 at 2:46 PM, Deva Ranganathan <
[email-masked]> wrote:
Erez,

thanks
 
Deva
HCL Technologies.

On Thu, Nov 6, 2008 at 12:54 PM, Erez Zilber <[email-masked]> 
wrote:
Hi,

Thanks,
Erez

---

From: "Erez Zilber" <[email-masked]>
Date: Thu, 6 Nov 2008 17:14:43 +0200

There could be a situation in which NOP-IN PDUs from the target are
sent successfully to the initiator, but some bug causes the initiator
not to send the data-out PDU. According to what you say, the target
may decide that it can't wait anymore and logout, right?

Thanks,
Erez

On Thu, Nov 6, 2008 at 3:09 PM, Julian Satran <[email-masked]> wrote:
> From: "Deva Ranganathan" <[email-masked]>
> To: "Erez Zilber" <[email-masked]>
> Cc: [email-masked]
> Date: 06/11/2008 04:20
> Subject: Re: [Ips] timeout for R2T PDUs?
> ________________________________
>
>
>
>
> On Thu, Nov 6, 2008 at 2:46 PM, Deva Ranganathan
> <[email-masked]> wrote:
> Erez,
>
> I think that this s a target implementation issue wherein the implementation
> can choose the timeout  depending on the availability of resources  and the
> software architecture. A target also has a NOP-IN sent periodically and can
> use this to cleanup  the stale resources as well.
>
> thanks
>
> Deva
> HCL Technologies.
>
>
>
> On Thu, Nov 6, 2008 at 12:54 PM, Erez Zilber <[email-masked]> wrote:
> Hi,
>

---

From: Julian Satran <[email-masked]>
Date: Thu, 6 Nov 2008 10:31:02 -0500

The target may try to finish the command with a "check condition" or some 
connection recovery before resorting  to the big hammer.

Julo

From:
"Erez Zilber" <[email-masked]>
To:
Julian Satran/Haifa/IBM@IBMIL
Cc:
"Deva Ranganathan" <[email-masked]>, [email-masked]
Date:
06/11/2008 10:15
Subject:
Re: [Ips] time-out for R2T PDUs?

Thanks,
Erez

> Subject: Re: [Ips] timeout for R2T PDUs?
implementation

---

From: "Erez Zilber" <[email-masked]>
Date: Thu, 6 Nov 2008 17:53:12 +0200

Got it. Thanks.

Erez

On Thu, Nov 6, 2008 at 5:31 PM, Julian Satran <[email-masked]> wrote:
> To: Julian Satran/Haifa/IBM@IBMIL
> Cc: "Deva Ranganathan" <[email-masked]>, [email-masked]
> Date: 06/11/2008 10:15
> Subject: Re: [Ips] time-out for R2T PDUs?

---

From: Ken Sandars <[email-masked]>
Date: Tue, 11 Nov 2008 20:02:51 +1100

Hi Erez,

Another option the target has is the recovery R2T as an attempt to provoke the initiator into action.

Cheers
Ken

> Date: Thu, 6 Nov 2008 17:53:12 +0200
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]

_________________________________________________________________
Time for change? Find your ideal job with SEEK.
http://a.ninemsn.com.au/b.aspx?URL=http%3A%2F%2Fninemsn%2Eseek%2Ecom%2Eau%2F%3Ftracking%3Dsk%3Atl%3Ask%3Anine%3A0%3Ahottag%3Achange&_t=757263783&_r=SEEK_tagline&_m=EXT