Subject: [Ipsec] Configuration Payload clarification

From: Ravi Kumar <[email-masked]>
Date: Fri, 10 Sep 2004 10:56:10 +0530

Hi,
       Section 3.15 (Configuration Payload) indicates that 
CFG_REQUEST/CFG-REPLY may optionally be added to any IKE 
request.

       Section 2.19 indicates that IRAC MUST request the 
IRAS controlled address in IKE-AUTH exchange.

       Does it mean that CFG-REQUEST/CFG-REPLY used to get 
the internal IP address on remote network, MUST be sent in 
IKE-AUTH exchange? If these payloads are with IP address 
attributes sent in any exchange (including informational), 
then can it be considered as ERROR by the receiving 
implementation?

  Thanks
  Ravi

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Srinivasa Rao Addepalli" <[email-masked]>
Date: Fri, 10 Sep 2004 10:08:39 -0700

----- Original Message ----- 
From: "Ravi Kumar" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, September 09, 2004 10:26 PM
Subject: [Ipsec] Configuration Payload clarification

> then can it be considered as ERROR by the receiving 

That is my understanding too.  Requesting internal address MUST
happen in AUTH exchange. As I understand, only reqeusting 
application version happens in informational exchange.
In future, some more attributes might be defined which can go in 
Informational exchange. As on today, I believe 'application version'
is the only attribute (as part of CP) can go in Informational exchange.

>  Ravi

Intoto Inc.
www.intoto.com