Subject: RE: [Ipsec] RE:

From: [email-masked]
Date: Tue, 4 Jan 2005 15:16:26 +0200

Hi,

Hmm, this was discussed off-list about a year ago (with Russ,
Charlie, and Hannes), but it seems that it was forgotten since...

You're quite right in that IKEv2 does not negotiate the hash
function (or the encoding method) used for RSA signatures. 
For the hash function, the intent was that supporting SHA-1
is mandatory (but draft-ietf-ipsec-ikev2-algorithms does not 
actually say that). 

For the encoding method, the draft talks about "PKCS#1 padded 
hash"; since the reference points to PKCS#1 v2.0 (and not v2.1), 
and that version has only one encoding method for signatures 
(EMSA-PKCS1-v1_5), that's the mandatory-to-support one (BTW, 
note that this is different from the encoding method used 
in IKEv1).

(Tero/Charlie/Russ/anyone: please correct me if I didn't
get this right.)

Best regards,
Pasi

> -----Original Message-----
> From: Magnus Alström
> Sent: Monday, January 03, 2005 11:32 AM
> To: Tero Kivinen
> Cc: [email-masked]
> Subject: [Ipsec] RE:
> 
> 
> Hi Tero,
> 
> 
> 
> Thanks for the comments. I guessed that the sign operation 
> should be a hash+sign operation, but the question is still 
> how the hashing should be performed. There is a prf function 
> negotiated, but no hash algorithm. Should I take the data and 
> create a hmac? Or should I take whatever algorithm I prefer 
> and encode the digest to a der-encoded digest-info before I sign?  
> 
> 
> 
> regards Magnus

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 4 Jan 2005 18:15:56 +0200

> is mandatory (but draft-ietf-ipsec-ikev2-algorithms does not 

Probably pest is to use same hash algorithm that was used to sign the
certificate itself. If the other end does not support that algorith,
then he cannot verify the certificate, thus the signature will be
invalid anyways. 
-- 
[email-masked]