Subject: [Ipsec] Next Layer Protocol (Ref: 2401-bis draft)

From: Subha Venkataramanan <[email-masked]>
Date: Thu, 13 Jan 2005 15:51:08 -0800 (PST)

Hi List-members,

In Section 4.4.4.1 (Selectors) under Next- Layer
Protocols, it is mentioned that "to simplify locating
the next header protocol, there SHOULD be a mechanism
for configuring which IPv6 extension headers to SKIP"

Could someone indicate to me what was the intent
behind this kind of configuration ?

Thanks,
Subha

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: Stephen Kent <[email-masked]>
Date: Tue, 18 Jan 2005 14:41:51 -0500

>behind this kind of configuration ?

In IPv6, the use of hop-by-hop and destination extension headers can 
make it harder than in Ipv4 to locate the next layer protocol. This 
text suggests that it would be useful to be able to configure an 
IPsec implementation with a list of which of these extension headers 
can safely be ignored when parsing the IPv6 header to locate the next 
protocol.

Steve