Subject: [Ipsec] RE: Question / Remark on PRF/MAC in IKEv2 draft-spec (repeat)

From: Paul Hoffman <[email-masked]>
Date: Thu, 10 Mar 2005 13:36:00 -0600

At 11:24 AM -0800 3/10/05, Charlie Kaufman wrote:
>2) The current spec says that when using shared keys the AUTH 
>payload is computed using the negotiated PRF algorithm. One could 
>argue that it would be cryptographically preferable to do the outer 
>computation with the negotiated MAC algorithm rather than the 
>negotiated PRF algorithm, but I don't believe there are any 
>weaknesses introduced by using the PRF so I don't believe it should 
>be changed at this late date given that there are working 
>implementations that such a change would break.
>
>Paul... can you confirm that PRF is what the implementations in the 
>bakeoff used?

You should check this with Tero and/or Geoffrey. However, since I 
didn't hear than anyone had any problem with this part of the spec, I 
suspect everyone understood that it was PRF.

--Paul Hoffman, Director
--VPN Consortium

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Geoffrey Huang" <[email-masked]>
Date: Thu, 10 Mar 2005 22:02:26 -0800

Yes, I understood it to be PRF.

-g  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Paul Hoffman
> Sent: Thursday, March 10, 2005 11:36 AM
> To: Charlie Kaufman; [email-masked]; [email-masked]
> Cc: Russ Housley
> Subject: [Ipsec] RE: Question / Remark on PRF/MAC in IKEv2 
> draft-spec(repeat)
> 
> >2) The current spec says that when using shared keys the 
> AUTH payload 
> >is computed using the negotiated PRF algorithm. One could 
> argue that it 
> >would be cryptographically preferable to do the outer 
> computation with 
> >the negotiated MAC algorithm rather than the negotiated PRF 
> algorithm, 
> >but I don't believe there are any weaknesses introduced by using the 
> >PRF so I don't believe it should be changed at this late date given 
> >that there are working implementations that such a change 
> would break.
> >
> You should check this with Tero and/or Geoffrey. However, 
> since I didn't hear than anyone had any problem with this 
> part of the spec, I suspect everyone understood that it was PRF.
> 
> --Paul Hoffman, Director
> --VPN Consortium
>