Subject: [Ipsec] CMAC Documents

From: Russ Housley <[email-masked]>
Date: Wed, 08 Jun 2005 11:55:18 -0400

Dear IPsec Mail List:

I am going to shepherd these documents.  As a first step, I would
appreciate your review and comment.

Thanks,

Russ

Hi Russ Housley,

We have I-Ds which are AES-CMAC usage on IPsec, but it has no workgroup
since IPsec workgroup completed last April.

Can you possibly shepherd it for standard track publication?

http://www.ietf.org/internet-drafts/draft-songlee-aes-cmac-96-02.txt

http://www.ietf.org/internet-drafts/draft-songlee-aes-cmac-prf-128-00.txt

Thanks,

Jun Hyuk Song

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: [email-masked]
Date: Thu, 9 Jun 2005 17:01:04 +0300

A comment about draft-songlee-aes-cmac-prf-128-00: 

Some features of IKEv2 work, well, poorly with PRFs that
require a fixed size key (see draft-eronen-ipsec-ikev2-
clarifications-03, Sections 2.8, 2.9, and 3.5 for details).
Currently we have only one such PRF (AES-XCBC-PRF-128), but 
there's work ongoing (draft-hoffman-rfc3664bis-02) to remove 
the fixed key size restriction from XCBC-MAC (by specifying 
how to get a 128-bit key from a shorter or longer key).

I think it would be useful to include such processing in
CMAC-PRF as well (so from IKEv2 point of view, it would accept
a key of arbitrary length).

Best regards,
Pasi

(BTW, the draft also needs an IANA considerations section.)

> -----Original Message-----
> From: Russ Housley
> Sent: Wednesday, June 08, 2005 6:55 PM
> To: [email-masked]
> Subject: [Ipsec] CMAC Documents
> 
> Dear IPsec Mail List:
> 
> I am going to shepherd these documents.  As a first step, I 
> would appreciate your review and comment.
> 
> Thanks,
>   Russ
> 
> 
>
> Hi Russ Housley,
> 
> We have I-Ds which are AES-CMAC usage on IPsec, but it has no
> workgroup since IPsec workgroup completed last April.
>