Subject: RE: [Ipsec] 3DES mode

From: "Vishwas Manral" <[email-masked]>
Date: Mon, 25 Jul 2005 01:41:03 -0700

Hi Alejandro,

I think it means 3DES_CBC as RFC2451 talks about CBC mode.

In my view if we want to use 3DES_ECB, we will need a new transform ID for transform type 1.

Thanks,
Vishwas
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alejandro Pérez Méndez
Sent: Monday, July 25, 2005 1:49 PM
To: [email-masked]
Subject: [Ipsec] 3DES mode

Hi,

i'm confused about what 3DES mode must be used to encrypt SK payload
data when 3DES is negociated in IKEv2 initial exchanges. Must be
3DES_CBC, 3DES_ECB...? Draft only specify 3DES. IMHO it could provoke
interoperability issues.

Thanks.

Alejandro

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: Bill Sommerfeld <[email-masked]>
Date: Tue, 26 Jul 2005 00:30:15 -0400

> In my view if we want to use 3DES_ECB, we will need a new transform ID

but then, nobody in their right mind would want to use any ECB mode
cipher directly.

						- Bill