Subject: [Ipsec] FW: Multicast - IPsec in Tunnel mode

From: "H.Cruickshank" <[email-masked]>
Date: Tue, 16 Aug 2005 10:42:04 +0100

-----Original Message-----
From: Cruickshank HS Dr (CCSR) 
Sent: 16 August 2005 08:56
To: [email-masked]'; [email-masked]
Subject: Multicast - IPsec in Tunnel mode

Hi,
 
I wonder if somebody can help me to understand how  does IPsec (tunnel
mode) work with multicast:
 
Scenario 1:
-----------
There is an IP multicast session in the clear.  Part of the multicast
distribution paths are controlled by security gateways, where they MUST
use IPsec in tunnel-mode between them.  Let us assume that there are 4
security gateways: How does IPsec (tunnel mode) work here.    

Scenario 2:
-----------
Same as scenario 1, except that the original IP multicast session is
secure (e.g. IPsec in transport mode between sender and receivers) .  So
how does the security gateways use IPsec in tunnel-mode now.
 
Many thanks.
Haitham
 
_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: George Gross <[email-masked]>
Date: Tue, 16 Aug 2005 05:55:42 -0400 (EDT)

Hi Haitham,

You can find a discussion of IPsec tunnel mode, and many other
aspects of IPsec secure multicast in the draft:

http://www.ietf.org/internet-drafts/draft-ietf-msec-ipsec-extensions-00.txt

wrt/ your two questions, the above draft defines an optional flag for use
in combination with the Populate From Packet (PFP) mode SPD entries that
enhances IPsec tunnel mode for secure multicast. Plz refer to the draft
section 3 for the details....

hth,
	George