Subject: [Ipsec] Is there anyone who install IKEv2?

From: "杜春燕" <[email-masked]>
Date: Sat, 10 Sep 2005 22:39:26 +0800

HI!

	I'm studying IKEv2 now. Recently i want to install ikev2-20050902 written by marcupic and sgros, which is download from sourceforge. However,it failed. Here is some error info.

	(1) when installing log4c 1.0.10 ―― first ./configure, then make, but error occurred:  
      "cd . && \
  		/bin/sh /home/running/log4c-1.0.10/config/missing --run automake --gnu  Makefile
		aclocal.m4: 421: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'
		configure.in: 421: required file `./$@)].in' not found
		cd . && /bin/sh /home/running/log4c-1.0.10/config/missing --run autoconf
		configure.in:39: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
		configure.in:89: error: possibly undefined macro: AM_PATH_EXPAT
	WARNING: `autoconf' is missing on your system.  You should only need it if
         you modified `configure.in'.  You might want to install the
         `Autoconf' and `GNU m4' packages.  Grab them from any GNU
         archive site."
	
	(2) then i downloaded  `Autoconf' and `GNU m4',but i couldn't understand what GNU m4 is.Would you please make an 		explaination ?

　Thanks for ahead.

　　　　　　　　Du Chunyan
　　　　　　　　[email-masked]
　　　　　　　　　　2005-09-10

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: Wade Yin <[email-masked]>
Date: Thu, 15 Sep 2005 22:32:33 +0800

That's not a ipsec-tools problem, a simple resolution is: install a full 
version linux(actually, there is no full version, linux software is so many, 
but Fedora 3 is not bad), all the necessary tools should be installed in 
your PC, and then try it again.
  另外， 很高兴看到来自.cn的朋友.

 On 9/10/05, 杜春燕 <[email-masked]> wrote: 
> 
> HI!
> 
> 
> I'm studying IKEv2 now. Recently i want to install ikev2-20050902 written 
> by marcupic and sgros, which is download from sourceforge. However,it 
> failed. Here is some error info.
> 
> configure.in <http://configure.in>: 421: required file `./$@)].in' not 
> found
> configure.in:39 <http://configure.in:39>: error: possibly undefined macro: 
> AC_PROG_LIBTOOL
> configure.in:89 <http://configure.in:89>: error: possibly undefined macro: 
> AM_PATH_EXPAT
> (2) then i downloaded `Autoconf' and `GNU m4',but i couldn't understand 
> what GNU m4 is.Would you please make an explaination ?
> 
> Thanks for ahead.
> 
> 
> Du Chunyan
> [email-masked]
> 2005-09-10
> 
>