Subject: [Ipsec] IKEv2 Notify INVALID_SYNTAX in IKE_SA_INIT exchange

From: Jan Hutter <[email-masked]>
Date: Mon, 5 Dec 2005 12:36:47 +0100

Hello,

Do I have to reply a IKE_SA_INIT request with a Notify payload of type
INVALID_SYNTAX in the following situations:
- No configuration for a specific peer could be found
- The SA payload does not contain an IKE proposal

Thank you for any hints.

Jan Hutter

Student at University of applied sciences, Rapperswil, Switzerland
_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Yoav Nir" <[email-masked]>
Date: Mon, 5 Dec 2005 13:48:17 +0200

For the first case, I would definitely send a NO_PROPOSAL_CHOSEN.  

For the second case, I also think NO_PROPOSAL_CHOSEN is best, although I can
see it fitting the "value was out of range" description of INVALID_SYNTAX

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jan Hutter
Sent: Monday, December 05, 2005 1:37 PM
To: [email-masked]
Subject: [Ipsec] IKEv2 Notify INVALID_SYNTAX in IKE_SA_INIT exchange

Hello,

Thank you for any hints.

Jan Hutter