Subject: Re: [Ipsec] short question about KE format in IKEv2

From: Francis Dupont <[email-masked]>
Date: Sat, 01 Apr 2006 10:01:47 +0200

In your previous mail you wrote:
   
   At least the "Field Element to Octet String" conversion function in
   X9.62-2005 Section A.5.4 always produces an output of the same length
   (padding the octet string with zeroes if necessary). Thus, it seems
   the requirement does make sense for ECC as well.
   
=> you confirm me in my opinion the length and the padding requirement
are in fact parts of the group definitions.

Thanks

[email-masked]

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Greg Bailey" <[email-masked]>
Date: Sun, 2 Apr 2006 23:38:09 -0700

Help!

I am trying to use the venerable IPSec tester kindly maintained by
NIST at http://ipsec-wit.antd.nist.gov/  - but it appears to be broken.

I have sent messages to NIST during the past two months but have been
unable to contact anyone who is responsible for this system.  Please
help me contact someone who might be able to help.  The internal error
message from the tester appears below.

Thanks in advance!

    Greg Bailey     |  ATHENA Programming, Inc    |  503-621-3461  |
  ----------------  |  19330 NW Sauvie Island Rd  |  fax   DOWN    |
  [email-masked]  |  Portland, OR  97231-1315   |

===============================================
Directive: Expect: SUCCESSFUL NEGOTIATION 

Native:plutoplus -p 500 -d 192.88.236.19 -b 2 -b 4 -i -e 2 -a 2 2>&1 
ISAKMP/IKE has the following parameters: 
Role : INITIATOR 
Authentication : PRESHARED 
Group number : 1 
ISAKMP SA algorithms (enc/hash) : DES_CBC(2)/MD5(2) 
IPsec ESP algorithm : DES (2) 
With authentication algorithm : MD5 (1) 
PFS : NO 
Replay Protection : YES 
Encryption IV length : 8 bytes 
Encryption key length: 8 bytes (64 bits) 
Mode : TRANSPORT 
Port # : 500 
DEFAULT Oakley SA life duration : 86400 seconds 
DEFAULT IPsec SA life duration : 28800 seconds 
DEFAULT IPsec SA life duration : 32767 kbytes 
******************** STARTING ******************* STARTING ******************** 
***Error: write() kernelfd_sav (ike) failed in kernel_unregister 

Error: Unexpected Result Occurred
===============================================