Subject: [Ipsec] Request SCTP over IPSEC

From: Randall Solano <[email-masked]>
Date: Tue, 23 May 2006 16:38:38 -0500 (CDT)

Hello:

I´d like to know if i can use IPsec with SCTP. My
network design is using between MGCs and MGs the
Megaco Protocol, but i don´t if this is correct:

MEGACO/SCTP/IP/IPSEC/ETHERNET/PHYSICAL LAYER 

Other point if i can use SCTP between MGCs different,
like this:

MGC(a)------SigTRAN-------MGC(2)

All of this Protocol stack is:

isup/m3ua/sctp/ip/ipsec/ethernet/physical 

Cheers,

Ran

__________________________________________________
Correo Yahoo!
Espacio para todos tus mensajes, antivirus y antispam ¡gratis! 
Regístrate ya - http://correo.espanol.yahoo.com/ 

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Tue, 23 May 2006 18:17:32 -0400

> isup/m3ua/sctp/ip/ipsec/ethernet/physical 
I'm not sure what you mean by "can" you use it.  SCTP with IPsec is
defined in RFC 3554.  However, your stack diagrams are wrong.  IPsec is on
top of IP; if you're using tunnel mode, there's a second IP header on top
of IPsec.  Thus, your first diagram should be

	MEGACO/SCTP/IPSEC/IP/ETHERNET/PHYSICAL LAYER 

for transport mode and

	MEGACO/SCTP/IP/IPSEC/IP/ETHERNET/PHYSICAL LAYER 

for tunnel mode.  (I don't remember which Megaco wants.)

		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

---

From: Stephen Kent <[email-masked]>
Date: Tue, 23 May 2006 18:17:42 -0400

>isup/m3ua/sctp/ip/ipsec/ethernet/physical

Ran,

yes you can use IPsec with SCTP in this context. 
Depending on the IPsec implementation, the stack 
might not show IPsec as below IP, but that's a 
minor detail.

Steve