Subject: [Ipsec] FW: I-D ACTION:draft-friedman-ike-short-term-certs-00.txt

From: Arik Friedman <[email-masked]>
Date: Wed, 29 Nov 2006 19:16:29 +0200

Hello, 

We would appreciate any comments you may have regarding this draft, either
privately or to the IPSec mailing list.

Thanks,
	Arik Friedman.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, November 29, 2006 17:50
To: [email-masked]
Subject: I-D ACTION:draft-friedman-ike-short-term-certs-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Short-Term Certificates
	Author(s)	: A. Friedman, et al.
	Filename	: draft-friedman-ike-short-term-certs-00.txt
	Pages		: 12
	Date		: 2006-11-29
	
   This document describes an extension to IKEv2 that allows an endpoint
   to prove to a security gateway that it was already authenticated by
   another trusted security gateway, thereby allowing the authentication
   of the endpoint without user intervention.  This is accomplished
   using a Short Term Credential that the endpoint requests from the
   authenticating security gateway.  This credential is a certificate
   issued by the authenticating gateway for a short period of time, and
   it can be used to authenticate the user with IKE signature based
   authentication.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-friedman-ike-short-term-certs-00.t
xt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of the
message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in, type
"cd internet-drafts" and then "get
draft-friedman-ike-short-term-certs-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-friedman-ike-short-term-certs-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

<ftp://ftp.ietf.org/internet-drafts/draft-friedman-ike-short-term-certs-00.t
xt>

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: [email-masked]
Date: Thu, 30 Nov 2006 16:47:10 -0500

Arik,

The Security Considerations section notes the dependence
of the "short term" property on security gateway clocks,
but doesn't seem to cover all the cases needed to prevent
problems here - all it says is that:
	1) If there are multiple security gateways
	2) Then their clocks SHOULD be synchronized
I think there is room for improvement in both aspects.

1) Gateway clocks have to be protected even if there's
only a single gateway.  If an attacker can roll a security
gateway's clock back, the attacker has extended the
validity of short term certificates, even if there's only
one gateway.  I suggest that all gateway clocks MUST be
protected against rollback, and in addition, the time
span of certificate validity (notBefore to notAfter) in
short term certificates SHOULD be limited (limit TBD) to
cap the benefit from a single clock rollback event.

2) The general "SHOULD" is a bit weak.  As a strawman I'd
suggest that if the STC_LIFETIME attribute is used
(indicating a concern about problems caused by lack of
clock synchronization with the client), then the security
gateway clocks MUST be synchronized in some fashion -
the current text that provides examples but does not
require a specific method to be used is fine.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> From: Arik Friedman [mailto:[email-masked]] 
> Sent: Wednesday, November 29, 2006 12:16 PM
> To: [email-masked]
> Subject: [Ipsec] FW: I-D 
> ACTION:draft-friedman-ike-short-term-certs-00.txt
> 
> Hello, 
>