Subject: [IPsec] I-D ACTION:draft-black-ipsec-ikev2-aead-modes-00.txt

From: [email-masked]
Date: Wed, 20 Feb 2008 10:09:31 -0800

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Using Authenticated Encryption Algorithms 
with the Encrypted Payload of the Internet Key Exchange version 2 
(IKEv2) Protocol
	Author(s)	: D. Black, D. McGrew
	Filename	: draft-black-ipsec-ikev2-aead-modes-00.txt
	Pages		: 14
	Date		: 2008-2-15

An authenticated encryption algorithm combines encryption and
    integrity into a single operation; such algorithms may also be
    referred to as combined modes of an encryption cipher or as combined
    mode algorithms.  This document describes the use of authenticated
    encryption algorithms with the Encrypted Payload of the Internet Key
    Exchange version 2 (IKEv2) protocol.

    The use of two specific authenticated encryption algorithms with the
    IKEv2 Encrypted Payload is also described; these two algorithms are
    the Advanced Encryption Standard (AES) in Galois/Counter Mode (AES
    GCM) and AES in Counter with CBC-MAC Mode (AES CCM).  Additional
    documents may describe use of other authenticated encryption
    algorithms with the IKEv2 Encrypted Payload.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-black-ipsec-ikev2-aead-modes-00.txt

_______________________________________________
IPsec mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipsec

---

From: [email-masked]
Date: Fri, 29 Feb 2008 14:55:29 -0500

David McGrew and I would appreciate comments on this
draft. Its primary purpose is to enable use of AES GCM
and AES CCM for the IKEv2 encrypted payload - currently,
these algorithms can be used with ESP, but not with
IKEv2 proper (i.e., IKEv2 can negotiate ESP usage of
GCM and CCM, but the IKEv2 encrypted payload can't
currently be encrypted with GCM or CCM).

This draft does so by applying the Authenticated
Encryption framework from RFC 5116 to IKEv2's encrypted
payload, as AES GCM, AES CCM and other combined modes
are examples of authenticated encryption algorithms.
The draft also supplies the remaining details needed
for use of AES GCM and AES CCM with IKEv2.  This
approach should make things easier for future
authenticated encryption algorithms because the
IKEv2-generic aspects (e.g., data that receives
integrity coverage but is not encrypted) won't have
to be respecified.

While this draft has already received some good review
(and we thank the reviewers), like any -00 version, it's
not complete.  The only major technical content that's
missing is completing the connection to RFC 5116, mostly
explaining how this draft relates to the specific AEAD
algorithms defined in RFC 5116.  As part of doing this,
additional AEAD algorithm identifiers for AES CCM will be
defined to the version of AES CCM specified in RFC 4309,
as the AEAD CCM algorithms in RFC 5116 differ from
those in RFC 4309.

There are a few technical issues that we are looking
for input on:

1) Key size.  IPsec in general allows 192 bit AES
	keys, but RFC 5116 currently does not.  Is it
	ok to not allow 192 bit AES keys when AES GCM
	and AES CCM are used for the IKEv2 encrypted
	payload.
2) ICV size.  Both RFC 4106 (GCM) and 4309 (CCM) are
	fairly permissive about 8-octet and 12-octet
	ICVs.  David McGrew would like to generally
	prohibit ICV sizes other than 16-octets and hence
	only specify and allow support of 16-octet ICVs
	in this draft.  That would place tighter
	restrictions on AES GCM and AES CCM usage with
	IKEv2 than with ESP unless something else is done.
3) Padding.  Both AES GCM and AES CCM only require
	padding only to a 32-bit alignment (this is
	done here for commonality with ESP).  Is that
	a general characteristic of authenticated
	encryption algorithms, or are there algorithms
	that may need more padding (e.g., to the AES
	encryption block size)?

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of [email-masked]
> Sent: Wednesday, February 20, 2008 1:10 PM
> To: IPsec WG
> Subject: [IPsec] I-D ACTION:draft-black-ipsec-ikev2-aead-modes-00.txt
> 
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec