Subject: [IPsec] EAP-AKA' draft queries.

From: "Kumar, Sunil" <[email-masked]>
Date: Tue, 21 Oct 2008 12:46:13 +0530

Hi Arkko,

We were going through the details of the new variant of EAP-AKA in IETF
drafts
and found your draft of EAP-AKA' (draft-arkko-eap-aka-kdf-xx.txt)

We have few queries related to the same

 Referring to the section 3.3 of draft, during full authentication
process,
      MK is derived as follows:

      MK = PRF' ( IK' | CK' , "EAP-AKA' " | Identity )

Ques1  What is the value of the "EAP-AKA' " in above MK derivation? As
there is no proposed value or description is available in the draft
document.

    When we are considering the case of fast re-authentication process,

    MK is derived as follows:
    MK = PRF' (K_re, "EAP-AKA'  re-auth" | Identity | Counter | NONCE_S)

Ques 2   What is the value of the "EAP-AKA'  re-auth" in above MK
generation? Similarly here also there is no proposed value or
description is available.

Thanks and Regards,

Sunil / Yogendra

The information contained in this electronic mail transmission 
may be privileged and confidential, and therefore, protected 
from disclosure. If you have received this communication in 
error, please notify us immediately by replying to this 
message and deleting it from your computer without copying 
or disclosing it.

_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Jari Arkko <[email-masked]>
Date: Tue, 21 Oct 2008 12:47:12 +0300

These are literal strings fed as input to the PRF.

Jari

Kumar, Sunil wrote:
>
> Hi Arkko,
>
>  
>
> We were going through the details of the new variant of EAP-AKA in 
> IETF drafts
> *Ques1*  What is the value of the *"EAP-AKA' "* in above MK 
> derivation? As there is no proposed value or description is available 
> in the draft document.
>
> *Ques 2*   What is the value of the *"EAP-AKA'  re-auth"* in above MK