Subject: [IPsec] Bis issue #62: Security considerations - implementation robustness

From: Yaron Sheffer <[email-masked]>
Date: Wed, 28 Jan 2009 00:49:49 +0200

Yaron:

Additional proposed text for the Security Considerations:

Both IKE_SA_INIT and IKE_AUTH exchanges happen before the initiator is authenticated. As a result, an implementation of this protocol (all 100-odd pages!) must be highly robust when deployed on any insecure network. Any implementation vulnerability can and will be exploited by unauthenticated peers. This applies in particular to denial of service attacks, and we note the particular issue with the potentially unbounded number of messages in EAP-based authentication.
[Note: I made minor changes to the text from the version on the issue tracker.]

Email secured by Check Point

_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Tero Kivinen <[email-masked]>
Date: Wed, 28 Jan 2009 14:11:44 +0200

Yaron Sheffer writes:
> Both IKE_SA_INIT and IKE_AUTH exchanges happen before the initiator
> is authenticated. As a result, an implementation of this protocol
> (all 100-odd pages!) must be highly robust when deployed on any
> insecure network. Any implementation vulnerability can and will be
> exploited by unauthenticated peers. This applies in particular to
> denial of service attacks, and we note the particular issue with the
> potentially unbounded number of messages in EAP-based
> authentication. 
>

I support adding that text to security considerations section. 
-- 
[email-masked]
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Thu, 29 Jan 2009 09:13:38 +0200

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Tero Kivinen
> Sent: Wednesday, January 28, 2009 2:12 PM
> To: Yaron Sheffer
> Cc: IPsecme WG
> Subject: [IPsec] Bis issue #62: Security considerations - implementation robustness
>
> Yaron Sheffer writes:
> > Yaron:

+1