Subject: [IPsec] WG Last Call: draft-ietf-ipsecme-ikev2-redirect-04

From: Yaron Sheffer <[email-masked]>
Date: Mon, 16 Feb 2009 11:45:56 +0200

This is a 2 week working group last call for draft-ietf-ipsecme-ikev2-redirect-04. The target status for this document is Proposed Standard.  

Please send your comments to the ipsec list by March 2, 2009, as follow-ups to this message.

Please clearly indicate the position of any issue in the Internet Draft, and if possible provide alternative text. Please also indicate the nature or severity of the error or correction, e.g. major technical, minor technical, nit, so that we can quickly judge the extent of problems with the document.

The document can be accessed here: http://tools.ietf.org/html/draft-ietf-ipsecme-ikev2-redirect-04.

Please note that one issue is currently open against this draft: http://tools.ietf.org/wg/ipsecme/trac/ticket/82.

Thanks,
	Yaron

Email secured by Check Point

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 25 Feb 2009 14:34:05 +0200

This is a reminder that we are having a last call for the Redirect document. Even if you support advancing this document, but have no other comments, please state your opinion on the list.

Thanks,
	Yaron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Yaron Sheffer
> Sent: Monday, February 16, 2009 11:46
> To: IPsecme WG
> Subject: [IPsec] WG Last Call: draft-ietf-ipsecme-ikev2-redirect-04
> 
> This is a 2 week working group last call for draft-ietf-ipsecme-ikev2-
> redirect-04. The target status for this document is Proposed Standard.
> 
> Please clearly indicate the position of any issue in the Internet Draft,
> and if possible provide alternative text. Please also indicate the nature
> or severity of the error or correction, e.g. major technical, minor
> technical, nit, so that we can quickly judge the extent of problems with
> the document.
> 
> Please note that one issue is currently open against this draft:
> http://tools.ietf.org/wg/ipsecme/trac/ticket/82.
> 
> Thanks,
> 	Yaron
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
> 
> Scanned by Check Point Total Security Gateway.
> 
> Scanned by Check Point Total Security Gateway.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 25 Feb 2009 15:02:46 +0200

I support advancing this.

I preferred allowing the redirect in IKE_AUTH as well, but it seems like the group consensus went against that.

One textual comment: since we have section 7 describing a symmetric case (redirect by either peer), section 6.1 should be chagned to reflect that the REDIRECT_SUPPORTED may be in either or both of the request and reply of the Initial exchange, and perhaps a picture can be added to section 7.

Even without this, the text is clear and useful.

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Yaron Sheffer
> Sent: Wednesday, February 25, 2009 2:34 PM
> To: IPsecme WG
> Subject: Re: [IPsec] WG Last Call: 
> draft-ietf-ipsecme-ikev2-redirect-04
> 
> This is a reminder that we are having a last call for the 
> Redirect document. Even if you support advancing this 
> document, but have no other comments, please state your 
> opinion on the list.
> 
> Thanks,
> 	Yaron
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Yaron Sheffer
> > Please send your comments to the ipsec list by March 2, 2009, as 
> > follow- ups to this message.
> > 
> > Please clearly indicate the position of any issue in the Internet 
> > Draft, and if possible provide alternative text. Please 
> also indicate 
> > the nature or severity of the error or correction, e.g. major 
> > technical, minor technical, nit, so that we can quickly judge the 
> > extent of problems with the document.
> > 
> > The document can be accessed here: 
> > http://tools.ietf.org/html/draft-ietf-
> > ipsecme-ikev2-redirect-04.
> >

---

From: fan zhao <[email-masked]>
Date: Wed, 25 Feb 2009 17:57:48 -0800

Hi,

I am ok with moving this draft forward. However, I strongly prefer allowing
redirection in the IKE_AUTH as well. As you may know, last week
on the 3GPP SA2 meeting, the SA2 working group adopted the solution
that uses the IKEv2 signaling message for gateway redirection/reallocation
when the mobile terminal performs attach.

Sincerely,
fan

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 26 Feb 2009 15:59:41 +0200

<WG chair hat off>

I join Yoav and Fan in supporting this draft, even in its current form. However I also agree with them that the protocol will be cleaner (and subsequently, implementations will be simpler), if we allow redirection in IKE_AUTH, specifically only in the last message of the exchange.

Thanks,
	Yaron

> fan zhao
> Sent: Thursday, February 26, 2009 3:58
> To: Yoav Nir
> Cc: IPsecme WG
> Subject: Re: [IPsec] WG Last Call: draft-ietf-ipsecme-ikev2-redirect-04
> 
> Hi,
> 
> > One textual comment: since we have section 7 describing a symmetric case
> (redirect by either peer), section 6.1 should be chagned to reflect that
> the REDIRECT_SUPPORTED may be in either or both of the request and reply
> of the Initial exchange, and perhaps a picture can be added to section 7.
> >