Subject: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

From: Yaron Sheffer <[email-masked]>
Date: Wed, 1 Apr 2009 23:37:53 +0300

>From Appendix C: The specification does not say which messages can contain
N(SET_WINDOW_SIZE). It can possibly be included in any message, but it is
not yet shown below.

SF discussion: Paul said, "wherever you wish."

---

From: Scott C Moonen <[email-masked]>
Date: Thu, 2 Apr 2009 08:48:05 -0400

> From Appendix C: The specification does not say which messages can 
contain N(SET_WINDOW_SIZE). It can possibly be included in any message, 
but it is not yet shown below.
> 
> SF discussion: Paul said, “wherever you wish.”

Should we prohibit or at least discourage it in the IKE_SA_INIT exchange 
so that it is not susceptible to third-party tinkering?

Scott Moonen ([email-masked])
z/OS Communications Server TCP/IP Development
http://scott.andstuff.org/
http://www.linkedin.com/in/smoonen

From:
Yaron Sheffer <[email-masked]>
To:
IPsecme WG <[email-masked]>
Date:
04/01/2009 04:39 PM
Subject:
[IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

SF discussion: Paul said, “wherever you wish.”
 
 [attachment "smime.p7s" deleted by Scott C Moonen/Raleigh/IBM] 
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Thu, 2 Apr 2009 15:52:24 +0300

Definitely

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott C Moonen
Sent: Thursday, April 02, 2009 3:48 PM
To: Yaron Sheffer
Cc: IPsecme WG
Subject: Re: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

> From Appendix C: The specification does not say which messages can contain N(SET_WINDOW_SIZE). It can possibly be included in any message, but it is not yet shown below.
>

Should we prohibit or at least discourage it in the IKE_SA_INIT exchange so that it is not susceptible to third-party tinkering?

From:   Yaron Sheffer <[email-masked]>
To:     IPsecme WG <[email-masked]>
Date:   04/01/2009 04:39 PM
Subject:        [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

________________________________

>From Appendix C: The specification does not say which messages can contain N(SET_WINDOW_SIZE). It can possibly be included in any message, but it is not yet shown below.

 [attachment "smime.p7s" deleted by Scott C Moonen/Raleigh/IBM] _______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

Email secured by Check Point

---

From: Yoav Nir <[email-masked]>
Date: Thu, 2 Apr 2009 16:42:25 +0300

Actually, just "yes", not "definitely".

All payloads in the IKE_SA_INIT are protected by the AUTH payload in the IKE_AUTH exchange, so if crypto works, a third party will not be able to tinker with it.

On the other hand, at the end of the IKE_SA_INIT exchange, there is no IKE SA, so setting up some properties of that as-yet-non-existant IKE SA seems premature to me. I think it should be in all but the IKE_SA_INIT exchange (and also not in unprotected informational)

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yoav Nir
Sent: Thursday, April 02, 2009 3:52 PM
To: Scott C Moonen
Cc: IPsecme WG
Subject: Re: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

Definitely

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 3 Apr 2009 00:18:21 +0300

Hi Yoav,

I don't see your point, since you're obviously setting up *some* properties
of the tentative IKE SA during IKE_SA_INIT. And it seems to be a very
convenient place to send N(SET_WINDOW_SIZE). So why not?

Thanks,

            Yaron

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yoav Nir
Sent: Thursday, April 02, 2009 16:42
To: Scott C Moonen
Cc: IPsecme WG
Subject: Re: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

All payloads in the IKE_SA_INIT are protected by the AUTH payload in the
IKE_AUTH exchange, so if crypto works, a third party will not be able to
tinker with it.

On the other hand, at the end of the IKE_SA_INIT exchange, there is no IKE
SA, so setting up some properties of that as-yet-non-existant IKE SA seems
premature to me. I think it should be in all but the IKE_SA_INIT exchange
(and also not in unprotected informational)

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yoav Nir
Sent: Thursday, April 02, 2009 3:52 PM
To: Scott C Moonen
Cc: IPsecme WG
Subject: Re: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

Definitely

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Scott C Moonen
Sent: Thursday, April 02, 2009 3:48 PM
To: Yaron Sheffer
Cc: IPsecme WG
Subject: Re: [IPsec] Issue #2: Where does N(SET_WINDOW_SIZE) go?

> SF discussion: Paul said, "wherever you wish." 

Should we prohibit or at least discourage it in the IKE_SA_INIT exchange so
that it is not susceptible to third-party tinkering? 

Scott Moonen ([email-masked])
z/OS Communications Server TCP/IP Development
 <http://scott.andstuff.org/> http://scott.andstuff.org/
 <http://www.linkedin.com/in/smoonen> http://www.linkedin.com/in/smoonen 

From: 

To: 

Date: 

04/01/2009 04:39 PM 

Subject: 

  _____  

  
 [attachment "smime.p7s" deleted by Scott C Moonen/Raleigh/IBM]
_______________________________________________
IPsec mailing list
[email-masked]
 <https://www.ietf.org/mailman/listinfo/ipsec>
https://www.ietf.org/mailman/listinfo/ipsec

Scanned by Check Point Total Security Gateway.

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 3 Apr 2009 15:52:41 +0300

> SF discussion: Paul said, "wherever you wish."

I agree on that. Logical places are:

1) In separate the INFORMATIONAL exchange immediately after IKE_AUTH
   or IKE SA rekey CREATE_CHILD_SA to set the initial window.

2) In the IKE_AUTH or in the IKE SA rekey CREATE_CHILD_SA to set
   initial window.

I do not think there is any need to prefer either one of those two
locations.

Usually the window size is something that is set once after the IKE SA
is created (and after it is rekeyed), and it will never be changed
after that.
-- 
[email-masked]

---

From: Tero Kivinen <[email-masked]>
Date: Fri, 3 Apr 2009 16:14:40 +0300

Scott C Moonen writes:
> > SF discussion: Paul said, $,1r|(Bwherever you wish.$,1r}
(B> 
> so that it is not susceptible to third-party tinkering?

The full contents of the IKE_SA_INIT message is also authenticated
after the IKE_AUTH finishes, so there is no security reason to
discourage it in the IKE_SA_INIT. Of course there are other reasons
not to send it in the IKE_SA_INIT. IKE_SA_INIT should be kept as small
as possible. Also the window size only takes effect after the IKE_AUTH
finishes. 
-- 
[email-masked]