Subject: [IPsec] GCM ICV lengths

From: Scott C Moonen <[email-masked]>
Date: Thu, 9 Apr 2009 12:29:19 -0400

Can anyone comment on current / best practices with AES-GCM ICV lengths? I 
note that algorithm identifiers are defined for ICV lengths of 8, 12 and 
16 octets.  I also see that RFC 4869 defines standard AES-GCM suites using 
16-octet ICVs.  Are most implementations supporting all three ICV choices 
or just the 16-octet ICV choice?

Thanks,

Scott Moonen ([email-masked])
z/OS Communications Server TCP/IP Development
http://scott.andstuff.org/
http://www.linkedin.com/in/smoonen

---

From: Joy Latten <[email-masked]>
Date: Thu, 09 Apr 2009 12:01:16 -0500

On Thu, 2009-04-09 at 12:29 -0400, Scott C Moonen wrote:
> 
> Can anyone comment on current / best practices with AES-GCM ICV
> lengths?  I note that algorithm identifiers are defined for ICV
> lengths of 8, 12 and 16 octets.  I also see that RFC 4869 defines
> standard AES-GCM suites using 16-octet ICVs.  Are most implementations
> supporting all three ICV choices or just the 16-octet ICV choice? 
> 

I believe Linux kernel supports 8, 12, and 16.

regards,
Joy