Subject: [IPsec] Proposed work item: WESP extensibility

From: Yaron Sheffer <[email-masked]>
Date: Sun, 29 Nov 2009 19:20:55 +0200

This draft proposes an extensibility framework for WESP, as well as several specific extensions.

Proposed starting point: http://tools.ietf.org/id/draft-montenegro-ipsecme-wesp-extensions-00.txt.

Please reply to the list:

- If this proposal is accepted as a WG work item, are you committing to review multiple versions of the draft?

- Are you willing to contribute text to the draft?

- Would you like to co-author it?

Please also reply to the list if:

- You believe this is NOT a reasonable activity for the WG to spend time on.

If this is the case, please explain your position. Do not explore the fine technical details (which will change anyway, once the WG gets hold of the draft); instead explain why this is uninteresting for the WG or for the industry at large. Also, please mark the title clearly (e.g. "DES40-export in IPsec - NO!").

---

From: Stephen Kent <[email-masked]>
Date: Sun, 29 Nov 2009 20:04:59 -0500

I am opposed to pursing this work at this time.  The ongoing 
discussion on the list suggests that the arguments put forth for WESP 
use in the OSPFv3 context, the first concrete proposal outside of the 
middlebox inspection context that motivated WESP, have not been 
validated. The presentation in Hiroshima listed a variety of possible 
use cases, without providing any detailed analysis, and at least one 
such case was considered and rejected by the IPSEC WG on at least two 
occasions.  My recollection is that Pasi agreed with my suggestion 
that at least 2 or 3 valid use cases need to be thoroughly vetted 
before the WG pursue this as a new work item.

Steve