Subject: Re: [IPsec] #116: The AUTH payload signature

From: Yaron Sheffer <[email-masked]>
Date: Tue, 24 Nov 2009 19:09:24 +0200

Tero requested a clarification: I'm proposing to say that the certificate's hash algorithm does not determine the AUTH hash function (which is the negotiated PRF). Implementations may use the certificates received from a given peer as a hint for selecting a mutually-understood PRF with that peer.

And yes, the last sentence refers to this text:

To promote interoperability, implementations that support this type SHOULD support signatures that use SHA-1 as the hash function and SHOULD use SHA-1 as the default hash function when generating signatures.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaron Sheffer
Sent: Friday, October 30, 2009 1:18
To: IPsecme WG
Subject: [IPsec] #116: The AUTH payload signature

The definition of the payload (sec. 3.8) should mention explicitly that the payload hash algorithm is unrelated to the one used in the certificate, or the algorithm used to sign the IKE Encrypted Payload.

Moreover, the words "by default" are confusing and should be deleted.

Scanned by Check Point Total Security Gateway.

---

From: Tero Kivinen <[email-masked]>
Date: Wed, 25 Nov 2009 13:44:24 +0200

Yaron Sheffer writes:
> Tero requested a clarification: I'm proposing to say that the
> certificate's hash algorithm does not determine the AUTH hash
> function (which is the negotiated PRF). Implementations may use the
> certificates received from a given peer as a hint for selecting a
> mutually-understood PRF with that peer. 

That I can accept. They are not unrelated, but certificate's hash
algorithm does not determine AUTH hash algorithm.

> To promote interoperability, implementations that support this type
> SHOULD support signatures that use SHA-1 as the hash function and
> SHOULD use SHA-1 as the default hash function when generating
> signatures. 

Do you have new proposed text?
-- 
[email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 25 Nov 2009 08:21:46 -0800

>algorithm does not determine AUTH hash algorithm.

+1

>Do you have new proposed text?

+1. :-)

--Paul Hoffman, Director
--VPN Consortium