Subject: [IPsec] crypting with aes-xcbc-mac hashing

From: rahul bharadhwaj <[email-masked]>
Date: Wed, 16 Dec 2009 10:06:23 +0530

Hi all

Could anyone let me know which crypt algo des/3des/aes should be used  with
aes-xcbc-mac hashing.

As aes-xcbc-mac uses aes for authentication and integrity, is it correct to
apply des for encryption or is there any restriction.

Thanks in advance
rb

---

From: Yoav Nir <[email-masked]>
Date: Wed, 16 Dec 2009 10:15:23 +0200

On Dec 16, 2009, at 6:36 AM, rahul bharadhwaj wrote:

Hi all

Could anyone let me know which crypt algo des/3des/aes should be used  with  aes-xcbc-mac hashing.

As aes-xcbc-mac uses aes for authentication and integrity, is it correct to apply des for encryption or is there any restriction.

Thanks in advance
rb

Hi.

We generally regard encryption and integrity to be orthogonal, so you can mix and match as you'd like as long as all algorithms are strong enough.

Some have an aesthetic preference to match key strengths, so they wouldn't use 56-bit DES with HMAC-SHA-512.  But if your security requirements are for 56-bit, there is no reason not to use DES.

If you have more stringent requirements, either 3DES or AES would be good. Usually AES is better performing, so you would usually prefer that.

---

From: "V Jyothi-B22245" <[email-masked]>
Date: Wed, 16 Dec 2009 14:36:30 +0530

Hi,
 
There is no restriction.
You can use any encryption algorithm with AES-XCBC
 
Regards
Jyothi

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of rahul bharadhwaj
Sent: Wednesday, December 16, 2009 10:06 AM
To: [email-masked]
Subject: [IPsec] crypting with aes-xcbc-mac hashing

Hi all

Could anyone let me know which crypt algo des/3des/aes should be used
with  aes-xcbc-mac hashing.

As aes-xcbc-mac uses aes for authentication and integrity, is it correct
to apply des for encryption or is there any restriction.

Thanks in advance
rb