Subject: Re: [IPsec] Proposed work item: Failure detection in IKEv2

From: Scott C Moonen <[email-masked]>
Date: Wed, 2 Dec 2009 20:42:38 -0500

If this proposal is accepted I commit to review it.

Scott Moonen ([email-masked])
z/OS Communications Server TCP/IP Development
http://www.linkedin.com/in/smoonen

From:
Yaron Sheffer <[email-masked]>
To:
"[email-masked]" <[email-masked]>
Date:
11/29/2009 12:26 PM
Subject:
[IPsec] Proposed work item: Failure detection in IKEv2

This work item proposes an IKEv2 extension to allow an IKE peer to quickly 
and securely detect that its opposite peer has lost state. This is claimed 
to be quicker than the current method, which is based on time outs.

Proposed starting point: http://tools.ietf.org/id/draft-nir-ike-qcd-05.txt 
or http://tools.ietf.org/html/draft-detienne-ikev2-recovery-03.
 
Please reply to the list:
 
- If this proposal is accepted as a WG work item, are you committing to 
review multiple versions of the draft?
- Are you willing to contribute text to the draft?
- Would you like to co-author it?
 
Please also reply to the list if:
 
- You believe this is NOT a reasonable activity for the WG to spend time 
on.
 
If this is the case, please explain your position. Do not explore the fine 
technical details (which will change anyway, once the WG gets hold of the 
draft); instead explain why this is uninteresting for the WG or for the 
industry at large. Also, please mark the title clearly (e.g. "DES40-export 
in IPsec - NO!").
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Michael Richardson <[email-masked]>
Date: Thu, 03 Dec 2009 22:18:17 -0500

Yaron Sheffer wrote:
> This work item proposes an IKEv2 extension to allow an IKE peer to quickly and securely detect that its opposite peer has lost state. This is claimed to be quicker than the current method, which is based on time outs.
> 
> Proposed starting point: http://tools.ietf.org/id/draft-nir-ike-qcd-05.txt or http://tools.ietf.org/html/draft-detienne-ikev2-recovery-03.
>  

I will review multiple versions of this document, and I will contribute
text.

I think this is an important problem, although I am not convinced that
qcd-05 is the right mechanism.  I am open to being convinced.