Subject: [IPsec] Issue #138: Calculations involving Ni/Nr

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Jan 2010 18:25:57 -0800

Section 2.14: "only the first 64 bits of Ni and the first 64 bits of
 Nr are used in the calculation". This section has two calculations
 involving Ni/Nr, but this sentence should only apply to the former.
 Suggested rephrasing: "the calculation" -> "when calculating SKEYSEED
 (but all bits are used when calculating SK_*)"

--Paul Hoffman, Director
--VPN Consortium

---

From: Yoav Nir <[email-masked]>
Date: Thu, 21 Jan 2010 09:49:11 +0200

I agree, and I don't think you need brackets:

only the first 64 bits of Ni and the first 64 bits of Nr are used in calculating SKEYSEED, but all the bits are used for input to the prf+ function.

(although I personally did not find it confusing)

On Jan 19, 2010, at 4:25 AM, Paul Hoffman wrote:

> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
> 
> Scanned by Check Point Total Security Gateway.