Subject: Re: [IPsec] Please review draft-ietf-ipsecme-aes-ctr-ikev2-05.txt

From: "Sean Shen" <[email-masked]>
Date: Thu, 04 Mar 2010 13:49:56 +0800

Thank you, Yoav,
I will have it fixed, listen to this channel for other suggestions and have the
revised version submitted by Mar 8th.

Sean

In your mail:
>From: Yoav Nir <[email-masked]>
>Reply-To: 
>To: "'Paul Hoffman'" <[email-masked]>, IPsecme WG <[email-masked]>
>Subject: Re: [IPsec] Please review draft-ietf-ipsecme-aes-ctr-ikev2-05.txt
>Date:Thu, 4 Mar 2010 07:16:55 +0200
>
>Paragraph 5 of section #2:
>    MUST accept any length that results in proper alignment.  It should
>    be noticed that the ESP [RFC4303] Encrypted Payload requires
> 
> Please change "noticed" to "noted".
> 
> Other than that, the document looks good enough for implementation.
> 
> >A New Internet-Draft is available from the on-line Internet-Drafts
>>directories.
>>This draft is a work item of the IP Security Maintenance and Extensions Working
Group of the IETF.
>>
>>	Title		: Using Advanced Encryption Standard (AES) Counter Mode with IKEv2
>>	Author(s)	: S. Shen, Y. Mao, S. murthy
>>	Filename	: draft-ietf-ipsecme-aes-ctr-ikev2-05.txt
>>	Pages		: 10
>>	Date		: 2010-3-2
>>	
>>This document describes the usage of Advanced Encryption Standard
>>   Counter Mode (AES-CTR), with an explicit initialization vector, by
>>   IKEv2 for encrypting the IKEv2 exchanges that follow the IKE_SA_INIT
>>   exchange.
>>
>>A URL for this Internet-Draft is:
>>http://www.ietf.org/internet-drafts/draft-ietf-ipsecme-aes-ctr-ikev2-05.txt
>
>Based on Pasi's AD review, the authors significantly shortened the document. It
seems prudent to have the WG review the new, shorter version. In particular, it
would be good for developers to look at the new short document and see if it is
complete enough to implement from.
>
>This review cycle will end in a week, but please do the review early in case
problems are found.
>
>--Paul Hoffman, Director
>--VPN Consortium
>_______________________________________________
>IPsec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ipsec
>
>Scanned by Check Point Total Security Gateway.
>_______________________________________________
>IPsec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ipsec

---

From: Raj Singh <[email-masked]>
Date: Thu, 4 Mar 2010 11:30:23 +0530

Hi Sean,

Section 5. IANA Considerations can be reworded in-line with ikev2bis.

5. IANA Considerations

IANA has already registered the type and value for AES-CTR.

Name                 Number      Defined In
--------------------------------------------

ENCR_AES_CTR         13          (RFC3686 <http://tools.ietf.org/html/rfc3686>)

Best regards,
Raj

---

From: Tero Kivinen <[email-masked]>
Date: Thu, 4 Mar 2010 13:52:45 +0200

> Section 5. IANA Considerations can be reworded in-line with

It would be better align it with ikev2-parameters iana registry. 

> IANA has already registered the type and value for AES-CTR.

I.e. correct line to be put to the IANA registry will be:

Number        Name                   ESP Reference  IKEv2 Reference
------------  ---------------------  -------------  ---------------
13            ENCR_AES_CTR           [RFC3686]      [RFC<this rfc>]

I.e this document change sthe IKEv2 Reference column of the 
Transform Type 1 - Encryption Algorithm Transform IDs iana table for
number 13 - ENCR_AES_CTR from "-" to refer this document instead.
-- 
[email-masked]

---

From: Sean Shen 沈烁 <[email-masked]>
Date: Mon, 8 Mar 2010 16:08:36 +0800

> Number        Name                   ESP Reference  IKEv2 Reference

If we need to give clear expression of what a IANA reference should be, I believe the iana registry is the proper format as showed above (also at http://www.iana.org/assignments/ikev2-parameters). 

Sean