Subject: [IPsec] Request for review: The ARIA Cipher Algorithm and Its Use with IPsec

From: Woo-Hwan Kim <[email-masked]>
Date: Thu, 15 Sep 2011 17:24:23 +0900

IPsec experts,

Let me make a request for review
on the draft "The ARIA Cipher Algorithm and Its Use with IPsec".

Any comments would be appreciated.

http://tools.ietf.org/html/draft-nsri-ipsecme-aria-ipsec-00

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2011/9/15
Subject: New Version Notification for draft-nsri-ipsecme-aria-ipsec-00.txt
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked],
[email-masked]

A new version of I-D, draft-nsri-ipsecme-aria-ipsec-00.txt has been
successfully submitted by Woo-Hwan Kim and posted to the IETF repository.

Filename:        draft-nsri-ipsecme-aria-ipsec
Revision:        00
Title:           The ARIA Cipher Algorithm and Its Use with IPsec
Creation date:   2011-09-15
WG ID:           Individual Submission
Number of pages: 10

Abstract:
  This document describes the use of the ARIA block cipher algorithm in
  conjunction with several different modes of operation within IKE and
  IPsec.  It describes the use of ARIA in CBC, CTR, GCM and CCM modes
  to encrypt and/or authenticate IKE and ESP traffic.  It also
  describes the use of ARIA in XCBC, CMAC, and GMAC modes to
  authenticate IKE, ESP and AH traffic.  The use of ARIA in XCBC and
  CMAC modes for pseudorandom functions is also included.

The IETF Secretariat

---

From: <[email-masked]>
Date: Thu, 15 Sep 2011 05:52:32 -0500

Should this be added to IPSec?  It's not clear to me that proliferation of ciphers is helpful.  A small set of very well vetted ciphers is better than a larger set that add others without a strong track record.

                paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Woo-Hwan Kim
Sent: Thursday, September 15, 2011 4:24 AM
To: [email-masked]
Cc: Daesung Kwon; Jungkeon Lee; Je Hong Park
Subject: [IPsec] Request for review: The ARIA Cipher Algorithm and Its Use with IPsec

IPsec experts,

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: 2011/9/15
Subject: New Version Notification for draft-nsri-ipsecme-aria-ipsec-00.txt
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

A new version of I-D, draft-nsri-ipsecme-aria-ipsec-00.txt has been successfully submitted by Woo-Hwan Kim and posted to the IETF repository.

Abstract:

The IETF Secretariat

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 15 Sep 2011 08:16:22 -0700

On Sep 15, 2011, at 3:52 AM, <[email-masked]> <[email-masked]> wrote:

> Should this be added to IPSec?  It’s not clear to me that proliferation of ciphers is helpful.  A small set of very well vetted ciphers is better than a larger set that add others without a strong track record.

IPsec (and IKE) allow the addition of new ciphers without those ciphers being considered "part of" IPsec. That is, no one should feel compelled to implement every cipher for which there is an RFC and a number in the registry.

This document is currently not being considered as a WG item. The authors have, correctly, proposed it as an informational submission.

--Paul Hoffman

---

From: <[email-masked]>
Date: Thu, 15 Sep 2011 10:28:56 -0500

Ok, thanks, that makes sense.

	paul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Thursday, September 15, 2011 11:16 AM
To: IPsecme WG
Subject: Re: [IPsec] Request for review: The ARIA Cipher Algorithm and Its Use with IPsec

--Paul Hoffman

_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec