Subject: [IPsec] IPR Disclosure: Certicom Corporation's Statement about IPR related to draft-ietf-ipsecme-dh-checks-04

From: IETF Secretariat <[email-masked]>
Date: Thu, 09 May 2013 12:41:11 -0700

Dear Yaron Sheffer, Scott Fluhrer:

 An IPR disclosure that pertains to your Internet-Draft entitled "Additional
Diffie-Hellman Tests for IKEv2" (draft-ietf-ipsecme-dh-checks) was submitted to
the IETF Secretariat on 2013-05-09 and has been posted on the "IETF Page of
Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/2072/). The title of the IPR disclosure is
"Certicom Corporation's Statement about IPR related to draft-ietf-ipsecme-dh-
checks-04."");

The IETF Secretariat

---

From: Michael Richardson <[email-masked]>
Date: Fri, 10 May 2013 13:13:33 -0400

I read: http://www.google.com/patents/US7215773

and I find: 

  In RSA or Rabin signatures there are generally three routines, namely
  key pair generation, signature generation and signature
  verification. Validating an RSA public key (n, e) involves three
  steps. Firstly validate e, secondly validate n and thirdly validate e
  and n are consistent with each other. In order to validate the public
  exponent e, use of made of the fact that the exponent 2<=e<=2(k

I can not speculate as to whether there is prior art, but it seems to
match what we have been discussing.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 10 May 2013 10:20:55 -0700

> match what we have been discussing.

<chair-hat on>
"We" have not been discussing it, and nor should we. Certicom has filed numerous IPR statements with the IETF over more than a decade. Earlier discussions of earlier IPR statements have not come to any general understanding of what Certicom claims and what they intend to do with those claims. In the absence of that understanding (which can be aided by Certicom at any time), there is no point in using the WG mailing list for guessing.

WG participants who want to read more about IPR are advised to see <https://www.ietf.org/ipr/>.

--Paul Hoffman

---

From: Matthew Campagna <[email-masked]>
Date: Mon, 13 May 2013 16:11:01 +0000

Paul et al,

   I would like to draw the groups attention to "Section VIII. Other Notes:" of the declaration https://datatracker.ietf.org/ipr/2072/.  It highlights previous declarations in regards to the referenced patent and its use in affiliated IPSec and IKE specifications.

  I personally hope that these earlier statements cover the bulk of concerns and expected uses.

Sincerely,
    Matt Campagna

Matthew Campagna - Director, Certicom Research 
BlackBerry

[email-masked]
direct          203.894.9777
office           877.746.5831x14181#
http://www.blackberry.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Friday, May 10, 2013 1:21 PM
To: IPsecme WG
Subject: Re: [IPsec] IPR Disclosure: Certicom Corporation's Statement about IPR related to draft-ietf-ipsecme-dh-checks-04

<chair-hat on>

--Paul Hoffman
_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Yoav Nir <[email-masked]>
Date: Mon, 13 May 2013 19:32:09 +0000

Hi Matthew.

Actually, that section makes it all the more puzzling. It lists 3 disclosures that relate to several RFCs, but none of those RFCs relates to Diffie-Hellman. Instead they relate to lists of algorithms, so I'm not sure how this helps cover the concerns.

Yoav

On May 13, 2013, at 7:11 PM, Matthew Campagna <[email-masked]> wrote:

> Email secured by Check Point