Subject: [IPsec] FWD from Cao Zhen \(CZ\): [Lwip] WGLC for I-D draft-ietf-lwig-ikev2-minimal-01.txt

From: Tero Kivinen <[email-masked]>
Date: Fri, 18 Oct 2013 15:15:33 +0300

My draft-ietf-lwig-ikev2-minimal-01.txt is starting WGLC in the lwig
WG, and as this is most likely interesting for people also in the
ipsecme wg you might want to go and read the document. The comments
and discussion about the draft should most likely be on the lwig
mailing list ([email-masked]). 

Subject: [Lwip] WGLC for I-D draft-ietf-lwig-ikev2-minimal-01.txt
From: "Cao Zhen \(CZ\)" <[email-masked]>
To: <[email-masked]>
Cc: [email-masked]
Date: Fri, 18 Oct 2013 11:25:17 +0800
List-Id: Lightweight IP stack <lwip.ietf.org>

hi ALL 

We received very positive support for this draft to move forward. 

This message starts a two-week WGLC for this document. If you have any comments or suggestions, please feedback within the timeline. 

And I believe Vancouver meeting is a good venue for f2f discussion if needed. 

Thanks and Best regards,
Zhen 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, October 17, 2013 8:35 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Lwip] I-D Action: draft-ietf-lwig-ikev2-minimal-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>  This draft is a work item of the Light-Weight Implementation Guidance Working Group of the
> IETF.
> 
> 	Title           : Minimal IKEv2
> 	Author(s)       : Tero Kivinen
> 	Filename        : draft-ietf-lwig-ikev2-minimal-01.txt
> 	Pages           : 44
> 	Date            : 2013-10-17
> 
> Abstract:
>    This document describes minimal version of the Internet Key Exchange
>    version 2 (IKEv2) protocol.  IKEv2 is a component of IPsec used for
>    performing mutual authentication and establishing and maintaining
>    Security Associations (SAs).  IKEv2 includes several optional
>    features, which are not needed in minimal implementations.  This
>    document describes what is required from the minimal implementation,
>    and also describes various optimizations which can be done.  The
>    protocol described here is compliant with full IKEv2 with exception
>    that this document describes mainly shared secret authentication
>    (IKEv2 requires support for certificate authentication in addition to
>    shared secret authentication).
> 
>    This document does not update or modify RFC 5996, but provides more
>    compact description of the minimal version of the protocol.  If this
>    document and RFC 5996 conflicts then RFC 5996 is the authoritative
>    description.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-lwig-ikev2-minimal
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-lwig-ikev2-minimal-01
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-ikev2-minimal-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized
> version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip

_______________________________________________
Lwip mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lwip

-- 
[email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 22 Oct 2013 17:28:50 +0400

HI Tero,

one editorial error, copied from RFC5996:

on Page 22, in the description of Next Payload, the sentence

      In the header of an Encrypted payload, the Next Payload field is set
      to the payload type of the first contained payload (instead of 0);
      conversely, the Next Payload field of the last contained payload
      is set to zero).

has extra round bracket at the end.

Regards,
Valery Smyslov.

----- Original Message ----- 
From: "Tero Kivinen" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 18, 2013 4:15 PM
Subject: [IPsec] FWD from Cao Zhen \(CZ\): [Lwip] WGLC for 
I-Ddraft-ietf-lwig-ikev2-minimal-01.txt

> mailing list ([email-masked]).

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>