Subject: [IPsec] 4301 questionnaire

From: Stephen Kent <[email-masked]>
Date: Mon, 02 Dec 2013 09:46:27 -0500

For progress to Internet Standard, we need to verify the status of 
implementations
relative to the RFCs.  Rather than Going through an exhaustive list of 
MUST and
SHOULD compliance, let's start with a simpler list, suggested by Sean.

I request that each implementer complete the following form:

*- Which of following databases does your implementation support:
	- SPD (Security Policy Database)
	- SAD (Security Association Database)
	- PAD (Peer Authorization Database)
- Which of the processing semantics does your implementation support:
	- IP Traffic:
	- ICMP:
	- Fragment:
	- Path MTU/DF

The following questions document whether interoperability has been achieved as well as other intangibles the IESG will be interested:

- What evidence do you have that your implementation can interoperate with other implementations?**
**
**  - In your opinion, are there unused features in the RFC that greatly increase implementation complexity?**
**
**  - Errata was filed against RFC 4301 and has been incorporated in**https://datatracker.ietf.org/doc/draft-kent-ipsecme-saforip-rfc4301bis/**; are any of the incorporated errata problematic for your implementation?**
**
**- Does your implementation support the updates documented in RFC 6401?

Additional information (optional):*

Thanks,

Steve

---

From: Stephen Kent <[email-masked]>
Date: Tue, 03 Dec 2013 10:52:09 -0500

Yaron pointed out that the reference to RFC 6401 was in error. The relevant
RFC is 6040 (Tunneling of Explicit Congestion Notification).

Sorry 'bout that,

Steve