Subject: [IPsec] ADVPN Use Cases & proposals

From: Brian Weis <[email-masked]>
Date: Wed, 11 Dec 2013 10:45:05 -0800

The ADVPN proposals currently state how they believe they meet the requirements of RFC 7018, but not how well they match each of the actual use cases. The minutes of the Vancouver meeting record that Steve Hanna suggested "it might be helpful to have each of proposal teams describe in more detail how their proposal would address the 3 use cases". There was some agreement (including from Sean) that this would be valuable information for the protocol starting point selection process.

Yaron & Paul, do you agree and if so can you give the authors some guidance on what you think would be most useful? E.g., have each proposal document how RFC7018's three use cases meet the 16+ RFC7108 requirements, or something else?

Thanks,
Brian

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 11 Dec 2013 18:05:17 -0800

> Yaron & Paul, do you agree and if so can you give the authors some guidance on what you think would be most useful? E.g., have each proposal document how RFC7018's three use cases meet the 16+ RFC7…

That could indeed be useful for the non-authors who are considering contributing to the current discussion. However, it feels like the authors have not been very interested in updating their docs when clarification has been asked for and given on the mailing list, so I am hesitant to stop the current discussion in order to wait for those. Personally, I don't think an author sending a message to the mailing list with their view of the matches; that feels like more advertising for the current round of questions. Yaron may have a different view.

--Paul Hoffman

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Dec 2013 21:28:18 -0500

Brian Weis <[email-masked]> wrote:
    > The ADVPN proposals currently state how they believe they meet the
    > requirements of RFC 7018, but not how well they match each of the
    > actual use cases. The minutes of the Vancouver meeting record that
    > Steve Hanna suggested "it might be helpful to have each of proposal
    > teams describe in more detail how their proposal would address the 3
    > use cases". There was some agreement (including from Sean) that this
    > would be valuable information for the protocol starting point selection
    > process.

    > Yaron & Paul, do you agree and if so can you give the authors some
    > guidance on what you think would be most useful? E.g., have each
    > proposal document how RFC7018's three use cases meet the 16+ RFC7108
    > requirements, or something else?

Yes, please revise their ID, add a compliance section or some such.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting for hire =-