Subject: Re: [IPsec] Survey for WG interest in adopting draft-mglt-ipsecme-clone-ike-sa

From: Yaron Sheffer <[email-masked]>
Date: Tue, 02 Dec 2014 23:20:33 +0200

And similarly for this draft: please speak up if you're interested in 
this document and are willing to contribute as co-author or reviewer.

Thanks,
	Yaron

On 11/25/2014 10:06 PM, Paul Hoffman wrote:
> <chair hats on>
>
> Greetings again. The "Clone IKE SA" proposal tries to optimize IKE SA setup in cases where VPN gateways have multiple interfaces and want to establish different SAs on the different interfaces without having to repeat the IKE authentication. Instead, they could clone a single IKE SA multiple times, and then move it to different interfaces using MOBIKE.
>
> If you agree with the need to standardize this usage, and believe that draft-mglt-ipsecme-clone-ike-sa is likely to be a good starting place for that standardization, and are willing to review and contribute text to the document if it is adopted by the WG, please say so on the list. This WG has a history of adopting documents but then not having enough reviewers for us to feel confident that we are making a good standard, so we need to see a reasonable number of actively interested people before we adopt the document. If it is not adopted, the authors can ask for it to be published as an RFC through individual submission or by the Independent Submissions Editor.
>
> Please reply by December 8, 2015.
>
> --Paul Hoffman and Yaron Sheffer
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 04 Dec 2014 16:14:38 -0500

Tero Kivinen <[email-masked]> wrote:
    >> > it can be used in load-sharing scenario when there are

    >> That would run into replay protection problems, just like if you copy
    >> all kernel IPsec state between machines. And I believe load sharing
    >> when properly done should be invisible to client side and not need
    >> special support.

    > Actually I tihnk the idea is to get rid of the replay protection
    > issues. In normal case if you just copy all IKE and IPsec state
    > between the servers, then you need to make sure you also copy all
    > replay data. If you clone the IKE SA, move the cloned IKE SA to new
    > IP-address (and new load sharing server in the cluster), and then
    > create the IPsec Child SAs there, then each of the replay data is only
    > located in the server you are talking to, and there is no need to move
    > replay data between the cluster members.

Given the the original document is about making multiple interfaces work,
in the degenerate case of a phone with 3G and wifi,  it seems to me that the
case where there are multiple gateways (probably with different ISPs) is just 
the degenerate case on speed/PCP.

All that is to say that it seems we should adopt this document, if this
is really a use case we care about.

    >> Throwing around private keys or computed shared secrets to multiple
    >> peers worry me.

    > Private keys do not need to be transmitted, only the SKEYSEED and
    > material generated from there needs to be transmitted (i.e. the
    > computed shared state). Doing load-sharing without the client
    > knowledge, do require exactly same material to be transmitted, but in
    > addition to that all the replay protection related material needs to
    > be transmitted also. 
 
I left this here: I think that load balancers often *do* share private keys,
and I think this protocol could reduce this need.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Daniel Migault <[email-masked]>
Date: Tue, 9 Dec 2014 12:01:32 +0100

Hi,

As a co-author of the draft I am of course supporting the draft and will
contribute to it.

BR,
Daniel

On Tue, Dec 2, 2014 at 10:20 PM, Yaron Sheffer <[email-masked]>
wrote:

> And similarly for this draft: please speak up if you're interested in this
> document and are willing to contribute as co-author or reviewer.
>
> Thanks,
>         Yaron
>
>
>> Greetings again. The "Clone IKE SA" proposal tries to optimize IKE SA
>> setup in cases where VPN gateways have multiple interfaces and want to
>> establish different SAs on the different interfaces without having to
>> repeat the IKE authentication. Instead, they could clone a single IKE SA
>> multiple times, and then move it to different interfaces using MOBIKE.
>>
>> If you agree with the need to standardize this usage, and believe that
>> draft-mglt-ipsecme-clone-ike-sa is likely to be a good starting place
>> for that standardization, and are willing to review and contribute text to
>> the document if it is adopted by the WG, please say so on the list. This WG
>> has a history of adopting documents but then not having enough reviewers
>> for us to feel confident that we are making a good standard, so we need to
>> see a reasonable number of actively interested people before we adopt the
>> document. If it is not adopted, the authors can ask for it to be published
>> as an RFC through individual submission or by the Independent Submissions
>> Editor.
>>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58