Subject: [IPsec] I-D Action: draft-ietf-ipsecme-chacha20-poly1305-03.txt

From: [email-masked]
Date: Sat, 25 Apr 2015 02:10:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IP Security Maintenance and Extensions Working Group of the IETF.

        Title           : ChaCha20, Poly1305 and their use in IKE & IPsec
        Author          : Yoav Nir
	Filename        : draft-ietf-ipsecme-chacha20-poly1305-03.txt
	Pages           : 7
	Date            : 2015-04-25

Abstract:
   This document describes the use of the ChaCha20 stream cipher along
   with the Poly1305 authenticator, combined into an AEAD algorithm for
   the Internet Key Exchange protocol (IKEv2) and for IPsec.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipsecme-chacha20-poly1305/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ipsecme-chacha20-poly1305-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-chacha20-poly1305-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yoav Nir <[email-masked]>
Date: Sat, 25 Apr 2015 12:25:00 +0300

Hi

This new version closes (I think) all the open issues. I have removed all references to GDOI as it has been pointed out that GDOI allocated sender-ID bits from the visible IV, not the invisible salt. I have replaced all places where it said “sender ID” with “Salt”. I have made the salt generated from the keymat just as it is for AES-GCM. The TLS working group has moved in a whole other direction ([1]) where they will generate a 96-bit value and XOR that with the record counter to produce the nonce. We can’t do that without revising ESP, so for this document I’ll just leave it at that.

With this I believe the document is ready for WGLC. I might want to add an appendix with an example.

Yoav

> On Apr 25, 2015, at 12:10 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Sat, 25 Apr 2015 12:27:01 +0300

Replying to myself to prevent others from sending messages to the internet-drafts and i-d-announce.

On Apr 25, 2015, at 12:25 PM, Yoav Nir <[email-masked]> wrote:

Hi

Yoav

---

From: Yoav Nir <[email-masked]>
Date: Sat, 25 Apr 2015 12:28:09 +0300

And adding the [1]…

On Apr 25, 2015, at 12:27 PM, Yoav Nir <[email-masked]> wrote:

Hi

Yoav

[1] http://www.ietf.org/mail-archive/web/tls/current/msg16122.html

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 25 Apr 2015 07:54:26 -0700

> With this I believe the document is ready for WGLC. I might want to add an appendix with an example.

As chair and shepherd: we can't start the WG Last Call on this until we have examples*s*, given the changes in the -03 to add IKEv2. Please issue a -04 soon that has an appendix with one example of use in IKEv2, and another in IPsec.

--Paul Hoffman

---

From: Yoav Nir <[email-masked]>
Date: Sat, 25 Apr 2015 20:50:41 +0300

Will do, although 4106 doesn’t have any either.

Yoav

> On Apr 25, 2015, at 5:54 PM, Paul Hoffman <[email-masked]> wrote:
>