Subject: Re: [IPsec] draft-ietf-ipsecme-chacha20-poly1305

From: Martin Willi <[email-masked]>
Date: Wed, 01 Jul 2015 09:31:50 +0200

Kathleen,

> I am getting the ballot ready for the next telechat (next week on
> Thursday).  Are there any implementations?

For the strongSwan open source project [1] I've implemented this draft,
supporting ChaCha20/Poly1305 both in IKEv2 and in our userland ESP
backend (see [2] for details). It is not mainline/released yet, but gets
merged as soon as we have the final IANA identifier.

For the Linux kernel a patchset [3] has been merged for the 4.2 release
to support the AEAD in ESP.

Kind regards
Martin

[1]https://www.strongswan.org/
[2]https://git.strongswan.org/?p=strongswan.git;a=shortlog;h=refs/heads/chapoly
[3]http://www.spinics.net/lists/linux-crypto/msg15123.html

---

From: Yoav Nir <[email-masked]>
Date: Wed, 1 Jul 2015 10:37:58 +0300

Hi, Kathleen.

The sentences in question are the ones that get modified after IANA assignment. We’ve asked for early assignment. If we get it (hint, hint, Tero) I’ll update these sentences (“… MUST use 31, the identifier assigned by IANA to …”). If not, then the RFC editor makes these edits anyway.

Although I have asked (and got) the assignment for AEAD_CHACHA20_POLY1305, I’m still not clear on what it is for. The numbers in that registry aren’t every transmitted on the wire in any protocol.

Yoav

> On Jun 30, 2015, at 4:05 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello,
> 
> I am getting the ballot ready for the next telechat (next week on Thursday).  Are there any implementations?
> 
> My other question is to see if some more text is going to be added to distinguish AEAD_CHACHA20_POLY1305 from ENCR_CHACHA20_POLY1305.  I ask because this came up in 2 reviews.  While the definitions for both are in the draft and this should be clear enough, an added sentence could do some good to explain that they are different.
> 
> Thanks.
> 
> -- 
> 
> Best regards,
> Kathleen
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Thu, 9 Jul 2015 23:25:02 +0300

> On Jul 1, 2015, at 10:31 AM, Martin Willi <[email-masked]> wrote:
> 
> Kathleen,
> 

Hi.

The latest two revisions have the final IANA number. It is 28.

Yoav