Subject: [IPsec] Call for adoption: draft-nir-ipsecme-curve25519 as a WG work item

From: "Paul Hoffman" <[email-masked]>
Date: Mon, 24 Aug 2015 15:58:41 -0700

Greetings. There was some general interest in having a standard way to 
modern elliptic curves for ephemeral key exchange. Please respond in 
this thread whether or no you think this document is a good start on 
that work, and whether or not you think the WG should have this as a 
work item.

--Paul Hoffman

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 24 Aug 2015 16:49:41 -0700

I think this would be a good feature for the WG to work on, and that this document provides a good start.

Thanks,
Tommy Pauly

> On Aug 24, 2015, at 3:58 PM, Paul Hoffman <[email-masked]> wrote:
> 
> Greetings. There was some general interest in having a standard way to modern elliptic curves for ephemeral key exchange. Please respond in this thread whether or no you think this document is a good start on that work, and whether or not you think the WG should have this as a work item.
> 
> --Paul Hoffman
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ipsec&d=BQICAg&c=eEvniauFctOgLOKGJOplqw&r=p3wIGO08_H-OJhunJTPABw&m=gT9uQhEuaKWOcKHV039CypYOlz19mz_f_1CQ4QpDt0U&s=RAO9in8Syrok4Purz0fgaBR1-MEHWdpPeB7N4l8lzrI&e=

---

From: Paul Wouters <[email-masked]>
Date: Tue, 25 Aug 2015 00:09:37 -0400 (EDT)

On Mon, 24 Aug 2015, Paul Hoffman wrote:

> Subject: [IPsec] Call for adoption: draft-nir-ipsecme-curve25519 as a WG work
>     item

Note that I tried looking at the document and pasted it into google and
oddly got:

https://tools.ietf.org/html/draft-nir-ipsecme-curve25519-00

which does NOT list that there is a -01 as well. But there is:

https://tools.ietf.org/html/draft-nir-ipsecme-curve25519-01

> Greetings. There was some general interest in having a standard way to modern 
> elliptic curves for ephemeral key exchange. Please respond in this thread 
> whether or no you think this document is a good start on that work, and 
> whether or not you think the WG should have this as a work item.

Yes I think the WG should take on this work, and this document is a good
start.

Paul

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 25 Aug 2015 14:46:30 +0300

> that work, and whether or not you think the WG should have this as a 

I think this is good start, and we should work on this in the WG. 
-- 
[email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 26 Aug 2015 09:38:33 +0300

Hi,

I support adopting this document.

Regards,
Valery Smyslov.

> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Andreas Steffen <[email-masked]>
Date: Fri, 28 Aug 2015 13:58:45 +0200

Hi Paul,

I'm in favour of adopting this document.

Best regards

Andreas Steffen

> that work, and whether or not you think the WG should have this as a
======================================================================
Andreas Steffen                         [email-masked]
strongSwan - the Open Source VPN Solution!          www.strongswan.org
Institute for Internet Technologies and Applications
University of Applied Sciences Rapperswil
CH-8640 Rapperswil (Switzerland)
===========================================================[ITA-HSR]==