Subject: [IPsec] certificate lifetimes vs SA lifetimes

From: Michael Richardson <[email-masked]>
Date: Sun, 29 Nov 2015 15:56:31 -0500

It is my belief/memory that IKEv2 implementations should NOT limit SA
(PARENT or CHILD) lifetimes based upon certificate lifetime or CRL lifetime.

Neither rfc4945 (pki4ipsec) nor rfc7296 seems to confirm or deny this.
Yet, I'm sure that this was consensus at some point.  Maybe I've mis-remembered?
What document did I miss?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: <[email-masked]>
Date: Mon, 30 Nov 2015 15:52:21 +0000

> On Nov 29, 2015, at 3:56 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

I don't remember one way or the other.  It seems perfectly logical to limit SA lifetime.  This certainly seems to be what customers expect (based on some feedback I've seen).  It's definitely a nuisance and I would be happy to have it optional ("MAY"), but prohibiting it doesn't make sense to me.

	paul

---

From: <[email-masked]>
Date: Mon, 30 Nov 2015 15:57:13 +0000

> On Nov 30, 2015, at 10:52 AM, <[email-masked]> <[email-masked]> wrote:
> 
> 

Sorry, I dropped a few words that muddle the meaning.  I meant to say "it's definitely a nuisance to implement limiting, ..."

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Tue, 1 Dec 2015 05:39:23 +0000

> From: IPsec [mailto:[email-masked]] On Behalf Of Michael
> Richardson
> 

It's listed as a requirement in 4301; section 4.4.2.1, Data Items in the SAD, which is the obvious place one should look for requirements on how IPSec/IKE interacts with PKI.

See the bullet point 'Lifetime of this SA':

      "If time is employed [as a limit on the lifetime of theSA], and if
      IKE employs X.509 certificates for SA establishment, the SA
      lifetime must be constrained by the validity intervals of the
      certificates, and the NextIssueDate of the Certificate Revocation
      Lists (CRLs) used in the IKE exchange for the SA."

Hmmm, the above implies that if the SA has a negotiated lifetime of a million years, then it is limited to the expiration of the certificate (if one was used), but if it has a technically unlimited lifetime (as far as time is concerned), then it is not.  I'm not sure what's the reasoning behind that.