Subject: [IPsec] Fw: New Version Notification for draft-smyslov-ipsecme-ikev2-compression-00.txt

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 25 Dec 2015 15:18:49 +0300

Hi,

I've posted a new draft on using compression in IKEv2.
Comments, thoughts, criticism are very very welcome.

Regards,
Valery Smyslov.

> A new version of I-D, draft-smyslov-ipsecme-ikev2-compression-00.txt
> has been successfully submitted by Valery Smyslov and posted to the
> IETF repository.
> 
> Name: draft-smyslov-ipsecme-ikev2-compression
> Revision: 00
> Title: Compression in the Internet Key Exchange Protocol Version 2 (IKEv2)
> Document date: 2015-12-25
> Group: Individual Submission
> Pages: 17
> URL:            https://www.ietf.org/internet-drafts/draft-smyslov-ipsecme-ikev2-compression-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-smyslov-ipsecme-ikev2-compression/
> Htmlized:       https://tools.ietf.org/html/draft-smyslov-ipsecme-ikev2-compression-00
> 
> 
> Abstract:
>   This document describes a method for reducing the size of IKEv2
>   messages by means of lossless compression.  Making IKEv2 messages
>   smaller is desirable for low power consumption battery powered IoT
>   devices.  It also helps avoid IP fragmentation of IKEv2 messages.
>   This document describes how compression is negotiated maintaining
>   backward compatibility and how it is used in IKEv2.
> 
>                                                                                  
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Paul Wouters <[email-masked]>
Date: Thu, 31 Dec 2015 16:58:38 -0500 (EST)

> Comments, thoughts, criticism are very very welcome.

This draft makes me nervous, as compression has been removed from
encryption specifications in the last few years. I find the security
considerations also weak on this. It basically says "if you think
compression might be security issue, don't use it". Which isn't helpful
at all to implementors.

I am also worried about the security of maliciously compressed payloads,
eg a zillion 0's, and other corner cases such as AUTH-NULL clients.

I'm also not yet very convinced about the use case. For instance, the
mentioned explosion of algorithms supported causing big IKE_INIT packets
seems very unlikely for IoT devices which most likely only support 1 or
2 algorithms anyway.

Note I'm not strongly against it. I just need more convincing.

Paul