Subject: Re: [IPsec] Textual changes to the DDoS draft

From: Yoav Nir <[email-masked]>
Date: Tue, 1 Mar 2016 12:18:16 +0200

I think SHOULD is strong enough.

> On 1 Mar 2016, at 8:07 AM, Valery Smyslov <[email-masked]> wrote:
> 
> Hi Yaron,
>  
> I also think that it's more safe to verify all 4 results (that's why it's SHOULD). 
> If nobody objects we can make it MUST for the sake of security and simplicity.
>  
> Regards,
> Valery.
>  
>> ----- Original Message ----- 
>> From: Yaron Sheffer <mailto:[email-masked]>
>> To: Valery Smyslov <mailto:[email-masked]> ; Yoav Nir <mailto:[email-masked]> ; Waltermire, David A. <mailto:[email-masked]>
>> Cc: [email-masked] <mailto:[email-masked]>
>> Sent: Friday, February 26, 2016 7:32 PM
>> Subject: Re: [IPsec] Textual changes to the DDoS draft
>> 
>> After reading the pull request, I suggest that we require the responder to verify all 4 puzzles. Although I don't have a proof why this is better (e.g. a game theoretic cost/benefit analysis), it would remove an unnecessary design decision from implementations at a trivial cost in performance.
>> 
>> Thanks,
>>     Yaron
>> 
>> On 02/25/2016 09:50 PM, Valery Smyslov wrote:
>>> That was also my impression. And the draft is already being edited to include multiple puzzles.
>>>  
>>> Valery.
>>>> ----- Original Message ----- 
>>>> From: Yoav Nir <mailto:[email-masked]>
>>>> To: Waltermire, David A. <mailto:[email-masked]>
>>>> Cc:  <mailto:[email-masked]%20WG>[email-masked] <mailto:[email-masked]> WG 
>>>> Sent: Friday, February 26, 2016 8:43 AM
>>>> Subject: Re: [IPsec] Textual changes to the DDoS draft
>>>> 
>>>> 
>>>>> On 26 Feb 2016, at 2:03 AM, Waltermire, David A. < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> I haven’t seen any additional feedback on the DDoS draft this week based on Yoav’s note about the PR [1]. It also looks like the discussion on chaining puzzles has wrapped up with no changes needed to the draft [2].
>>>> 
>>>> Oh. My impression of [2] was that Valery and I were in agreement that this change was a good idea, with Scott and Yaron supporting (not quite as enthusiastically) and with not opinions to the contrary. Valery and I thought we’d make this change over the weekend. 
>>>> 
>>>> Yoav
>>>> 
>>>> 
>>>> _______________________________________________
>>>> IPsec mailing list
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/ipsec <https://www.ietf.org/mailman/listinfo/ipsec>
>>> 
>>> 
>>> _______________________________________________
>>> IPsec mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/ipsec <https://www.ietf.org/mailman/listinfo/ipsec>
>> 
>

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 1 Mar 2016 15:34:01 +0000

It looks like the freshly posted -04 draft has this requirement as a MUST. Let's hash this out during the WGLC. If we need to make any changes we can make them all after the call concludes.

Thanks,
Dave

From: Yoav Nir [mailto:[email-masked]]
Sent: Tuesday, March 01, 2016 5:18 AM
To: Valery Smyslov <[email-masked]>
Cc: Waltermire, David A. (Fed) <[email-masked]>; Yaron Sheffer <[email-masked]>; [email-masked]
Subject: Re: [IPsec] Textual changes to the DDoS draft

On 1 Mar 2016, at 8:07 AM, Valery Smyslov <[email-masked]<mailto:[email-masked]>> wrote:

Hi Yaron,

Regards,
Valery.

----- Original Message -----
From: Yaron Sheffer<mailto:[email-masked]>
To: Valery Smyslov<mailto:[email-masked]> ; Yoav Nir<mailto:[email-masked]> ; Waltermire, David A.<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Sent: Friday, February 26, 2016 7:32 PM
Subject: Re: [IPsec] Textual changes to the DDoS draft

Thanks,
    Yaron

Valery.
----- Original Message -----
From: Yoav Nir<mailto:[email-masked]>
To: Waltermire, David A.<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]> WG
Sent: Friday, February 26, 2016 8:43 AM
Subject: Re: [IPsec] Textual changes to the DDoS draft

On 26 Feb 2016, at 2:03 AM, Waltermire, David A. <[email-masked]<mailto:[email-masked]>> wrote:

I haven't seen any additional feedback on the DDoS draft this week based on Yoav's note about the PR [1]. It also looks like the discussion on chaining puzzles has wrapped up with no changes needed to the draft [2].

Oh. My impression of [2] was that Valery and I were in agreement that this change was a good idea, with Scott and Yaron supporting (not quite as enthusiastically) and with not opinions to the contrary. Valery and I thought we'd make this change over the weekend.

Yoav

________________________________
_______________________________________________
IPsec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ipsec

IPsec mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/ipsec