Subject: Re: [IPsec] Alissa Cooper's No Objection on charter-ietf-ipsecme-10-00: (with COMMENT)

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 1 Sep 2016 11:39:21 +0200

I thought the way we usually do this, is to have milestones with a timeline and have a sentence saying: When these milestones have been reached the working group will recharter or close.

Given the planned work and the rather near-time date, I can already say that they have to extend this date which in this case means a full recharter and processing. While updating milestones can be done by the chairs.

Mirja

> Am 01.09.2016 um 03:39 schrieb Kathleen Moriarty <[email-masked]>:
> 
> On Wed, Aug 31, 2016 at 6:05 PM, Mirja Kuehlewind (IETF)
> <[email-masked]> wrote:
>> That’s actually a good point that I forgot to mention as well. Actually my question is, why is this limited needed at all?
> 
> The WG has had this in their charter for some time.  The previous
> chairs with the WG have wanted to keep a window set since this is a
> maintenance WG as a way to prevent it from living on beyond it's
> usefulness.  They believe that it's okay to shutdown the WG if it
> dwindles and would like to have ways to determine if that is
> necessary.  They are also fine with a temporary closing to then reopen
> as another follow on effort.  This is a follow on WG itself after the
> original WG responsible for IPsec had closed for a few years.
> 
>> 
>> 
>>> Am 31.08.2016 um 21:36 schrieb Alissa Cooper <[email-masked]>:
>>> 
>>> Alissa Cooper has entered the following ballot position for
>>> charter-ietf-ipsecme-10-00: No Objection
>>> 
>>> When responding, please keep the subject line intact and reply to all
>>> email addresses included in the To and CC lines. (Feel free to cut this
>>> introductory paragraph, however.)
>>> 
>>> 
>>> 
>>> The document, along with other ballot positions, can be found here:
>>> https://datatracker.ietf.org/doc/charter-ietf-ipsecme/
>>> 
>>> 
>>> 
>>> ----------------------------------------------------------------------
>>> COMMENT:
>>> ----------------------------------------------------------------------
>>> 
>>> This seems like a lot of documents for a 16-month window based on this
>>> group's past publication rate. Good to be ambitious, but I'm just
>>> wondering how realistic this is.
> 
> Yes, it's ambitious.  I'll leave that to the chairs to respond.  In
> the past they have tried to keep the date to a reasonable one to
> complete work or to close if the WG became too inactive since it's
> along-standing one.  It has gotten some new life recently, so I don't
> expect this WG to close too soon.
> 
>>> 
>>> 
>> 
> 
> 
> 
> -- 
> 
> Best regards,
> Kathleen
>

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 1 Sep 2016 12:04:13 +0100

On 01/09/16 10:39, Mirja Kuehlewind (IETF) wrote:
> I thought the way we usually do this, is to have milestones with a
> timeline and have a sentence saying: When these milestones have been
> reached the working group will recharter or close.

Yep, that is the usual approach. The ipsecme wg however have
not taken the usual approach for quite a while now and that's
also ok. As Kathleen explained they've tended to have a drop
dead date in the charter as a way to motivate folks to have made
sufficient progress by that date. I think they've come close to
closing for that reason a couple of times over the last few
years.

IIRC, that was started because there was a fear of having
loads and loads of seemingly reasonable work items, few of
which were of enough interest to be finished in a timely manner.
(I'm open to correction on that though.)

One can of course wonder if that's the best approach, but I
think it's perfectly fine that different WGs use different ways
of doing things like this. It's also fine that the IESG ask about
it of course, but we (the IESG) should also be careful to not give
the impression we're trying to shoe-horn all WGs into using the
same management techniques. (I don't think that's what's happening,
but one could get that impression maybe.)

Cheers,
S.

> 
> Given the planned work and the rather near-time date, I can already
> say that they have to extend this date which in this case means a
> full recharter and processing. While updating milestones can be done
> by the chairs.
> 
> Mirja
> 
> 
>>> That’s actually a good point that I forgot to mention as well.
>>> Actually my question is, why is this limited needed at all?
>> 
>> chairs with the WG have wanted to keep a window set since this is
>> a maintenance WG as a way to prevent it from living on beyond it's 
>> necessary.  They are also fine with a temporary closing to then
>> reopen as another follow on effort.  This is a follow on WG itself
>> after the original WG responsible for IPsec had closed for a few
>> years.
>> 
>>> 
>>> 
>>>> When responding, please keep the subject line intact and reply
>>>> to all email addresses included in the To and CC lines. (Feel
>>>> free to cut this introductory paragraph, however.)
>>>> 
>>>> 
>>>> 
>>>> The document, along with other ballot positions, can be found
>>>> here: https://datatracker.ietf.org/doc/charter-ietf-ipsecme/
>>>> 
>>>> 
>>>> 
>>>> group's past publication rate. Good to be ambitious, but I'm
>>>> just wondering how realistic this is.
>> 
>> Yes, it's ambitious.  I'll leave that to the chairs to respond.
>> In the past they have tried to keep the date to a reasonable one
>> to complete work or to close if the WG became too inactive since
>> it's along-standing one.  It has gotten some new life recently, so
>> I don't expect this WG to close too soon.
>> 
>>>> 
>>>> 
>>> 
>> 
>> 
>> 
>> --
>> 
>> Best regards, Kathleen
>> 
>

---

From: [email-masked]
Date: Thu, 1 Sep 2016 07:34:50 -0400

Sent from my iPhone

> On Sep 1, 2016, at 7:04 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> 

> (I'm open to correction on that though.)
Yes and they've also reconsidered drafts that have been accepted.  If they think an approach is not going to be feasible after more research, they've dropped the work.

> but one could get that impression maybe.)

I think this WG and SACM are my only two with a deadline and this one is from the WG themselves.

Thanks,
Kathleen

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 1 Sep 2016 14:29:37 +0200

I don’t know. I mean I don’t want to enforce a certain management strategy but in this case it seems to me they actually use the wrong tool here. Milestones with deadlines are what we have to set up some time pressure. They are often not really used by the chairs this way, but they could still say something like: if you don’t deliver in time, we’ll go ahead and request the closing of the wg no matter if you are done or not. Requiring a recharter process over and over is just additional load on the IESG with no gain. I know it’s very low load but as I said I think it’s just the wrong tool they use.

And would rather understand to use this mechanism by an AD to build up some additional pressure if that seems to be needed but having this requested by the wg/chairs I understand even less…

Mirja

> Am 01.09.2016 um 13:34 schrieb [email-masked]:
> 
> 
> 
> Sent from my iPhone
>