Subject: [IPsec] Fw: New Version Notification for draft-smyslov-ipsecme-ikev2-compact-00.txt

From: Valery Smyslov <[email-masked]>
Date: Fri, 7 Oct 2016 18:24:14 +0300

Hi all,

I've prepared a draft describing an alternate compact format for IKEv2 payloads.
Compact format will allow to reduce IKEv2 messages size, that is important
for IoT devices. It also decreases the chances that initial IKEv2 messages 
are fragmented by IP level.

Reviews and comments are very welcome.

Regards,
Valery. 

----- Original Message ----- 
From: <[email-masked]>
To: "Valery Smyslov" <[email-masked]>
Sent: Friday, October 07, 2016 6:18 PM
Subject: New Version Notification for draft-smyslov-ipsecme-ikev2-compact-00.txt

> 
> A new version of I-D, draft-smyslov-ipsecme-ikev2-compact-00.txt
> has been successfully submitted by Valery Smyslov and posted to the
> IETF repository.
> 
> Name: draft-smyslov-ipsecme-ikev2-compact
> Revision: 00
> Title: Compact Format of IKEv2 Payloads
> Document date: 2016-10-07
> Group: Individual Submission
> Pages: 24
> URL:            https://www.ietf.org/internet-drafts/draft-smyslov-ipsecme-ikev2-compact-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-smyslov-ipsecme-ikev2-compact/
> Htmlized:       https://tools.ietf.org/html/draft-smyslov-ipsecme-ikev2-compact-00
> 
> 
> Abstract:
>   This document describes a method for reducing the size of the
>   Internet Key Exchange version 2 (IKEv2) messages by using an
>   alternate format for IKE payloads.  Standard format of many IKE
>   payloads contains a lot of redundancy.  This document takes advantage
>   of this fact and specifies a way to eliminate some redundancy by
>   using more dense encoding.  Reducing size of IKEv2 messages is
>   desirable for low power consumption battery powered devices.  It also
>   helps to avoid IP fragmentation of IKEv2 messages.
> 
>                                                                                  
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 7 Oct 2016 18:26:32 +0300

Hi all,

Regards,
Valery.