Subject: Re: [IPsec] I-D Action: draft-ietf-ipsecme-eddsa-00.txt

From: Tommy Pauly <[email-masked]>
Date: Wed, 09 Nov 2016 09:51:58 -0800

Hi Yoav,

Thanks for posting this. The draft looks good, and we're eager to see this move along! If you have an implementation already supporting this, I'd be interested in testing interop.

I think the reservation of the 0 IANA hash value for the "Identity" hash makes sense; since it seems pretty straightforward, is there a possibility of getting this reserved soon?

Thanks,
Tommy

> On Oct 29, 2016, at 8:19 AM, Yoav Nir <[email-masked]> wrote:
> 
> This version is similar to draft-nir-ipsecme-eddsa-01, with the following changes:
> Updated references
> Removed the title of the Curdle draft from the text because it had become unwieldy [1]
> Updated the OIDs in appendix A and added a binary representation as in RFC 7427
> Added some text in IANA considerations
> 
> The XML source is now in https://github.com/ietf-ipsecme/drafts/blob/master/draft-ietf-ipsecme-eddsa.xml <https://github.com/ietf-ipsecme/drafts/blob/master/draft-ietf-ipsecme-eddsa.xml>
> 
> Yoav
> 
> [1] Algorithm Identifiers for Ed25519, Ed25519ph, Ed448, Ed448ph, X25519 and X448 for use in the Internet X.509 Public Key Infrastructure
> 
>> On 28 Oct 2016, at 22:54, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the IP Security Maintenance and Extensions of the IETF.
>> 
>>        Title           : Using Edwards-curve Digital Signature Algorithm (EdDSA) in the Internet Key Exchange (IKEv2)
>>        Author          : Yoav Nir
>> 	Filename        : draft-ietf-ipsecme-eddsa-00.txt
>> 	Pages           : 5
>> 	Date            : 2016-10-28
>> 
>> Abstract:
>>   This document describes the use of the Edwards-curve digital
>>   signature algorithm in the IKEv2 protocol.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-ipsecme-eddsa/ <https://datatracker.ietf.org/doc/draft-ietf-ipsecme-eddsa/>
>> 
>> There's also a htmlized version available at:
>> https://tools.ietf.org/html/draft-ietf-ipsecme-eddsa-00
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> IPsec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ipsec
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Wed, 9 Nov 2016 22:31:23 +0200

For the most part, it is up to the IETF what gets registered for our protocols at IANA.

If we want early assignment for this, it’s up to the chair, the document shepherd and the IANA expert.  It helps that all three are the same person (Tero)

But if he and we agree that it’s going to end up being zero, there’s nothing to stop anyone from implementing.

And I’m sorry but I don’t have an implementation.

Yoav

> On 9 Nov 2016, at 19:51, Tommy Pauly <[email-masked]> wrote:
> 
> Hi Yoav,
> 
>> On Oct 29, 2016, at 8:19 AM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> https://tools.ietf.org/html/draft-ietf-ipsecme-eddsa-00 <https://tools.ietf.org/html/draft-ietf-ipsecme-eddsa-00>
>>> 
>>> 
>> [email-masked] <mailto:[email-masked]>