Subject: [IPsec] [Editorial Errata Reported] RFC7296 (5247)

From: RFC Errata System <[email-masked]>
Date: Tue, 30 Jan 2018 13:50:39 -0800 (PST)

The following errata report has been submitted for RFC7296,
"Internet Key Exchange Protocol Version 2 (IKEv2)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5247

--------------------------------------
Type: Editorial
Reported by: Andrew Cagney <[email-masked]>

Section: 3.10.

Original Text
-------------
   o  Protocol ID (1 octet) - If this notification concerns an existing
      SA whose SPI is given in the SPI field, this field indicates the
      type of that SA.  For notifications concerning Child SAs, this
      field MUST contain either (2) to indicate AH or (3) to indicate
      ESP.  Of the notifications defined in this document, the SPI is
      included only with INVALID_SELECTORS, REKEY_SA, and
      CHILD_SA_NOT_FOUND.  If the SPI field is empty, this field MUST be
      sent as zero and MUST be ignored on receipt.

Corrected Text
--------------
   o  Protocol ID (1 octet) - If this notification concerns an existing
      SA whose SPI is given in the SPI field, this field indicates the
      type of that SA.  For notifications concerning Child SAs, this
      field MUST contain either (2) to indicate AH or (3) to indicate
      ESP.  Of the notifications defined in this document, the SPI is
      included only with INVALID_SELECTORS, REKEY_SA, and
      CHILD_SA_NOT_FOUND.  If the SPI field is empty, this field MUST be
      sent as zero to indicate NONE and MUST be ignored on receipt.

Notes
-----
If I assume that the 'Protocol ID' field in the notification payload is specified by:

  Internet Key Exchange Version 2 (IKEv2) Parameters
  IKEv2 Security Protocol Identifiers

then a notification is using the 'Reserved' value 0.   Since the value is being used,
I think it would be better to give it a name.  Other uses of 'Protocol ID' don't need
updating as they all explicitly list allowed values, and in no case is 0 allowed.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7296 (draft-kivinen-ipsecme-ikev2-rfc5996bis-04)
--------------------------------------
Title               : Internet Key Exchange Protocol Version 2 (IKEv2)
Publication Date    : October 2014
Author(s)           : C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen
Category            : INTERNET STANDARD
Source              : IP Security Maintenance and Extensions
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Yoav Nir <[email-masked]>
Date: Wed, 31 Jan 2018 07:04:10 +0200

Hi.

I don’t see anything wrong with the suggestion (it’s just adding “to indicate NONE” in the last sentence). However:
A value marked “Reserved” in IANA just means that IANA should not assign it. It does not mean that it cannot appear in the protocol.
Using a zero in a field to indicate no value is common, and IANA registries are inconsistent about whether such zero values are named or just reserved.
Unless we want to change the IANA registry, there is no reason to uppercase ‘none’
I don’t think we need to update the IANA registry.

“Hold for document update”?

> On 30 Jan 2018, at 23:50, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Yoav Nir <[email-masked]>
Date: Wed, 31 Jan 2018 07:07:23 +0200

Sorry. Resending with the correct To: and CC: lists

> On 31 Jan 2018, at 7:04, Yoav Nir <[email-masked]> wrote:
> 
> Hi.
> 
>> On 30 Jan 2018, at 23:50, RFC Errata System <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> http://www.rfc-editor.org/errata/eid5247 <http://www.rfc-editor.org/errata/eid5247>
>>