Subject: [IPsec] Review of draft-ietf-ipsecme-implicit-iv-00

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Thu, 22 Mar 2018 17:40:40 +0000

After reviewing this document, I think the draft looks fairly good. I found a few small issues which should be addressed in the next revision. Comments on these issues are below.

We adopted this draft at IETF 100 and I haven't seen any discussion on it since. I'd like to see more review by the working group before sending it forward to the IESG. Are there any concerns with starting a WG last call on the draft?

-- Comments

1 - There are lowercase RFC2119 keywords in teh draft that don't appear to be normative (e.g., "may" in section 5). You should use text from RFC8174 to indicate that lowercase versions of the
keywords are not normative.

Something like the following would work:

   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
   "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and
   "OPTIONAL" in this document are to be interpreted as described in BCP
   14 [RFC2119] [RFC8174] when, and only when, they appear in all
   capitals, as shown here.

5 - IIV is not spelled out on first use.

7 - "as long as certain security requirements are met" It would be useful to clarify what "certain" means here. Maybe a reference to section 2 would suffice? Or a reference to where the text in the next paragraph lands? See next comment.

7 - The second paragraph contains normative requirements in the Security Considerations. This is typically frowned upon. It might make sense to move these requirements to an earlier section (e.g., section 4).

9 - "woudl" replace with "would"

Regards,

Dave

---

From: Daniel Migault <[email-masked]>
Date: Fri, 23 Mar 2018 18:33:50 -0400

Hi David,

Thank you for the review. I believe the version 01 [1] addresses your
concerns.

Yours,
Daniel

[1]
https://tools.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-implicit-iv-01.txt

On Thu, Mar 22, 2018 at 1:40 PM, Waltermire, David A. (Fed) <
[email-masked]> wrote:

> After reviewing this document, I think the draft looks fairly good. I
> found a few small issues which should be addressed in the next revision.
> Comments on these issues are below.
>
>
> We adopted this draft at IETF 100 and I haven't seen any discussion on it
> since. I'd like to see more review by the working group before sending it
> forward to the IESG. Are there any concerns with starting a WG last call on
> the draft?
>
>
> -- Comments
>
> 1 - There are lowercase RFC2119 keywords in teh draft that don't appear to
> be normative (e.g., "may" in section 5). You should use text from RFC8174
> to indicate that lowercase versions of the
> 7 - "as long as certain security requirements are met" It would be useful
> to clarify what "certain" means here. Maybe a reference to section 2 would
> suffice? Or a reference to where the text in the next paragraph lands? See
> next comment.
>
>
> 7 - The second paragraph contains normative requirements in the Security
> Considerations. This is typically frowned upon. It might make sense to move
> these requirements to an earlier section (e.g., section 4).
>
>
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>
>