Subject: [IPsec] Call for WG Adoptation for draft-boucadair-ipsecme-ipv6-ipv4-codes

From: Tero Kivinen <[email-masked]>
Date: Sat, 13 Oct 2018 03:09:19 +0300

Our new charter has been approved and that includes item:

    RFC7296 defines a generic notification code that is related to a
    failure to handle an internal address failure. That code does not
    explicitly allow an initiator to determine why a given address
    family is not assigned, nor whether it should try using another
    address family. The Working Group will specify a set of more
    specific notification codes that will provide sufficient
    information to the IKEv2 initiator about the encountered failure.
    A possible starting pointing is
    draft-boucadair-ipsecme-ipv6-ipv4-codes.

So this email will start one week long WG adoptation call for that
document [1] for WG adoptation.

Send your comments to this list before the 2018-10-21.

[1] https://datatracker.ietf.org/doc/draft-boucadair-ipsecme-ipv6-ipv4-codes/
-- 
[email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Sat, 13 Oct 2018 16:48:08 +0300

I believe the final document should address the stuff in RFC 5739. Also, I’m not sure you need to update 7296 to add some new code points.

Neither of these is a barrier for adoption.

I have read the draft and support its adoption.

Yoav

> On 13 Oct 2018, at 3:09, Tero Kivinen <[email-masked]> wrote:
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: <[email-masked]>
Date: Mon, 15 Oct 2018 06:05:00 +0000

Hi all, 

I support adoption, obviously. 

FWIW, I have no IPR related to this draft. 

Cheers,
Med

> -----Message d'origine-----
> De : IPsec [mailto:[email-masked]] De la part de Tero Kivinen
> Envoyé : samedi 13 octobre 2018 02:09
> À : [email-masked]
> Objet : [IPsec] Call for WG Adoptation for draft-boucadair-ipsecme-ipv6-ipv4-
> codes
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 17 Oct 2018 09:59:10 +0300

Hi,

after reading the draft's introduction, I think the problem described
is real. So I support adoption of this draft.

That said, it seems that the current draft solves the problem in 
suboptimal way (too many new notifications defined), but that
can be definitely discussed in the WG. And yes, I'm ready to 
review the draft.

Regards,
Valery.

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 17 Oct 2018 06:26:35 -0700

Agreed with Valery that this is a fine starting point to define the problem, but we will need to iterate on the details. 

I do support adoption. 

Thanks,
Tommy 

> On Oct 16, 2018, at 11:59 PM, Valery Smyslov <[email-masked]> wrote:
> 
> Hi,
>

---

From: Daniel Migault <[email-masked]>
Date: Fri, 19 Oct 2018 06:28:23 -0400

+1, there seems a problem to solve, so I support the adoption.

The question I would raise are:
* Do we want to add code and update IKEv2 or do we want to define an
extension with IP46_SUPPORTED. For interoperability, the latest may be
preferred.
* Looking at the code points, I have the impression that with the current
signaling, only the case where a single af is supported could be ambiguous.
A host sending a request for IP4 and IP6 addresses, can easily deduce is
which are the supported AF, except when the a single AF is supported. In
that case maybe the IP6 should be provided with the notification ,in case
the host really wants a IP4 address.
* While 3gpp use case is sufficient, I am wondering if we have use cases
outside 3gpp where such extension is needed ?

Of course these could be discussed after adoption.

Yours,
Daniel

On Wed, Oct 17, 2018 at 9:27 AM Tommy Pauly <[email-masked]> wrote:

> Agreed with Valery that this is a fine starting point to define the
> problem, but we will need to iterate on the details.
>
> I do support adoption.
>
> Thanks,
> Tommy
>
> >> [1]
> https://datatracker.ietf.org/doc/draft-boucadair-ipsecme-ipv6-ipv4-codes/
> >> --
> >> [email-masked]
> >>