Subject: [IPsec] Rename IKE_AUX?

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 12 Nov 2018 17:07:19 +0300

Hi,

I'm going to update IKE_AUX draft (in particular - change the way 
it is authenticated based on recent discussion with Scott).

I recall that there were some complaints that the name IKE_AUX
is not good because it can easily be mixed up with IKE_AUTH
Actually, the phonetically close name was selected intentionally 
to show that these exchanges are related. However, I'm not a native
speaker and not always can realize how good or bad this similarity
sounds for a native ear. 

So, my question to WG - do we need to change the name? If yes,
then to what? Possible variants - IKE_INT (intermediate), IKE_PRE_AUTH. 
Something else?

Regards,
Valery.

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 12 Nov 2018 13:14:23 -0800

I agree that IKE_AUX can be easily confused with IKE_AUTH. Similarly, IKE_INT looks a lot like the INIT from IKE_SA_INIT.

I don't necessarily love IKE_PRE_AUTH, but it still seems preferable to the other options. You could also spell out "intermediate" to have IKE_INTERMEDIATE. This is still shorter than other existing exchange types, like IKE_SESSION_RESUME.

Thanks,
Tommy

> On Nov 12, 2018, at 6:07 AM, Valery Smyslov <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: CJ Tjhai <[email-masked]>
Date: Mon, 12 Nov 2018 21:28:55 +0000

How about IKE_SUP or IKE_SUPP (for IKE_SUPPLEMENTARY)?

---

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 13 Nov 2018 04:59:26 +0000

I think IKE_SUPP is better compare to what have mentioned 

-----Original Message-----
From: IPsec <[email-masked]> On Behalf Of CJ Tjhai
Sent: Monday, November 12, 2018 1:29 PM
To: [email-masked]
Cc: [email-masked]; Valery Smyslov <[email-masked]>
Subject: Re: [IPsec] Rename IKE_AUX?

How about IKE_SUP or IKE_SUPP (for IKE_SUPPLEMENTARY)?
On Mon, 12 Nov 2018 at 21:14, Tommy Pauly <[email-masked]> wrote:
> > I'm going to update IKE_AUX draft (in particular - change the way it 
> > is authenticated based on recent discussion with Scott).
> >
> > I recall that there were some complaints that the name IKE_AUX is 
> > not good because it can easily be mixed up with IKE_AUTH Actually, 
> > the phonetically close name was selected intentionally to show that 
> > these exchanges are related. However, I'm not a native speaker and 
> > not always can realize how good or bad this similarity sounds for a 
> > native ear.
> >
> > So, my question to WG - do we need to change the name? If yes, then 
> > to what? Possible variants - IKE_INT (intermediate), IKE_PRE_AUTH.
> > Something else?
> >
> > Regards,
> > Valery.
> >

---

From: Paul Wouters <[email-masked]>
Date: Tue, 13 Nov 2018 00:19:50 -0500 (EST)

Some other bike shed colours

IKE_INIT_C - Init Continued
IKE_INIT2
IKE_BE - Blob Exchange, Bulk Exchange
IKE_LARGE
IKE_BULK
IKE_BIG_KE
IKE_LARGE_KE

I think IKE_SA_INIT is misnamed and should have been IKE_INIT,
or IKE_AUTH should have been IKE_SA_AUTH :)

I don't like IKE_CONT[INUE] because it might imply something after
IKE is done. Similarly for IKE_SUPP is is midleading that it might
be something in supplement of IKE. The same is true for IKE_AUX.

But I don't care that much, just pick one. I don't object strongly to
any name mentioned so far. I rather see people reading the whole
draft carefully :)

Paul