Subject: [IPsec] I-D Action: draft-ietf-ipsecme-ikev2-intermediate-00.txt

From: [email-masked]
Date: Sun, 02 Jun 2019 15:07:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Security Maintenance and Extensions WG of the IETF.

        Title           : Intermediate Exchange in the IKEv2 Protocol
        Author          : Valery Smyslov
	Filename        : draft-ietf-ipsecme-ikev2-intermediate-00.txt
	Pages           : 10
	Date            : 2019-05-30

Abstract:
   This documents defines a new exchange, called Intermediate Exchange,
   for the Internet Key Exchange protocol Version 2 (IKEv2).  This
   exchange can be used for transferring large amount of data in the
   process of IKEv2 Security Association (SA) establishment.
   Introducing Intermediate Exchange allows re-using existing IKE
   Fragmentation mechanism, that helps to avoid IP fragmentation of
   large IKE messages, but cannot be used in the initial IKEv2 exchange.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipsecme-ikev2-intermediate/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ipsecme-ikev2-intermediate-00
https://datatracker.ietf.org/doc/html/draft-ietf-ipsecme-ikev2-intermediate-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 3 Jun 2019 08:01:12 +0300

Hi,

I've published a new version of ikev2-aux draft, which is now called ikev2-intermediate.
There are few changes compared to previous version - the exchange is renamed (again)
to IKE_INTERMEDIATE and the introduction text is changed to make more explicit
that QSKE is not the only intended applycation for the exchange. There are also
some clarifications and text improvements.

Reviews and comments are appreciated, the document is stable for quite a long period of time.

Regards,
Valery.

-----Original Message----- 
From: [email-masked]
Date: 3 июня 2019 г. 1:07
To: [email-masked]
Cc: [email-masked]
Subject: [IPsec] I-D Action: draft-ietf-ipsecme-ikev2-intermediate-00.txt

Abstract:

_______________________________________________
IPsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Michael Richardson <[email-masked]>
Date: Mon, 03 Jun 2019 10:38:30 -0400

> to IKE_INTERMEDIATE and the introduction text is changed to make more

I'm not super enthusiastic about IKE_INTERMEDIATE, but I sure prefer it to
aux!  Thank you for the change.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 3 Jun 2019 22:02:00 +0300

Hi Michael,

this name was suggested by Paul Wouters at the last IETF.
If you have better name in mind, please come out with it :-)

Regards,
Valery.

>     > I've published a new version of ikev2-aux draft, which is now called
ikev2-
> intermediate.
>     > to IKE_INTERMEDIATE and the introduction text is changed to make
more
>     > explicit
> Michael Richardson <[email-masked]>, Sandelman Software Works  -
> = IPv6 IoT consulting =-
> 
>