Subject: [IPsec] Adoption call for draft-hopps-ipsecme-iptfs

From: Tero Kivinen <[email-masked]>
Date: Sat, 26 Oct 2019 18:17:16 +0300

So this is fast (one week) adoption call for the
draft-hopps-ipsecme-iptfs draft to be accepted to the WG document. We
did have quite positive feedback in last IETF meeting and the charter
item is being worked on in parallel to this call.

If you support adopting this document as WG document and as a starting
place for the charter item proposed for the WG, then send email
indicating your support to the [email-masked] mailing-list. If you
have any comments or reservations send them to list too.

This adoption call finishes at 2019-11-04.

----------------------------------------------------------------------
The demand for Traffic Flow Confidentiality has been increasing in the user
community; however, the current method defined in RFC4303 (i.e., add null
padding to each ESP payload) is very inefficient in it's use of network
resources. The working group will develop an alternative TFC solution that
provides for efficient use of network resources.
-- 
[email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Sun, 27 Oct 2019 08:39:54 +0300

Hi,

I've read the draft and I think it addresses an important problem.
So, I support adoption of the draft as a starting point
( I think the draft has some issues that can be addressed 
in WG).

Regards,
Valery.

> -----Original Message-----
> From: IPsec <[email-masked]> On Behalf Of Tero Kivinen
> Sent: Saturday, October 26, 2019 6:17 PM
> To: [email-masked]
> Subject: [IPsec] Adoption call for draft-hopps-ipsecme-iptfs
> 
> So this is fast (one week) adoption call for the draft-hopps-ipsecme-iptfs
draft
> to be accepted to the WG document. We did have quite positive feedback in
> last IETF meeting and the charter item is being worked on in parallel to
this call.
> If you support adopting this document as WG document and as a starting
place
> for the charter item proposed for the WG, then send email indicating your
> support to the [email-masked] mailing-list. If you have any comments or
> reservations send them to list too.
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Lou Berger <[email-masked]>
Date: Sun, 27 Oct 2019 10:05:45 -0400

Hi,

I support adoption and the charter addition.  (No surprise as I'm a 
contributor to this work.)

Also, I know of no IPR that applies to this draft.

Lou

---

From: Christian Hopps <[email-masked]>
Date: Sun, 27 Oct 2019 14:32:00 -0400

As author, I know of no IPR that applies to this draft, and support its adoption by the WG.

Thanks,
Chris.

> On Oct 26, 2019, at 11:17 AM, Tero Kivinen <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 28 Oct 2019 10:30:28 -0400

I have read the document in a few iterations.
I think that it addresses an important need both for resistance to traffic
analysis, but also it has the potential to deal with the PMTU problems that
tunnels always seem to create.

Please adopt!

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 28 Oct 2019 09:44:18 -0700

I've read the document and think this is good problem area to work on, and this document is a good starting place to adopt.

Going forward, I would like to see more discussion and review of the use IP fragmentation (how often is that really needed, and is it worth the concerns stated in https://tools.ietf.org/html/draft-ietf-intarea-frag-fragile-17), as well as the use of Congestion Control (considerations for how having multiple layers of CC works, and if we can make sure that the format of the payload is aligned with current work in QUIC, etc).

Thanks,
Tommy

> On Oct 26, 2019, at 8:17 AM, Tero Kivinen <[email-masked]> wrote:
>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 28 Oct 2019 20:56:02 +0200

I have read the -01 version of this draft.  I believe it addresses a useful use case and that the solution presented there is a good starting point.

I support its adoption.

Yoav

> On 26 Oct 2019, at 18:17, Tero Kivinen <[email-masked]> wrote:
>

---

From: Paul Wouters <[email-masked]>
Date: Tue, 29 Oct 2019 19:11:52 -0400 (EDT)

> item is being worked on in parallel to this call.

I'm in favour of adopting this document to work on in the WG.

I'm very nervous about the current document's requirement of a new IP
protocol number, and would hope the WG can find a way to avoid that.

Paul