Subject: [IPsec] FW: I-D Action: draft-kampati-ipsecme-ikev2-sa-ts-payloads-opt-02.txt

From: "Panwei (William)" <[email-masked]>
Date: Tue, 5 Nov 2019 02:10:33 +0000

Hi,

I've updated the IKEv2 rekeying optimization draft.
In the new version, IKE SAs rekeying optimization is optional now. It's up to the implementer to optimize the IKE SAs rekeying or not.
And the optimization processes are also simplified to two cases (before was three cases):
- The initiator sends the optimized rekeying request message, the responder accepts it and replies the optimized rekeying response message.
- The initiator sends the optimized rekeying request message, the responder refuses it and replies NO_PROPOASL_CHOSEN.

Review and comments are more than welcome.

Regards & Thanks!
潘伟 Wei Pan
华为技术有限公司 Huawe Technologies Co., Ltd.

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Monday, November 4, 2019 5:57 PM
> To: [email-masked]
> Subject: I-D Action: draft-kampati-ipsecme-ikev2-sa-ts-payloads-opt-02.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : IKEv2 Optional SA&TS Payloads in Child
> Exchange
>         Authors         : Sandeep Kampati
>                           Meduri S S Bharath
>                           Wei Pan
> 	Filename        :
> draft-kampati-ipsecme-ikev2-sa-ts-payloads-opt-02.txt
> 	Pages           : 12
> 	Date            : 2019-11-04
> 
> Abstract:
>    This document describes a method for reducing the size of the
>    Internet Key Exchange version 2 (IKEv2) exchanges at time of rekeying
>    IKE SAs and Child SAs by removing or making optional of SA & TS
>    payloads.  Reducing size of IKEv2 exchanges is desirable for low
>    power consumption battery powered devices.  It also helps to avoid IP
>    fragmentation of IKEv2 messages.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-kampati-ipsecme-ikev2-sa-ts-payloa
> ds-opt/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-kampati-ipsecme-ikev2-sa-ts-payloads-opt
> -02
> https://datatracker.ietf.org/doc/html/draft-kampati-ipsecme-ikev2-sa-ts-p
> ayloads-opt-02
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-kampati-ipsecme-ikev2-sa-ts-paylo
> ads-opt-02
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Paul Wouters <[email-masked]>
Date: Mon, 4 Nov 2019 22:50:12 -0500 (EST)

> - The initiator sends the optimized rekeying request message, the responder refuses it and replies NO_PROPOASL_CHOSEN.

Great! I will read it and maybe try to implement this during the
hackathon.

Paul