Subject: [IPsec] Adoption call for draft-tjhai-ipsecme-hybrid-qske-ikev2

From: Tero Kivinen <[email-masked]>
Date: Mon, 4 Nov 2019 00:42:07 +0200

This is adoption call for the draft-tjhai-ipsecme-hybrid-qske-ikev2
draft to be accepted to be WG Document. This draft has been around for
some time, and we have been discussing it in the meetings.

If you support adopting this document as WG Document, then send email
indicating your support to the [email-masked] mailing-list. If you
have any comments or reservations send them to the list too.

This adoption call finishes 2019-11-11.
-- 
[email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 4 Nov 2019 14:39:47 +0300

Hi,

I support adoption of this draft (not a surprise, I'm a co-author).
I think the draft is of interest from various vendors and I know
that some vendors have already implemented it (or one of its earlier
versions),
so making it a WG document will help achieve interoperability.

Regards,
Valery.

> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: "Graham Bartlett (grbartle)" <[email-masked]>
Date: Mon, 4 Nov 2019 12:45:40 +0000

Hi

Like Valery, I'm a co-author and support adoption.

I have seen a lot of customer interest in this draft as it will allow organisations to implement standard based PQC at scale. One main driver being reduction of business risk.

This will provide users of IKEv2 to protect themselves when migrating to a PQ world.

cheers

On 04/11/2019, 11:40, "IPsec on behalf of Valery Smyslov" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Regards,
    Valery.

---

From: Paul Wouters <[email-masked]>
Date: Mon, 4 Nov 2019 09:42:24 -0500 (EST)

> This will provide users of IKEv2 to protect themselves when migrating to a PQ world.

Agreed, please adopt. And libreswan plans to implement this.

Paul

---

From: CJ Tjhai <[email-masked]>
Date: Mon, 4 Nov 2019 22:29:37 +0100

Not sure my vote as a co-author will count, but I also support the adoption.

There are interests in the community on this and I believe there is an
interoperability test based on the current version of the draft.

CJ

> On 4 Nov 2019, at 14:42, Paul Wouters <[email-masked]> wrote:
>

-- 

PQ Solutions Limited (trading as ‘Post-Quantum’) is a private limited 
company incorporated in England and Wales with registered number 06808505.

This email is meant only for the intended recipient. If you have received 
this email in error, any review, use, dissemination, distribution, or 
copying of this email is strictly prohibited. Please notify us immediately 
of the error by return email and please delete this message from your 
system. Thank you in advance for your cooperation.

For more information 
about Post-Quantum, please visit www.post-quantum.com 
<http://www.post-quantum.com>.

In the course of our business relationship, 
we may collect, store and transfer information about you. Please see our 
privacy notice at www.post-quantum.com/privacy-notice 
<http://www.post-quantum.com/privacy-notice> to learn about how we use this 
information.

---

From: "Guggemos, Tobias" <[email-masked]>
Date: Tue, 5 Nov 2019 12:03:21 +0000

Hey,
I also strongly support adoption.

>   It is an open question whether or not it is feasible to build a
>   Quantum Computer (and if so, when one might be implemented), but if
>
> Feasibility of some quantum computer is becoming much less of an open 
> question; perhaps we want some qualifiers about efficiency, scale, 
> and/or general-purpose-nature.
> Do we have a reference for this "it is believed", or is it just the 
> outcome of the WG discussions?

Regarding this discussion (and sorry if this was discussed before and I didn't realize).
Do we really need the term post-quantum in the title (and maybe even in the abstract)?
The draft tells how to do multiple/hybrid key-exchanges in IKEv2, PQ is the major motivation but not the only use case.
As far as I'm familiar with the draft, you could easily do DH + ECDH with it (and if not I'd really like it be like that).

Regards
Tobias

> -----Ursprüngliche Nachricht-----
> Von: IPsec <[email-masked]> Im Auftrag von Tero Kivinen
> Gesendet: Sonntag, 3. November 2019 23:42
> An: [email-masked]
> Betreff: [IPsec] Adoption call for draft-tjhai-ipsecme-hybrid-qske-ikev2
> 
> indicating your support to the [email-masked] mailing-list. If you have any
> comments or reservations send them to the list too.
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 5 Nov 2019 15:09:02 +0300

Hi Tobias,

> As far as I'm familiar with the draft, you could easily do DH + ECDH with it (and if not I'd really like it be like

The title is inherited from the early versions of the draft :-)
I agree that in the current form the draft is far less restrictive
in combining KE methods and the title could (and I think should)
be modified to reflect this.

Regards,
Valery.

---

From: "Bruckert, Leonie" <[email-masked]>
Date: Fri, 8 Nov 2019 10:09:27 +0000

We think that it's very important to add post quantum key exchange to IKEv2 and therefore strongly support adoption. However, there are still some things that could be improved further, e.g.  transmission of pq keys/cipher texts for Child SAs.

BTW, we performed an interop test. Valery will present the results at the upcoming meeting.

Regards
Leonie

> The draft tells how to do multiple/hybrid key-exchanges in IKEv2, PQ is the
> major motivation but not the only use case.