Subject: [IPsec] Clarifications and Implementation Guidelines for using TCP Encapsulation in IKEv2 draft

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 28 Apr 2020 12:54:49 +0300

Hi,

a one and half year ago at IETF 103 in Bangkok I presented
draft-smyslov-ipsecme-tcp-guidelines
"Clarifications and Implementation Guidelines for using TCP Encapsulation in
IKEv2"
(https://datatracker.ietf.org/doc/draft-smyslov-ipsecme-tcp-guidelines/).
>From my recollection of the meeting and from minutes it was a general
feeling in the room that 
this document was useful for implementers, since it clarified some subtle
issues
that were not covered in RFC 8229. However, at that time no adoption call
was issued since this work would require to update the IPSECME charter.
It took over a year to adopt the updated charter and now the WG
is chartered for this work with this draft as a possible starting point.
The text in the charter:

	RFC8229, published in 2017, specifies how to encapsulate 
	IKEv2 and ESP traffic in TCP. Implementation experience has 
	revealed that not all situations are covered in RFC8229, and that
may 
	lead to interoperability problems or to suboptimal performance. The
WG 
	will provide a document to give implementors more guidance about how
to use 
	reliable stream transport in IKEv2 and clarify some issues that have
been 
	discovered.

However, since it was so long since the WG last discussed the draft, the
chairs asked me to 
send a message to the list to determine whether there is still an interest 
in the WG to proceed with this work with this draft as a starting point. 

Regards,
Valery.

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 29 Apr 2020 06:52:39 -0700

Hi Valery,

Thanks for bringing this up again. Would you be interested in making this an RFC8229bis instead? I think it would be most useful for an implementer to fold some of these clarifications into the main text itself. How do you feel about that?

Best,
Tommy

> On Apr 28, 2020, at 2:54 AM, Valery Smyslov <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Paul Wouters <[email-masked]>
Date: Wed, 29 Apr 2020 10:47:05 -0400 (EDT)

> Thanks for bringing this up again. Would you be interested in making this an RFC8229bis instead? I think it would be most useful for an implementer to fold some of these clarifications into the mai…

That might be better. We have also been working on the Linux and
libreswan code for this, and have also gotten into a few corner
cases that might be good to explain the implementors.

Paul

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 29 Apr 2020 18:42:18 +0300

Hi Tommy,

> Hi Valery,
> 
> Thanks for bringing this up again. Would you be interested in making this
an
> RFC8229bis instead? I think it would be most useful for an implementer to
fold
> some of these clarifications into the main text itself. How do you feel
about
> that?

I'd be happy to do it. I also think that a -bis document is more useful.
The reason that this draft is not a rfc8229bis is that one and half
year ago it was a general feeling that more experience need to be
collected before -bis document should be issued. Now it is almost
3 years since rfc8229 is published, I agree that it's probably time to start
preparing -bis.

One concern is the current WG charter - 
it seems to me that it only allows
clarification document and not a -bis.
It is a question to our chairs and AD - are
we allowed to proceed with rfc8229bis document
with the current charter text or should we update it
and ask for re-chartering?

Regards,
Valery.

> > "Clarifications and Implementation Guidelines for using TCP
> > Encapsulation in IKEv2"
> >
> > this document was useful for implementers, since it clarified some
> > subtle issues that were not covered in RFC 8229. However, at that time
> > no adoption call was issued since this work would require to update
> > the IPSECME charter.
> > It took over a year to adopt the updated charter and now the WG is
> > chartered for this work with this draft as a possible starting point.
> > The text in the charter:
> >
may
> > However, since it was so long since the WG last discussed the draft,
> > the chairs asked me to send a message to the list to determine whether
> > there is still an interest in the WG to proceed with this work with
> > this draft as a starting point.
> >
> > Regards,
> > Valery.
> >
> >
> >

---

From: Yoav Nir <[email-masked]>
Date: Wed, 29 Apr 2020 22:54:26 +0300

[With chair hat on]

Yes, the charter says that we are to make a guidance document. If the working group feels that it’s better to put the specification and guidance in a single document, we can work on that and clear it with the ADs. 

Charters can be modified.

Yoav

> On 29 Apr 2020, at 18:42, Valery Smyslov <[email-masked]> wrote:
> 
> Hi Tommy,
> 
>> Hi Valery,
>>