Subject: [IPsec] terminology check: "modern IPsec protocol suite"

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 8 Apr 2020 15:10:32 -0700

Hi all,

draft-ietf-taps-transport-security is currently in IESG evaluation, and in
its description of IKEv2 with ESP it asserts that "IKEv2 [RFC7296] and ESP
[RFC4303] together form the modern IPsec protocol suite that encrypts and
authenticates IP packets, either for creating tunnels (tunnel-mode) or for
direct transport connections (transport-mode)."
(https://tools.ietf.org/html/draft-ietf-taps-transport-security-11#section-3.4.1).
I don't think I see a problem with that description, but wanted to run it
by the WG for a quick sanity check before the document gets approved, in
case there's something I'm forgetting.

Thanks,

Ben

---

From: Paul Wouters <[email-masked]>
Date: Wed, 8 Apr 2020 19:09:22 -0400

> case there's something I'm forgetting.

Looks correct and appropriate to me.

Paul

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 Apr 2020 20:11:53 -0400

> Looks correct and appropriate to me.

I also agree.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 9 Apr 2020 09:02:12 +0300

Hi,

> Looks correct and appropriate to me.

I concur. 

However, I'd suggest changing the title of the section from "IKEv2 with ESP" to "IPsec".

Regards,
Valery.

> Paul
> 
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 9 Apr 2020 15:42:11 -0700

> However, I'd suggest changing the title of the section from "IKEv2 with ESP" to "IPsec".

Thanks everyone for the quick review!

I will pass the title suggestion on to the authors.

-Ben

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 10 Apr 2020 00:46:40 +0200

Does IPsec not also include AH as an option still ?

---

From: Paul Wouters <[email-masked]>
Date: Thu, 9 Apr 2020 19:07:00 -0400

L
> On Apr 9, 2020, at 18:56, Toerless Eckert <[email-masked]> wrote:
> 

We don’t mention the Protocol That Shall Not Be Named, and recommend ESP-NULL instead.

Paul

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 10 Apr 2020 02:02:43 +0200

Haha. So you have to choose whether you want a title that a Muggle understand or not ;-)

Cheers
   Toerless

On Thu, Apr 09, 2020 at 07:07:00PM -0400, Paul Wouters wrote:
> > ???Does IPsec not also include AH as an option still ?
> 
> We don???t mention the Protocol That Shall Not Be Named, and recommend ESP-NULL instead.
> 
> Paul

-- 
---
[email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 10 Apr 2020 08:46:32 +0300

Hi Toerless,

> Does IPsec not also include AH as an option still ?

AH is still formally a part of IPsec, but it is next to extinct in real
life.
I see no ambiguity in renaming the section, since the text clearly says
that IKEv2+ESP is a "modern IPsec protocol suite", which is right.

Regards,
Valery.

> > > > its description of IKEv2 with ESP it asserts that "IKEv2 [RFC7296]
and
> ESP
> > > > [RFC4303] together form the modern IPsec protocol suite that
encrypts
> > > and
> > > > authenticates IP packets, either for creating tunnels (tunnel-mode)
or
> for
> > > > (https://tools.ietf.org/html/draft-ietf-taps-transport-security-
> 11#section-
> > > 3.4.1).
> > > > by the WG for a quick sanity check before the document gets
approved,
> in